Comment définir une adresse IP statique?

23

J'ai configuré la carte réseau de l'invité Ubuntu pour qu'elle fonctionne en mode ponté afin que je puisse y accéder depuis l'ordinateur hôte.

Le problème est que l'adresse IP Ubuntu de l'invité continue à changer.

Même si cela change dans un intervalle très court, 192.168.0.4-10, il faut encore du temps pour configurer Putty et les autres programmes à chaque fois.

Existe-t-il un moyen de rendre l’adresse IP Ubuntu de l’invité statique?

Mon système d’exploitation invité a l’interface graphique complète.

    
posée Mitten 28.08.2013 - 17:27
la source

7 réponses

28

Donner une adresse IP statique graphiquement

1.Aller à network connections

2.Ensuite, modifiez les connexions dans les paramètres câblés

3.Ajouter l'adresse IP du système

Voici les images ci-dessous

Si vous êtes curieux, vous pouvez trouver la connexion nouvellement créée à partir des étapes ci-dessus en tant que fichier de configuration à /etc/NetworkManager/system-connections

    
réponse donnée Tarun 29.08.2013 - 14:01
la source
21

Modifiez /etc/network/interfaces pour refléter quelque chose comme ceci:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.0.X
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.X
dns-nameservers 192.168.0.X

Alors faites un:

sudo /etc/init.d/networking restart

Et cela va vous aider à régler le problème.

    
réponse donnée Brian Harrington 29.08.2013 - 13:59
la source
10

OP publié:

  

Définition de l'adresse IP statique

sudo nano /etc/network/interfaces #  I use vi instead of nano
     

Lorsque vous ouvrez le document d'interface, vous verrez quelque chose comme ceci:

auto lo eth0
iface lo inet loopback
iface eth0 inet dynamic
     

Vous souhaitez le modifier pour intégrer les éléments suivants:

auto lo eth0
iface lo inet loopback
iface eth0 inet static
        address xxx.xxx.xxx.xxx (enter your ip here)
        netmask xxx.xxx.xxx.xxx (mine was 255.255.255.0)
        gateway xxx.xxx.xxx.xxx (enter gateway ip here,usually the address of the router)
     

Enregistrez vos modifications et quittez.

     

Ensuite, je devais ajouter des informations sur DNS à resolv.conf , alors j'ai ouvert la   fichier comme ça:

sudo nano /etc/resolv.conf # I use vi instead of nano
     

Initialement, ce fichier est vide, sauf un avertissement de "Ne pas mettre   rien ici ne sera écrasé ". J'ai ajouté le texte suivant   information néanmoins.

     

Voici le format:

nameserver xxx.xxx.xxx.xxx(enter your dns server ip)
nameserver xxx.xxx.xxx.xxx(enter your alt dns server ip)
     

C'est ce que je suis entré:

nameserver 8.8.8.8 
nameserver 8.8.4.4
     

Enregistrez vos modifications et quittez.

     

À ce stade, vous pouvez soit redémarrer le réseau:

sudo /etc/init.d/networking restart  
     

ou redémarrer ce que j'ai fait:

sudo reboot
     

Une fois que je suis connecté à nouveau, j'ai réessayé l'installation de pure-ftpd et   tout va bien:

apt-get install pure-ftpd
     

J'espère que cela aide quelqu'un, j'ai cherché le correctif et juste   est arrivé par accident.

    
réponse donnée Radu Rădeanu 07.09.2013 - 22:38
la source
1

Il semble que l’interface eth0 ait été configurée auparavant et l’adresse a été conservée de manière persistante (pour une raison quelconque) par le noyau.

Pour effacer toutes les adresses de l'interface eth0 sans avoir à redémarrer les services réseau ou à mettre l'interface haut / bas:

sudo ip addr flush dev eth0

Ensuite, vous pouvez utiliser ifup pour configurer eth0 en lisant le fichier /etc/network/interfaces :

sudo ifup eth0

Pour la verbosité:

sudo ifup -v eth0
    
réponse donnée venky 27.06.2016 - 19:57
la source
0

La seule chose qui a fonctionné pour moi était:

  • entrer dans la configuration du modem ( http://192.168.0.1 )
  • configurez le bail de réservation DHCP: il associe les adresses IP LAN aux adresses MAC
  • configurez l'interface pour utiliser DHCP (valeur par défaut, modifiable sur NetworkManager à nm-connection-editor )
la source
0

==== Configurer l’IP statique sur Ubuntu 14.04

dans le fichier / etc / network / interfaces

iface eth0 inet static
address 10.193.36.29
netmask 255.255.255.0
gateway 10.193.36.1
dns-nameservers 10.124.31.140  10.213.134.41  10.72.255.100

alors:

sudo ifup eth0

besoin de temps pour prendre effet

    
réponse donnée Bruce 15.11.2016 - 17:55
la source
0

Sous Ubuntu 18.04, LTS Netplan est disponible et remplace ifupdown par défaut. Disons que notre interface est ens192 . Pour vérifier si elle est gérée par NetworkManager:

cat /run/NetworkManager/conf.d/netplan.conf

Qui pourrait sortir ceci:

[keyfile]
# devices managed by networkd
unmanaged-devices+=interface-name:ens192,

Sauvegardez le fichier de configuration (votre chemin ou fichier peut être différent):

cp /etc/netplan/01-netcfg.yaml /etc/netplan/01-netcfg.yaml.ori

Puis éditez /etc/netplan/01-netcfg.yaml pour ressembler à:

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  ethernets:
    ens192:
      dhcp4: false
      wakeonlan: true
      addresses:
        - 192.168.14.2/24
      gateway4: 192.168.14.1
      nameservers:
        addresses: [8.8.8.8]

Générez le fichier de sortie avec debug pour plus de détails:

sudo netplan --debug generate

Nous aimerions voir:

DEBUG:command generate: running ['/lib/netplan/generate']
** (generate:9991): DEBUG: 18:08:30.447: Processing input file //etc/netplan/01-netcfg.yaml..
** (generate:9991): DEBUG: 18:08:30.447: starting new processing pass
** (generate:9991): DEBUG: 18:08:30.448: ens192: setting default backend to 1
** (generate:9991): DEBUG: 18:08:30.448: Generating output files..
** (generate:9991): DEBUG: 18:08:30.449: NetworkManager: definition ens192 is not for us (backend 1)

Nous pouvons voir la configuration actuelle avec:

cat /run/systemd/network/10-netplan-ens192.network

Rendons-le actif par:

sudo systemctl restart systemd-networkd

Soyez prêt à perdre la connexion si vous le faites via SSH. Ne man netplan pour plus de détails. Il existe également une réponse associée sur ce site.

    
réponse donnée Nagev 09.07.2018 - 19:35
la source

Lire d'autres questions sur les étiquettes