Scintillement gênant dans 16.04 LTS - Chrome

194

Je suis passé de la version 4.4.0 à la version 4.4.8, puis à la version 4.5.2 sur Ubuntu 16.04 LTS 64 bits, et cela se produit toujours.

A 4.5.2, c'est encore plus fréquent, et principalement dans Chrome (je n'ai pas encore essayé Firefox ou Opéra). Chaque fois que j'ouvre une nouvelle page Web. Un moyen de résoudre ce problème, ou est-ce un bogue?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Cheers.

    
posée Mookey 03.05.2016 - 08:31
la source

11 réponses

184

Après quelques recherches, j'ai trouvé une solution à ce problème. Cela fonctionne pour moi maintenant.

J'ai désactivé l'accélération matérielle de mon navigateur depuis

Settings > Advance Settings > System > uncheck the hardware acceleration

J'espère que cela fonctionne sur votre machine.

J'utilise google-chrome-stable Version 50.0.2661.94 (64-bit) on Ubuntu 16.04

----- EDIT ----

Si vous rencontrez un retard de défilement et une déchirure de l'écran. Faites comme suggéré par Amos Folarin dans le commentaire ci-dessous:

Allez à: chrome://flags/#smooth-scrolling et activez-le.

    
réponse donnée sgiri 05.05.2016 - 19:54
la source
158

J'ai eu le même problème, il semble que le paramétrage de la rasterisation GPU sur "Activé pour toutes les couches" fonctionne enfin:

    
réponse donnée Gondy 08.08.2016 - 09:52
la source
38

Ouvrez un terminal et entrez cette commande:

sudo nano /usr/share/applications/chromium-browser.desktop

et défilez jusqu’à ce que vous arriviez à cette ligne:

Exec= chromium-browser

Puis ajoutez ces deux paramètres

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Appuyez sur Ctrl + O pour enregistrer et Ctrl + X pour quitter.

Puis entrez cette commande:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

et ajoutez ces lignes

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Appuyez sur Ctrl + O puis Ctrl + X.

Ouvrez Chromium et écrivez dans la barre d'adresse: chrome://flags/ et entrez.

  • Activer-zero-copy
  • Activer la liste de rendu des logiciels
  • Activer le canevas de la liste d'affichage 2D

Enfin, ouvrez les paramètres de chrome et cliquez sur:

  • Utilisez l'accélération matérielle si disponible
réponse donnée zafer 27.07.2016 - 10:10
la source
37

Je l'ai corrigé comme suit:

sudo apt-get purge xserver-xorg-video-intel

puis redémarrez. C'est parce que les pilotes Intel sont passés à modesetting. Pour plus d'informations, voir ce commentaire dans le fil de bogue Chromium .

    
réponse donnée ComBin 19.08.2016 - 16:25
la source
24

Aucune de ces réponses ne m'a semblé aider. Ce que j'ai fini par faire et qui semble l'avoir corrigé (ma référence était ce lien qui scintillait comme CRAZY et maintenant ça fonctionne bien) est la suivante:

1.- Naviguer vers chrome://gpu/ . C'est ce qu'il a montré:

2.- J'ai essayé de résoudre les problèmes un par un. Dans mon cas, l'activation de ces indicateurs a permis de corriger certains d'entre eux: GPU rasterization , Override software rendering list . Ensuite, il a montré comme ceci:

3.- J'ai édité le lanceur de bureau et ajouté les paramètres --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers .

4.- Après cela, plus de problèmes détectés, tout montre comme "accélération matérielle" et, plus important encore, plus de scintillement:

Si vous ajoutez les paramètres au lanceur en premier, la liste des problèmes devrait être plus courte et il serait probablement plus facile de déterminer quels drapeaux vous aideront à résoudre les problèmes qui vous restent.

    
réponse donnée Nahuel 14.09.2016 - 14:29
la source
7

Avec la version Chrome 51.0.2704.103 (64 bits), les indicateurs

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

ne fonctionne plus.

La meilleure façon de faire est de revenir à Chrome 50 (Version 50.0.2661.86 (64-bit)), voici une instruction pour savoir comment revenir en arrière: Comment rétrograder Google Chrome?

Il est important de faire pression sur Google pour résoudre ce problème, votez pour le bogue dans Chrome et sur la page produit de Google:

lien

lien

    
réponse donnée user157697 19.06.2016 - 10:02
la source
5
chrome://flags/ > GPU rasterization > Enable,

Cela a finalement fonctionné pour moi! Vous l'avez trouvé au bas de ce formulaire Google! lien

    
réponse donnée Chris Lane Jones 16.10.2016 - 22:44
la source
4

Je pense avoir trouvé la solution:

flags --disable-gpu-driver-bug-workarounds

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection
    
réponse donnée Hector 07.07.2016 - 17:14
la source
2

Essayez de charger avec certaines options GPU désactivées:

- disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Après avoir essayé, vous pouvez également manipuler certains paramètres de rendu dans about: // pour voir si quelque chose aide, mais le gros de mes scintillements de rendu a été résolu par les deux indicateurs de la ligne de commande. Si vous avez un fichier .desktop de lanceur, ajoutez ces indicateurs à l'entrée Exec supérieure avant le '% U' Vous pouvez également les ajouter aux autres entrées Exec pour que les indicateurs soient appliqués à tous les modes de démarrage.

    
réponse donnée MattCole3 04.05.2016 - 17:44
la source
2

J'ai trouvé que les correctifs actuels ne fonctionnaient pas pour la version actuelle de chrome, d'autres éléments devaient être modifiés (au moins pour ma configuration).

Je peux confirmer que cela fonctionne (supprime les scintillements et les déchirures) - merci à lien

Ordinateur: XPS13 9343 Graphisme: 00: 02.0 Contrôleur compatible VGA: Intel Corporation Broadwell-U Integrated Graphics (version 09) Version Chrome: Version 54.0.2840.100 (64 bits)

Paramètres

1) Vérifiez les messages d'erreur avant et après les réglages de configuration ci-dessous

  • chrome: // gpu
  • prenez une capture d'écran pour pouvoir comparer après.

2) Edit (pour chrome): /usr/share/applications/google-chrome.desktop ou pour (chrome): /usr/share/applications/chromium-browser.desktop

  • Ajoutez les drapeaux --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers
  • La ligne
  • devrait ressembler à ceci: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf ajoutez ceci (vous devrez peut-être créer le fichier):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Paramètres des indicateurs Chrome: chrome: // flags:

  • Activer ("rasterizer zéro copie"): chrome: // flags / # enable-zero-copy
  • Activer (activer la liste d'affichage 2d canvas): chrome: // flags / # enable-display-list-2d-canvas
  • Activer ("Remplacer la liste de rendu du logiciel"): chrome: // flags / # ignore-gpu-blacklist
  • Activer "Canevas 2D de la liste d'affichage"): chrome: // flags / # enable-display-list-2d-canvas
  • Activer (indicateur de chrome pour un défilement régulier dans linux): chrome: // flags / # smooth-scrolling

5) J'ai conservé le paramètre Chrome & gt; Avancé & gt; Utilisez l'accélération matérielle si disponible [ cocher ]. Si vous décochez cette option vraiment , elle réduit les scintillements mais ne déchire pas, mais les options ci-dessus ont été bien meilleures pour moi.

6) Redémarrez l'ordinateur.

7) Comparer les paramètres. chrome: // gpu

Cela a totalement éliminé le scintillement et le déchirement pour moi.

    
réponse donnée Amos Folarin 15.02.2017 - 15:27
la source
1

La désactivation de l’accélération matérielle va dégrader les performances de votre navigateur pour les pages comportant des animations et d’autres tâches exigeantes en termes de processeur.

Toutefois, si aucun GPU n’est installé sur votre système, l’approche consistant à désactiver l’accélération matérielle proposée par sgiri est mieux pour vous.

J'ai un GPU NVidia installé sur mon ordinateur portable et j'utilise le système d'exploitation de bureau Ubuntu. J'ai donc installé le pilote binaire propriétaire (version 352.63). Cela a fonctionné pour moi, l’espoir fonctionnera aussi dans votre système Ubuntu.

    
réponse donnée user4128091 23.08.2016 - 08:50
la source

Lire d'autres questions sur les étiquettes