Comment changer le système de fichiers en mode de récupération en mode lecture-écriture?

105

J'ai foiré mon fichier sudoers et je souhaite modifier la permission.

Lorsque je me connecte en mode de récupération, je ne peux pas exécuter la commande chmod car elle est en lecture seule.

J'ai essayé mount -o remount,rw / en mode de récupération. N'a pas fonctionné pour moi:

Err : Ext4-fs remount. Opts errors=remount-ro 

Comment puis-je démarrer en mode de récupération et avec l'option de lecture-écriture?

    
posée bale 01.04.2012 - 18:45
la source

3 réponses

177

J'ai fait quelques recherches sur le site "Recover Mode Read Only" et j'ai trouvé cet article sur le site LinuxQuestions.org .

  1. Arrêter l'ordinateur
  2. Démarrage en mode de récupération --Après le chargement du BIOS, maintenez la touche Maj enfoncée pour accéder au menu grub --Une fois dans le menu grub, sélectionnez l’entrée se terminant par "(mode de récupération)"
  3. Dans le menu suivant, option sélectionnée pour entrer la session racine
  4. A la session racine, exécutez la commande mount -o rw,remount / to remonter le système de fichiers en lecture-écriture
réponse donnée twister_void 01.04.2012 - 18:54
la source
17

J'utilise toujours le moyen suivant pour passer en mode lecture / écriture

  • Connectez-vous en mode sans échec
  • Dans le menu, allez simplement à l'option Grub , cela affichera un message comme Mise à jour de grub pour monter votre système en mode lecture / écriture . Choisissez simplement oui pour monter votre système en mode lecture / écriture. Il mettra à jour votre grub et quittera le menu Grub .
  • Enfin, connectez-vous en tant que root , votre système sera en mode lecture / écriture.
  • Vous pouvez également choisir l'option dpkg dans le menu pour changer le système de fichiers en mode lecture / écriture.

Ça a toujours fonctionné pour moi. Cela aide lorsque vous ne vous souvenez pas de la commande pour passer en mode lecture / écriture.

Essayez-le ..

    
réponse donnée Saurav Kumar 28.08.2013 - 18:52
la source
13

Comme la réponse est un peu ancienne et n’a pas fonctionné pour moi, je partage avec vous ma solution. J'ai mal saisi une option dans fstab pour le répertoire / (très mauvais, je sais).

Pour pouvoir monter en mode de récupération avec l'option read write, les solutions mentionnées ne fonctionnaient pas pour moi.

J'ai simplement choisi le noyau avec l'option de mode de récupération et j'ai appuyé sur e pour modifier le paramètre de démarrage de ro à rw .

    
réponse donnée Ely 22.06.2015 - 04:16
la source

Lire d'autres questions sur les étiquettes