HWE (Hardware Enablement Stack) hors support

20

Depuis hier, mon gestionnaire de mise à jour me donne le message suivant:

  

Votre pile d'activation de matériel (HWE) actuelle est en panne   le 07/08/2014. Après cette date, les mises à jour de sécurité pour les pièces critiques (noyau   et la pile graphique) de votre système ne seront plus disponibles.

     

Pour plus d'informations, consultez: lien

Mais quand j'essaye de mettre à jour HWE avec la commande suggérée par hwe-support-status --verbose c'est

sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty

Je reçois des erreurs de dépendance:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx-lts-trusty : Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) but it is not going to be installed
 xserver-xorg-lts-trusty : Recommends: xserver-xorg-input-all-lts-trusty but it is not going to be installed
                           Recommends: xserver-xorg-video-all-lts-trusty but it is not going to be installed
                           Recommends: x11-xserver-utils-lts-trusty but it is not going to be installed
                           Conflicts: libglapi-mesa:i386 (>= 0~)
E: Unable to correct problems, you have held broken packages.

Comment puis-je résoudre ce problème?

J'exécute Ubuntu 12.04.4 LTS 64 bit avec le noyau 3.5.0-53-generic .

    
posée Red 09.07.2014 - 11:15
la source

2 réponses

10

J'ai eu le même problème, c'est ce qui a fonctionné pour moi

Commande:

Pour amd64:

sudo apt-get install -V libglapi-mesa-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty xserver-xorg-input-all-lts-trusty xserver-xorg-video-all-lts-trusty libgl1-mesa-dri-lts-trusty x11-xserver-utils-lts-trusty libglapi-mesa-lts-trusty:i386 libgl1-mesa-dri-lts-trusty:i386 libgl1-mesa-glx-lts-trusty:i386 libgles2-mesa-lts-trusty libglapi-mesa-lts-trusty mesa-vdpau-drivers-lts-trusty

Pour i386:

sudo apt-get install -V libglapi-mesa-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty xserver-xorg-input-all-lts-trusty xserver-xorg-video-all-lts-trusty libgl1-mesa-dri-lts-trusty x11-xserver-utils-lts-trusty mesa-vdpau-drivers-lts-trusty libgles2-mesa-lts-trusty libglapi-mesa-lts-trusty
    
réponse donnée ECII 11.07.2014 - 13:04
la source
6

L'installation manuelle de xserver-xorg-lts-precise garantit que vous disposez de toutes les dépendances dont vous avez besoin. Ensuite, installez les packages définis par hwe-support-status .

Pour vous, cela signifie exécuter les deux commandes ...

sudo apt-get install xserver-xorg-lts-precise
hwe-support-status --verbose
sudo apt-get install linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty linux-image-generic-lts-trusty

Ce problème est discuté dans bogue n ° 1328264 Je ne l'avais tout simplement pas lu correctement: -)

    
réponse donnée Dogsbody 11.07.2014 - 18:53
la source

Lire d'autres questions sur les étiquettes