Comment désactiver la notification du gestionnaire de réseau

19

Puis-je désactiver toutes les notifications associées à libnotify à partir de Network Manager? La boîte de dialogue "Modifier la connexion" n'aide pas

    
posée daisy 16.10.2011 - 15:37
la source

5 réponses

30

12.10 - Dconf

Exécutez ces commandes:

gsettings set org.gnome.nm-applet disable-disconnected-notifications "true"
gsettings set org.gnome.nm-applet disable-connected-notifications "true"

Ou ouvrez dconf-editor et faites défiler jusqu'à orggnomenm-applet et vérifiez les paramètres disable-connected-notifications et disable-disconnected-notifications ici.

11.10 et 12.04 - Gconf

Gconf-editor vous permet d’éditer les notifications du gestionnaire de réseau.

Pour modifier ces paramètres, installez gconf-editor à partir du centre du logiciel.

Sélectionnez / ▸ apps ▸ nm-applet et vérifiez les paramètres disable-connected-notifications et disable-disconnected-notifications ici. Vérifiez l'image jointe pour plus de précisions.

    
réponse donnée jokerdino 27.11.2011 - 08:27
la source
10

En plus de la façon de jokerdino, vous pouvez aussi changer cela en ligne de commande:

gconftool -s /apps/nm-applet/disable-disconnected-notifications --type=bool true
gconftool -s /apps/nm-applet/disable-connected-notifications --type=bool true

Pour voir ce qui peut être changé:

gconftool -R /apps/nm-applet
    
réponse donnée Caesium 27.11.2011 - 11:06
la source
3

Les autres réponses peuvent vous aider à vous débarrasser des messages "vous êtes connecté", mais il y a un bogue, à lien (voir aussi lien et lien ), provoquant la notification disable-disconnected réglage à ignorer.

Jusqu'à ce que cela soit résolu, il existe une solution de contournement. Mettez ceci dans /etc/pm/sleep.d/49_killall_notify :

#!/bin/sh

case "" in
    resume|thaw)
    ( sleep 2 ; /usr/bin/killall /usr/lib/xfce4/notifyd/xfce4-notifyd ) &
    ( sleep 4 ; /usr/bin/killall /usr/lib/xfce4/notifyd/xfce4-notifyd ) &
     ;;
esac

puis chmod +x /etc/pm/sleep.d/49_killall_notify . Ceci est pour Xubuntu, sur Ubuntu ordinaire, je suppose que ce serait /usr/bin/killall notify-osd ou quelque chose comme ça. Vous pourriez également avoir besoin de modifier les temps de sommeil.

Mais c’est un hack moche;) il vaudrait mieux voir un vrai correctif.

    
réponse donnée unhammer 27.01.2012 - 08:10
la source
1

unhammer a raison de dire que la désactivation des notifications de déconnexion dans gconf-editor ne fonctionne pas. Dans Ubuntu, vous pouvez tuer les notifications de déconnexion avec:

sudo chmod -x /usr/lib/notify-osd/notify-osd

Puis tuez le processus notify-osd.

Je suppose que cela tue probablement toutes les notifications, pas seulement celles liées au réseau.

    
réponse donnée Sophie Gage 08.04.2012 - 09:09
la source
0

Une solution grossière:

dbus-monitor "interface='org.freedesktop.Notifications'"                \
| grep --line-buffered  'string "NetworkManager"'                       \
| sed -u -e  's/.*/killall notify-osd/g'                                \
| bash

Avertissement:
killall notify-osd est non discriminant et efface complètement la pile de notifications des messages en attente, que NM soit l'agent notifiant ou non.

Une solution "honnête" peut être affinée mais cela nécessite que les notifications en attente, autres que les NM, doivent être rétablies tout en maintenant leur intégrité temporelle. Cela signifie que l'ordre chronologique doit être maintenu pour les autres notifications et que dbus est surveillé pour vérifier si le statut des notifications a changé ... c'est-à-dire. annulé, message modifié, etc.

Idéalement, l’utilisation directe de% /_de% de

method void org.freedesktop.Notifications.CloseNotification(uint id)

cibler spécifiquement uniquement les notifications du gestionnaire de compte, n'est malheureusement pas évident ...

ref:

Signet:
Comment désactiver la notification du réseau -manager

    
réponse donnée George Rowell 29.09.2012 - 05:57
la source

Lire d'autres questions sur les étiquettes