gnome-shell 3.26.1 utilise constamment 20 à 30% de CPU

15

J'ai mis à niveau du 17.04 au 17.10 sur mon XPS13 9360 et j'ai, comme d’autres, des tonnes de problèmes. Celui-ci est maintenant que le processus

/usr/bin/gnome-shell

a un moyen de consommer constamment entre 20 et 30% de CPU :

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                                                                     
2026 xxxxxx   20   0 4264020 703284 315308 S  29,6  4,3   9:32.37 gnome-shell                                                                                                 

La version utilisée est

$ gnome-shell --version
GNOME Shell 3.26.1

Cela se produit directement après le démarrage du système avec rien d’ouvert sauf un terminal exécutant htop (à côté de certaines applications de démarrage telles que Dropbox) mais clairement pas de programmes graphiques lourds. Je ne sais pas par où commencer, voici quelques informations sur ma carte graphique

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)

$ glxinfo | grep -i render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_conditional_render, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 

S'il vous plaît laissez-moi savoir ce que je devrais poster afin de tracer ces problèmes - merci beaucoup!

    
posée Christian 02.11.2017 - 11:44
la source

2 réponses

9

Il s’est avéré que le processus gnome-shell était tombé en dessous de 10% lors de la désactivation de l’extension du moniteur système lien .

Il reste également inférieur à 10% lors de l’augmentation du temps de rafraîchissement à 1 seconde, alors qu’il a augmenté à nouveau lorsque je l’ai déplacé au-dessous de 1 seconde.

    
réponse donnée Christian 07.11.2017 - 10:29
la source
1

J'ai rencontré le même problème gnome-shell cpu hog et c'est kmailservice5 qui déclenche le processeur lorsque vous n'avez pas Thunderbird. Chaque fois que je clique sur un lien mailto , le processeur devient fou, tout comme gnome-shell et kmailservice5 ne fait rien. Il s'agit d'un bogue KDE signalé et a été corrigé depuis, mais pour les autres Ubuntu LTS comme 16.10, le problème est de désinstallez kmailservice5 .

    
réponse donnée A__ 16.01.2018 - 12:10
la source

Lire d'autres questions sur les étiquettes