Comment désactiver lightdm?

20

Je veux désactiver lightdm du démarrage automatique. Currenty, je lance service lightdm disable depuis le terminal, puis exécute startx .

update-rc.d ne vous aide pas

    
posée Samat 18.05.2012 - 18:16
la source

5 réponses

19

lightdm est lancé par Upstart, pas par SysV Init. Donc, update-rc.d ne fonctionne pas.

Utiliser

 echo  "manual" | sudo tee -a /etc/init/lightdm.override
    
réponse donnée Florian Diesch 18.05.2012 - 18:42
la source
21

Notez que la méthode décrite ci-dessus ne fonctionne plus depuis 15.04 et plus tard, puisque Upstart a été remplacé par Systemd. Comme décrit ici , il est désormais possible de désactiver lightdm comme ceci:

16.04 vers le haut

systemctl disable lightdm.service

15.04, 15.10

systemctl disable lightdm
    
réponse donnée Wolfgang Noichl 06.11.2015 - 14:10
la source
4

Si vous souhaitez désactiver lightdm pour activer gdm ou kdm ou tout autre gestionnaire d’affichage, entrez la commande suivante dans le terminal:

sudo dpkg-reconfigure lightdm

Ensuite, entrez ok , puis sélectionnez dans la liste le gestionnaire d'affichage souhaité.

La même réponse avec les captures d’écran est donnée ici: Réinitialiser la connexion par défaut à Unity

    
réponse donnée Nirmik 18.05.2012 - 18:30
la source
1

Je viens de supprimer le bit d'exécution sur le binaire lightdm.

chmod -x /usr/sbin/lightdm

Ensuite, pour le réactiver:

chmod +x /usr/sbin/lightdm

    
réponse donnée John 10.10.2015 - 21:10
la source
0

Ceci est géré par display-manager ... Désactiver sur systemd et vous avez terminé.

# systemctl disable display-manager        
Removed symlink /etc/systemd/system/display-manager.service.
    
réponse donnée Trunet 14.07.2016 - 16:00
la source

Lire d'autres questions sur les étiquettes