La luminosité est réinitialisée au maximum à chaque redémarrage

135

La luminosité de mon ordinateur portable est réinitialisée à chaque redémarrage. J'ai essayé la solution fournie à ce site mais n'a pas eu de chance.

Cette commande

cat /sys/class/backlight/acpi_video0/max_brightness

Retours

cat: /sys/class/backlight/acpi_video0/max_brightness: No such file or directory

Ensuite, j'ai constaté que je n’avais pas de dossier nommé acpi_video0 , mais un dossier appelé intel_backlight :

Chaque fois que j'augmente ou diminue la luminosité à l’aide des touches de contrôle de la luminosité, les valeurs de brightness et actual_brightness sont mises à jour.

Y a-t-il une méthode que je pourrais suivre pour définir la luminosité à une valeur fixe sur chaque démarrage et la modifier au fur et à mesure que j'en ai besoin en utilisant les touches de contrôle de la luminosité?

    
posée Bhargav 16.06.2012 - 12:06
la source

20 réponses

112

Vous pouvez essayer d’ajouter une ligne à /etc/rc.local qui définira le niveau de luminosité souhaité. Pour éditer le fichier, exécutez

sudo -H gedit /etc/rc.local

et ajoutez les éléments suivants

echo X > /sys/class/backlight/intel_backlight/brightness

pour que le résultat final ressemble à ceci

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo X > /sys/class/backlight/intel_backlight/brightness

exit 0

Remplacez X par le niveau de luminosité souhaité.

Dans le cas où /etc/rc.local n'existe pas, comme c'est le cas avec les nouvelles versions d'Ubuntu, vous devrez le créer et rendre le fichier exécutable avec les commandes suivantes:

printf '%s\n' '#!/bin/bash' 'exit 0' | sudo tee -a /etc/rc.local
sudo chmod +x /etc/rc.local

PS: Alternativement, il peut y avoir /sys/class/backlight/acpi_video0/brightness au lieu de ce qui précède. Les niveaux de luminosité varient énormément et peuvent aller de 0 à 10 ou à 1000. Pour trouver la valeur maximale, essayez

cat /sys/class/backlight/acpi_video0/max_brightness
or
cat /sys/class/backlight/intel_backlight/max_brightness
    
réponse donnée mikewhatever 16.06.2012 - 12:31
la source
25

J'ai converti mon petit script pour enregistrer et restaurer le niveau de rétroéclairage (luminosité) dans le package Ubuntu. Il est situé dans mon PPA et nommé sysvinit-backlight .
Il contient sysvinit init-script, placé dans /etc/init.d/sysvinit-backlight .
Il est compatible avec Ubuntu 12.04 LTS et 14.04 LTS.

Pour les nouvelles versions d’Ubuntu, mon PPA n’est pas nécessaire car elles utilisent le service intégré systemd-backlight.

Vous pouvez installer mon script avec les commandes suivantes:

sudo add-apt-repository ppa:nrbrtx/sysvinit-backlight
sudo apt-get update
sudo apt-get install sysvinit-backlight

Vous pouvez le supprimer par

sudo apt-get purge sysvinit-backlight

Veuillez noter que si vous avez installé la version précédente de mon script, veuillez la supprimer par

sudo rm /etc/rc?.d/?25backlight /etc/init.d/brightness /etc/rc?.d/?25brightness

La fonctionnalité de script est la suivante:

  • enregistrer les niveaux de rétro-éclairage (luminosité) de toutes les cartes vidéo et du clavier lors du redémarrage et de l'arrêt (niveaux d'exécution 0 et 6)
  • charge les niveaux de rétro-éclairage (luminosité) de toutes les cartes vidéo et du clavier au démarrage (niveaux d’exécution S, 1, 2, 3, 4 et 5)

Les options de script sont les suivantes:

  • sudo service sysvinit-backlight status (affiche les niveaux de luminosité actuels et enregistré dans les valeurs des fichiers)
  • sudo service sysvinit-backlight start (définissez les niveaux enregistrés à partir des fichiers)
  • sudo service sysvinit-backlight stop (enregistrer les niveaux actuels dans les fichiers)

Vous pouvez me contacter ici ou sur le tableau de bord.

    
réponse donnée N0rbert 17.08.2018 - 10:33
la source
21

Plus simple:

  1. Ouvrez une fenêtre de terminal.

  2. Tapez la commande suivante, puis appuyez sur Entrée après.

    sudo apt-get install xbacklight
    
  3. Ouvrez le menu Applications de démarrage .

  4. Cliquez sur le bouton Ajouter et ajoutez les informations suivantes:

    • Nom: Luminosité
    • Commande: xbacklight -set 60
  5. Remplacez 60 par le niveau de luminosité que vous préférez.

Source: Définir la luminosité de l'affichage de démarrage

    
réponse donnée Din 05.04.2014 - 12:05
la source
13

Avant d’essayer les solutions de contournement dans rc.local , il convient d’essayer les éléments suivants:

  • ajouter simple: quiet splash acpi_backlight=vendor à grub semble être suffisant dans ma configuration.

    1. sudo gedit /etc/default/grub
    2. remplacer
      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
      avec
      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

    3. sudo update-grub et reboot.

a travaillé sur:

  • Ubuntu 12.04 LTS (Asus U31SD-XH51)
  • Ubuntu 14.04 LTS (Dell 14z)
  • Ubuntu 14.04 LTS (Lenovo g500, supprimez nomodeset et cela fonctionnera correctement)
réponse donnée Casonade 02.04.2013 - 16:09
la source
6

J'ai modifié le code en /etc/rc.local comme ceci:

Obtenez une luminosité maximale:

$ cat /sys/class/backlight/intel_backlight/max_brightness
4882

Exécutez gksudo gedit /etc/rc.local et modifiez le fichier:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 4882 > /sys/class/backlight/intel_backlight/brightness
exit 0

Cela a fonctionné pour moi.

    
réponse donnée Anonymous Coder 02.10.2012 - 04:43
la source
5

Installez xbacklight ( sudo apt-get install xbacklight ) et ajoutez

xbacklight -set x

(où 'x' = 0 à 100 luminosité souhaitée) aux applications de démarrage via le tableau de bord. Par exemple:

xbacklight -set 50
    
réponse donnée Brandex 16.10.2013 - 02:54
la source
4

Les solutions proposées ici dépendent d’une manière ou d’une autre du système.

Une bonne conception consiste à disposer d’un seul endroit qui prend en charge les détails dépendants du système et fournit une interface unifiée. Il semble que le noyau n'offre actuellement pas une interface aussi simple via /sys . Au niveau X, cependant, il y en a un: xbacklight .

Une solution basée sur xbacklight est proposée sur Comment est-ce que je règle la luminosité d'affichage par défaut? , pour 11.10 et plus.

De plus, il ne devrait pas y avoir de problèmes signalés dans certains domaines (par exemple, lien ), cette mauvaise luminosité revient dans certaines situations.

    
réponse donnée Stéphane Gourichon 26.12.2012 - 08:51
la source
3

Comment déboguer le rétroéclairage:

lien

Malheureusement, l'ajout de acpi_backlight = vendeur ne semble pas enregistrer la valeur par défaut pour mon Lenovo G575 12.04.

    
réponse donnée grantbow 25.05.2013 - 22:05
la source
2

Mon ordinateur portable est Compaq Presario CQ62 111TU, installé Ubuntu 12.04. Les étapes suivantes ont bien fonctionné pour moi.

  1. Ajustez la luminosité de l'écran à votre niveau préféré.
  2. Ouvrez Terminal et entrez cat /sys/class/backlight/intel_backlight/actual_brightness et enlevez la valeur.
  3. Entrez cat /sys/class/backlight/acpi_video0/actual_brightness et enlevez la valeur.
  4. Entrez sudo gedit /etc/rc.local et ajoutez-les avant la dernière ligne exit 0 in gedit:

    echo ValueFromStep2 > /sys/class/backlight/intel_backlight/brightness
    echo ValueFromStep3 > /sys/class/backlight/acpi_video0/brightness
    

économisez et appréciez.

Mes paramètres sont affichés ci-dessous

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 478 > /sys/class/backlight/intel_backlight/brightness
echo 0 > /sys/class/backlight/acpi_video0/brightness

exit 0
    
réponse donnée Chanaka Sameera 09.07.2013 - 11:40
la source
2

Je trouve que la solution de N0rbert est la meilleure, car le script fourni permet de restaurer votre niveau de luminosité précédent au démarrage.

Il y avait cependant une petite modification à apporter à sa solution pour que cela fonctionne. Au lieu de créer des liens symboliques qu'il a mentionnés, j'ai fourni les éléments suivants:

ln -s /etc/init.d/brightness /etc/rc0.d/S25backlight
ln -s /etc/init.d/brightness /etc/rc2.d/S25backlight
ln -s /etc/init.d/brightness /etc/rc6.d/S25backlight

Notez qu'au lieu de rcS.d , j'ai ajouté un lien symbolique vers rc2.d , qui est un niveau d'exécution pour "Multi-utilisateur graphique avec réseau" ( voir plus ). Je crois que la raison pour laquelle l'ancien ne fonctionne pas pour moi est le fait que Ubuntu remplace le niveau de luminosité après qu'il a été configuré par le script /etc/init.d/brightness lors de l'exécution de S runlevel.

Avec ce changement subtil, la restauration du niveau de luminosité fonctionne à merveille, en particulier pour Ubuntu 14.04 LTS sur Lenovo ThinkPad L540.

    
réponse donnée falconepl 01.09.2014 - 19:20
la source
2

J'utilise un modèle Sony Vaio S et des graphiques hybrides. J'ai désactivé ma carte ATI G et mon Intel HD 3000 est ma seule carte g.

J'ai trouvé que définir la valeur de luminosité sur le fichier actual_brightness dans le dossier intel_backlight aidera. et l'autre pas.

pour moi, ma valeur de luminosité minimale est 236 et le maximum est 4648, vous pouvez donc définir une valeur n'importe où entre cette valeur.

alors essayez ceci:

echo 236 > /sys/class/backlight/intel_backlight/actual_brightness
    
réponse donnée Junior Hacker 15.11.2012 - 09:03
la source
1

Pas besoin de tomber dans le script et le codage.

Suivez simplement ces étapes simples:

Si la luminosité de l'écran est bloquée au maximum à chaque démarrage, installez xbacklight ( sudo apt-get install xbacklight ) et ajoutez "xbacklight -set x" (où "x" = 0 à 100 luminosité souhaitée) aux applications de démarrage via le tableau de bord. Par exemple, "xbacklight -set 50".

J'ai réglé la luminosité de mon ordinateur portable sur 30.

Source: lien [Recherchez le mot "luminosité" et lisez les paragraphes correspondants sur cette page source.]

Profitez !!

    
réponse donnée i50729 01.11.2013 - 00:58
la source
1

J'ai ajouté ce qui suit dans /etc/rc.local, pour gérer la luminosité de l'écran et le rétroéclairage du clavier, et cela fonctionne parfaitement

...
echo 30 | sudo tee /sys/class/backlight/acpi_video0/brightness
echo 3 | sudo tee /sys/devices/platform/applesmc.768/leds/smc::kbd_backlight/brightness

exit 0
    
réponse donnée j3ffyang 29.06.2015 - 09:38
la source
1

Utilisez cette commande pour découvrir votre niveau de luminosité actuel:

cat /sys/class/backlight/intel_backlight/brightness

Ensuite, éditez le fichier rc.local en utilisant cette commande:

gksudo gedit /etc/rc.local

Ajoutez cette ligne avant exit 0 line:

echo X > /sys/class/backlight/intel_backlight/brightness

Si cela ne résout pas le problème, il se peut que quelque chose dans votre système écrase le niveau de luminosité. Ensuite, vous pouvez essayer d'ajouter une commande de veille pour retarder l'exécution de la commande précédente:

(sleep 10 && echo X > /sys/class/backlight/intel_backlight/brightness)

Source

    
réponse donnée user3753202 01.12.2015 - 17:53
la source
0

Il vaut mieux vérifier les fichiers max_brightness pour les valeurs maximales absolues dans les répertoires / sys / class / backlight / intel_backlight et / sys / class / backlight / acpi_video0 pour éviter de définir des valeurs inutilisables.

Mon Dell Inspiron 5720 utilise des valeurs maximales de 4882 et 100 respectivement. Je les ai réglés sur 2508 et 52 pour prolonger la durée de vie de la batterie. La valeur ACPI dans ce cas est équivalente au pourcentage de la luminosité maximale.

La modification de rc.local fonctionne pour moi. J'ai ajouté des commentaires pour clarifier la façon dont les valeurs ont été déterminées. définir la luminosité requise avec les touches de fonction et lire les valeurs dans les fichiers luminosité ou actual_brightness de chacun des répertoires Intel / ACPI ci-dessus.

    
réponse donnée KeithB_5720 16.04.2014 - 19:05
la source
0

Pour mint mate 17, vous pouvez définir la luminosité par défaut en procédant comme suit:

  • sudo apt-get installe dconf-tools
  • Applications - & gt; Outils système - & gt; Outils dconf,
  • recherche de rétro-éclairage, recherche et modification des options suivantes:

    • luminosité-ac
      luminosité lorsque vous utilisez le powser AC (chargé),
    • luminosité-dim-batterie
      luminosité lorsque la batterie est utilisée (non chargée),
réponse donnée Eric Wang 23.07.2014 - 10:16
la source
0

toutes les réponses sont utiles, mais ne m'ont pas aidé à atteindre mes objectifs. Je voulais des niveaux de luminosité prédéfinis pour la batterie et l’alimentation en courant alternatif.

  1. utilisez les outils du mode ordinateur portable ici Outils du mode ordinateur portable
  2. éditez le fichier conf pour la luminosité et remplacez [valeurs] par les valeurs souhaitées. comme "echo 1" pour la batterie. wiki

travaille pour moi:)

    
réponse donnée aishu 25.12.2014 - 21:26
la source
0

Modifier le niveau de luminosité par défaut dans Ubuntu 14. 04 LTS / Luminosité est réinitialisé au maximum à chaque redémarrage sur Ubuntu 14.04 LTS

Voici ce que j'ai découvert.

Dans mon cas, j'avais les deux dossiers.

Lorsque j'ai modifié le niveau de luminosité par défaut, il a fallu modifier le fichier dans le dossier acpi_video0 . c'est-à-dire à partir de la deuxième ligne de code.

Voici le code qui sera utile pour définir le niveau de luminosité par défaut pour Ubuntu 14.04 LTS.

#!/bin/sh -e
#rc.local
#This script is executed at the end of each multiuser runlevel.
#Make sure that the script will "exit 0" on success or any other
#Value on error.
#In order to enable or disable this script just change the execution
#bits.
#By default this script does nothing.
#
#
#
#if you are changing the default brightness in Ubuntu 14.4 LTS
#the brightness under the folder acpi_video0 is important.
#Because brightness is set from that folder and not from intel_backlight
#(in case of my PC. It may very in others)
#That means you can omit the first echo line.
#However the command lines are given if any one has some problem and doesnot
#have the acpi_video0 folder
echo 1020 > /sys/class/backlight/intel_backlight/brightness
#Under the above given address the range of brightness is from 0 to 4648.
echo 3 > /sys/class/backlight/acpi_video0/brightness
#Under the above given address the range of brightness is from 0 to 7.
exit 0
    
réponse donnée Greeny 23.12.2015 - 12:18
la source
0

Cela fonctionne sur Ubuntu 16.10

Créez un fichier brightness.service in /lib/systemd/system avec le contenu suivant (modifiez 100 à la luminosité de votre choix, en gros entre 0 et 1000).

[Unit]
Description=Lower default brightness

[Service]
ExecStart=/usr/bin/zsh -c "echo 100 > /sys/class/backlight/intel_backlight/brightness"

[Install]
WantedBy=multi-user.target

Activez-le.

sudo systemctl enable brightness.

Redémarrer. Ça va marcher.

    
réponse donnée Searene 05.12.2016 - 17:24
la source
0

Ceci est une autre solution de contournement

$ sudo dd if=/dev/tty of=/sys/class/backlight/intel_backlight/brightness
3000

Appuyez sur Ctrl + D

moins de frappe pour les doigts échappés ...

    
réponse donnée Stan Portner 12.06.2015 - 06:32
la source

Lire d'autres questions sur les étiquettes