Aucune connectivité Internet dans une boîte virtuelle avec hôte et système d'exploitation virtuel étant 12.04

19

J'ai Precise 12.04 installé en tant qu'OS hôte. Dans VirtualBox, j'ai également installé 12.04.

Je ne parviens pas à connecter le Virtual 12.04 à Internet hôte. J'ai essayé de sélectionner toutes les options disponibles dans les cartes réseau (NAT, hôte uniquement, Bridge, etc.), mais aucune d'entre elles ne fonctionne. Dans certaines options, certains éléments doivent être saisis manuellement, ce que je ne sais pas quoi entrer.

Où est-ce que je me trompe dans les paramètres?

    
posée Nirmik 29.05.2012 - 18:44
la source

5 réponses

22

La connexion NAT devait être sélectionnée avec le matériel étant:

AMD PCNet FAST III (Am79C973, the default)

Cela fonctionne avec presque n'importe quel système d'exploitation (comme mentionné sur la page d'aide de Virtualbox ). Le paramètre Intel pour une raison quelconque ne fonctionnait pas.

Pour les configurations réseau avec des paramètres de routeur lourds, vous devrez peut-être utiliser l'option Bridged avec "PCNet FAST III" par défaut.

    
réponse donnée Nirmik 30.05.2012 - 09:15
la source
3

VB a probablement établi une connexion "réseau non identifié" avec votre machine réelle et l'utilise comme source de connexion Internet. Suivez les paramètres ci-dessous pour vérifier vos bases pour que l'Internet fonctionne dans votre système d'exploitation virtuel.

Paramètres réseau: * Sélectionnez NAT sous "Attaché à:" * "Type d'adaptateur:" MT Desktop (peut uniquement être modifié lorsque l'alimentation de la vm est coupée) * La case "Câble connecté" est cochée

Paramètres système: * La case "Réseau" est cochée dans la liste "Ordre de démarrage:".

    
réponse donnée Benjamin 15.05.2013 - 18:34
la source
2

Je voulais juste que tout le monde sache que j'ai résolu le problème en désinstallant Virtualbox du Software Center et en installant la copie trouvée sur le site virtualbox.org. Ensuite, je mets également l’adaptateur sur AMD PCNet FAST III (Am79C973, la valeur par défaut)

    
réponse donnée alemur 18.03.2013 - 15:22
la source
0

En utilisant Debian sur ma VM, j'ai dû éditer les interfaces / etc / network / pour utiliser eth0 comme interface de bouclage par défaut:

...
auto eth0
iface eth0 inet dhcp
    
réponse donnée Greg K. 24.12.2015 - 00:49
la source
0

Supprimez tous les packages virtualbox du système, puis installez le package à partir de Virtualbox.org. En raison de l'absence du fichier /usr/lib/virtualbox/VBoxNetNAT binary, l'accès Internet en mode réseau NAT ne fonctionne pas. Ce n'est pas une option par défaut NAT.

Normalement, il devrait exécuter ce fichier comme:

/usr/lib/virtualbox/VBoxNetNAT --ip-address 10.0.2.1 --netmask 255.255.255.0 --network NatNetwork --trunk-type whatever

Mais sans ce fichier, l’invité n’obtient que l’adresse IP du serveur DHCP et il ne peut pas se connecter à Internet. La communication entre invités fonctionne très bien.

Après avoir désinstallé tous les packages Virtualbox et installé le package (5.1.4-110228 ~ Ubuntu ~ trusty) de VirtualBox.org, /usr/lib/virtualbox/VBoxNetNAT se connecte très bien à Internet.

    
réponse donnée Borys 09.09.2016 - 16:29
la source

Lire d'autres questions sur les étiquettes