L'installation de glib donne "Vous devez soit avoir le support de gettext"

4

J'essaie d'installer glib-2.37.6 (également le même problème avec glib-2.32.1 ) et d'obtenir cette erreur lors de la configuration:

  

Vous devez avoir soit le support de gettext dans votre bibliothèque C, soit utiliser le   Bibliothèque GNU gettext. ( lien

J'ai déjà construit gettext , cependant. Pour clarifier, j'essaie de construire un certain nombre de choses (menant à gtk+ ) sans installer réellement aux endroits habituels, puisque c'est une machine que les autres utilisent; au lieu de cela, j'utilise --prefix= pour tout placer dans un répertoire de travail sous mon répertoire personnel.

J'ai essayé de regarder les journaux pour voir si je pouvais savoir si je devais définir autre chose. J'ai également essayé de regarder le script configure , bien que je ne sois pas un expert sur autoconf . Ce que j'ai trouvé, c'est que l'erreur s'est produite car gt_cv_have_gettext n'était pas défini sur yes . Alors, j'ai cherché où il était censé se mettre en place, de sorte que je puisse dire quel fichier ou ce qu'il cherchait. Mais à moins que je ne manque quelque chose, la seule commande qui le définirait sur yes se trouve sous ce if :

  if test "$gt_cv_func_dgettext_libc" != "yes" \
     || test "$gt_cv_func_ngettext_libc" != "yes" \
     || test "$ac_cv_func_bind_textdomain_codeset" != "yes" ; then

Le config.log (en regardant les numéros de ligne configure ) indique que la condition était fausse, donc tout ce qui était à l'intérieur (y compris la commande pour définir gt_cv_have_gettext ) était ignoré. Mais le test semble vérifier qu'aucune des trois choses ne manque. Et aucun d'entre eux n'est; voici l'un des derniers segments de config.log juste avant l'erreur:

configure:7982: checking for ngettext in libc
configure:8000: gcc -o conftest -g -O2   conftest.c  >&5
configure:8000: $? = 0
configure:8009: result: yes
configure:8013: checking for dgettext in libc
configure:8031: gcc -o conftest -g -O2   conftest.c  >&5
configure:8031: $? = 0
configure:8040: result: yes
configure:8047: checking for bind_textdomain_codeset
configure:8047: gcc -o conftest -g -O2   conftest.c  >&5
configure:8047: $? = 0
configure:8047: result: yes
configure:8323: checking for msgfmt

(La ligne qui définirait gt_cv_have_gettext est quelque part entre 8047 et 8323.) Donc, à moins de rater quelque chose, il semble que si toutes ces trois choses - ngettext , dgettext , bind_textdomain_codeset - être présent (ou réussir, ou quelque chose), alors une erreur résultera.

Alors, qu'est-ce qui me manque? Y a-t-il une autre option qui doit être définie, ou autre chose avec ma configuration? Ou ai-je trouvé une erreur dans le script configure ? Merci pour toute aide. Je voulais demander dans un forum comme celui-ci avant de le soumettre en tant que rapport de bogue.

    
posée ajb 29.08.2013 - 02:18
la source

2 réponses

3

OK, je pense que je l'ai compris. Comme je "installais" tout dans un répertoire sous mon répertoire personnel, je devais ajouter le sous-répertoire "bin" du répertoire --prefix à mon $PATH avant d'exécuter configure . Cela l'a amené à trouver msgfmt et, je pense, à contourner l'erreur.

    
réponse donnée ajb 29.08.2013 - 03:01
la source
-1

comment ajouter le sous-répertoire "bin" du répertoire --prefix à mon $ PATH avant de lancer configure. Cela l'a fait trouver msgfmt et, je pense, l'a compris autour de l'erreur.

    
réponse donnée user2782858 25.09.2013 - 11:14
la source

Lire d'autres questions sur les étiquettes