Ubuntu 17.10 tonnes de retard avec pépin de souris et de fenêtre

23

J'ai installé Ubuntu 17.10 sur mon ordinateur portable sans aucun problème, mais lorsque j'utilise le système, tout est en retard et n'est pas fluide. La souris pépie (j'utilise une souris physique et un trackpap), comme si elle sautait et qu'elle n'était pas fluide.

C'est la même chose avec Windows quand je les fais glisser ou simplement ouvre des applications. La même chose se produit lorsque j'ouvre la page d'application de Gnome.

J'ai essayé de passer de Wayland à Xorg à partir de l’écran de verrouillage et, ce faisant, la souris fonctionne sans aucun problème, mais j’ai toujours des problèmes de fluidité et de fluidité partout.

Est-ce un problème avec mon ordinateur ou Ubuntu a un problème avec Gnome sur certains appareils et que puis-je faire pour résoudre ce problème?

Mon ordinateur portable est un Asus Q501LA . Je n'ai pas de carte graphique dédiée.

    
posée vinid223 20.10.2017 - 23:09
la source

5 réponses

12

Malheureusement, je ne pense pas que ce soit un problème uniquement avec Wayland. Après avoir mis à jour à partir de 17.04, j'ai trouvé une réponse lag / sluggish avec gnome-shell sous Wayland et Xorg. Cela semble être un peu pire sous Wayland.

Dans mon cas, après un redémarrage, tout va bien pendant un certain temps, mais les choses se dégradent lentement et après quelques heures, il devient de plus en plus lent de basculer entre les bureaux virtuels ou les fenêtres mobiles. Lorsque l'écran de verrouillage se déclenche, après avoir appuyé sur une touche pour faire apparaître l'invite de mot de passe, il se produit un retard de 15 secondes avant que le fond d'écran verrouillé ne disparaisse et que l'invite s'affiche.

Ceci est sur une machine de haute qualité, à savoir i7 3Ghz à 12 cœurs avec une mémoire de 32 Go. J'utilise les pilotes graphiques par défaut oss (j'ai une carte nvidia gforce, mais n'utilise pas le pilote nvidia car il n'est pas compatible avec wayland).

Je n'ai pas eu ces problèmes avec 17.04 et le remix de Ubuntu gnome.

J'ai maintenant installé MATE et je vois si cela fonctionne mieux car le gnome-shell est assez lent pour être presque inutilisable à moins que je ne redémarre toutes les quelques heures.

En utilisant journalctl pour consulter les journaux, je vois beaucoup d’erreurs et d’avertissements liés à gnome-shell.

Tous assez décevant. J'ai aussi eu la malchance de rencontrer le bug lié à certains claviers de Logitech. J'ai donc dû changer de clavier pour que 17.10 fonctionne!

    
réponse donnée Tim X 02.11.2017 - 07:02
la source
5

GNOME a l’histoire d’être incroyablement lent. J'ai rencontré les problèmes que vous avez décrits sur Ubuntu 17.10 et je n'ai pas trouvé de correctif. Je suggère soit de rétrograder GNOME vers la version 3.24, soit simplement de rétrograder Ubuntu vers la version 17.04.

    
réponse donnée Chili Bebber 22.10.2017 - 23:46
la source
1

J'ai des extensions gnome installées et le moniteur système sous tension.

Cela a causé mon retard. La seule solution consistait à changer le temps de rafraîchissement dans le moniteur système à 50.

    
réponse donnée Jacob Stermer 01.12.2017 - 16:03
la source
1

Après le premier clic de la souris sur l’écran de connexion, mon curseur de souris USB a commencé à se comporter de manière irrégulière. L'entrée du trackpad fonctionne normalement .. J'ai essayé les suggestions ci-dessus en vain. Sur un autre forum, j'ai vu le paramètre du noyau irqpoll comme un correctif possible. Cela a fonctionné pour moi - maintenant, la souris fonctionne bien sous Ubuntu, Unity et Xfce par défaut.

Modifier /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash irqpoll"

(Je dis normalement noquiet nosplash - Je veux voir les messages de démarrage!)

Matériel:

  • McBook Pro, 5
  • NVidia GeForce 9400M (pilote nvidia 340)
  • Souris USB
réponse donnée tkam 16.01.2018 - 10:44
la source
-2

De cette réponse :

  

"Gnome / Wayland a des problèmes de suivi de la souris (voir lien )."

     

Ubuntu 17.10 utilise wayland par défaut. cependant, vous pouvez revenir à   Xorg, sans rien installer, il suffit de:

     
  1. Déconnectez-vous de votre utilisateur actuel.

  2.   
  3. Sous le mot de passe, près du bouton "déverrouiller", vous aurez quelque chose comme une icône de paramètres.

  4.   
  5. Cliquez dessus , puis choisissez la deuxième option (celle portant la mention "xorg")

  6.   
  7. Et voilà! la bonne vieille session xorg, avec plus de décalage du curseur!

  8.   

" Passer à une session Xorg à partir de l'écran de connexion devrait résoudre   it. "

Aussi: On dirait que GDM3 utilise aussi Wayland par défaut. Je devais également désactiver Wayland dans GDM en décommentant le WaylandEnable=false in /etc/gdm3/custom.conf .

    
réponse donnée Jacquesdupontd 25.10.2017 - 19:42
la source

Lire d'autres questions sur les étiquettes