Comment installer curl dans php5?

197

J'ai actuellement PHP 5.3 installé avec Apache dans 10.04 Lucid. Comment puis-je ajouter les bibliothèques PHP Curl? Dois-je installer d'autres dépendances pour curl?

    
posée Darren Newton 25.10.2010 - 05:06
la source

7 réponses

291

Je crois que le paquet php5-curl devrait faire l'affaire. Utilisez le gestionnaire de paquets de votre choix et les déps doivent être pris en charge.

sudo apt-get install php5-curl

Vous devrez ensuite redémarrer le serveur:

sudo service apache2 restart

Sinon, si vous utilisez php-fpm, vous devrez redémarrer php5-fpm à la place

sudo service php5-fpm restart
    
réponse donnée KFro 25.10.2010 - 05:44
la source
10

Pour subversion, php5.6 utilise la commande suivante (testée pour Ubuntu 14.04):

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php5.6
php — version
sudo apt-get install php5.6-curl
    
réponse donnée Mona Jalal 06.03.2017 - 02:34
la source
7

Mon conf: Ubuntu 11.10, déjà installé mysql, php5 et apache2, avant d’installer php5-curl dans le terminal que j’ai fait:

modifier la liste des sources comme:

sudo -H gedit /etc/apt/sources.list

vous pouvez vérifier votre configuration dans lien

Commande suivante:

apt-get install aptitude

Commande suivante:

aptitude install php5-curl

Vous obtenez quelque chose comme ça:

The following NEW packages will be installed:
php5-curl{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 27.1 kB of archives. After unpacking 127 kB will be used.
The following packages have unmet dependencies:
php5-curl: Depends: php5-common (= 5.3.6-13ubuntu3.1) but 5.3.6-13ubuntu3.8 is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1)     php5-curl [Not Installed]                          

Accept this solution? [Y/n/q/?] n

Votre réponse ici est n

Les lignes suivantes sont imprimées:

The following actions will resolve these dependencies:

Downgrade the following packages:                                             
1)     libapache2-mod-php5 [5.3.6-13ubuntu3.8 (now) -> 5.3.6-13ubuntu3.1 (oneiric)]
2)     php5 [5.3.6-13ubuntu3.8 (now) -> 5.3.6-13ubuntu3.1 (oneiric)]               
3)     php5-cli [5.3.6-13ubuntu3.8 (now) -> 5.3.6-13ubuntu3.1 (oneiric)]           
4)     php5-common [5.3.6-13ubuntu3.8 (now) -> 5.3.6-13ubuntu3.1 (oneiric)]        
5)     php5-gd [5.3.6-13ubuntu3.8 (now) -> 5.3.6-13ubuntu3.1 (oneiric)]            
6)     php5-mysql [5.3.6-13ubuntu3.8 (now) -> 5.3.6-13ubuntu3.1 (oneiric)]         

Accept this solution? [Y/n/q/?] y

Votre réponse ici est y.

Dans votre navigateur, ouvrez phpinfo (), vérifiez la propriété:

extension_dir   /usr/lib/php5/20090626+lfs

Dans ce dossier, vous devriez maintenant avoir curl.so

Modifier php.ini

nano /etc/php5/apache2/php.ini

trouver "extensions dynamiques" ajouter le code ci-dessous:

extension=curl.so

Après avoir redémarré apache2 et vérifié phpinfo (), curl doit être activé

    
réponse donnée Matija-cro 01.10.2012 - 13:49
la source
5

solution complète d’installation des extensions LAMP et cURL:

sudo apt-get update
sudo apt-get install php5

sudo apt-get install libapache2-mod-php5

sudo apt-get install curl libcurl3 libcurl3-dev php5-curl

et ensuite:

cd /etc/php5/apache2/

sudo nano php.ini

ajoutez cette commande: extension=curl.so

la dernière chose restart apache

    
réponse donnée Aragon 20.03.2012 - 15:30
la source
4

Vous devez installer le package php5-curl.

sudo apt-get install php5-curl
    
réponse donnée Astiam 25.10.2010 - 05:45
la source
2

Exécuter la commande suivante

sudo apt-get install curl libcurl3 libcurl3-dev php5-mcrypt php5-curl
    
réponse donnée user11271 22.02.2011 - 11:18
la source
1

Pour php 5.6 , cela fera l'affaire:

sudo apt-get install php5.6-curl

sudo service apache2 restart
    
réponse donnée Achraf JEDAY 19.07.2017 - 16:43
la source

Lire d'autres questions sur les étiquettes