Comment puis-je désactiver X au démarrage pour que le système démarre en mode texte?

206

Est-il possible de désactiver X au démarrage? Je suis en train de mettre en place un serveur, donc ce serait bien s'il ne chargeait pas l'interface graphique à chaque démarrage.

    
posée Olivier Lalonde 06.12.2010 - 03:42
la source

15 réponses

244

Modifiez /etc/default/grub avec votre éditeur favori, par exemple. nano :

sudo nano /etc/default/grub

Recherchez cette ligne:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Changez-le en:

GRUB_CMDLINE_LINUX_DEFAULT="text"

Mettre à jour GRUB:

sudo update-grub

Pour les systèmes utilisant systemd

Il s'agit d'une étape supplémentaire pour les versions de systemd, par exemple. Ubuntu 15.04, les étapes ci-dessus pour grub sont toujours nécessaires.

Vous devez indiquer à systemd de ne pas charger le gestionnaire de connexion graphique:

sudo systemctl enable multi-user.target --force
sudo systemctl set-default multi-user.target

Vous pourrez toujours utiliser X en tapant startx après vous être connecté.

    
réponse donnée Bruno Pereira 16.11.2011 - 02:35
la source
32

L'installation de l'interface graphique entraînera probablement son démarrage automatique, mais il est très facile de démarrer en mode texte dans Ubuntu. Ouvrez simplement /etc/default/grub en tant que root et ajoutez text à la

GRUB_CMDLINE_LINUX_DEFAULT=

ligne. Puis lancez:

sudo update-grub

Votre système démarrera alors toujours en mode texte.

Si vous souhaitez démarrer depuis l'interface graphique, appuyez simplement sur e dans le menu de démarrage et supprimez text de la ligne kernel .

Si vous souhaitez démarrer l'interface graphique après le démarrage, exécutez simplement:

sudo /etc/init.d/lightdm start

J'espère que cela vous aidera:)

    
réponse donnée Andrew Gunnerson 14.11.2011 - 15:55
la source
24

Pour 11.04 et les versions précédentes (et peut-être plus tard)

Si vous souhaitez démarrer en mode texte:

Éditez /etc/default/grub . Par exemple:

sudo gedit /etc/default/grub

Recherchez cette ligne:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Ajouter text :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"

Puis mettez à jour Grub:

sudo update-grub

Remarque: Si vous supprimez quiet splash (c’est-à-dire GRUB_CMDLINE_LINUX_DEFAULT="" ), le texte sera affiché au démarrage, mais un écran de connexion graphique apparaîtra normalement. Remplacer quiet splash par text vous laissera à l'invite de connexion; pour démarrer une session GNOME, utilisez sudo /etc/init.d/gdm start ou startx .

Pour désactiver GDM:
Installez bum .

Aprèsl'installation,vousletrouverezsousSystème>>Administration>>Gestionnairededémarrage

DésélectionnezGestionnaired'affichageGnome.

    
réponse donnée karthick87 06.12.2010 - 03:48
la source
23

Si vous utilisez lightdm en tant que gestionnaire de connexion, son chargement peut être empêché en le désactivant.

Vous pouvez utiliser un remplacement:

sudo bash -c 'echo "manual" >> /etc/init/lightdm.override'

Et pour lancer lightdm sur la commande:

sudo start lightdm

Pour restaurer votre système afin que lightdm soit toujours démarré au démarrage:

sudo rm /etc/init/lightdm.override

Pour plus d'informations, le livre de recettes disponible est votre ami:

réponse donnée achiang 16.11.2011 - 04:02
la source
19

Vous pouvez utiliser la édition Ubuntu Server .

    
réponse donnée RolandiXor 06.12.2010 - 03:58
la source
10

On a déjà répondu à plusieurs anciennes questions, mais je ne les trouve pas pour le moment, alors je résume ici les différentes situations.

  1. Pour arrêter un serveur X démarré par startx , terminez simplement la session.

  2. Pour arrêter un serveur X démarré par le gestionnaire de connexion (GDM), exécutez

    sudo service gdm stop
    

    puis déplacez-vous vers un terminal , par exemple en appuyant sur Ctrl - Alt - F1 , puis connectez-vous ici mode texte.

  3. Pour éviter tout démarrage du gestionnaire de connexion (et X), modifiez

    /etc/default/grub
    

    changer la ligne

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    devenir

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
    

    puis mettez à jour le fichier de configuration grub avec

    sudo update-grub
    

    pour que la prochaine fois que vous passiez directement en mode texte et que vous ayez besoin de startx pour lancer une session X, ou bien sudo service gdm start .

réponse donnée enzotib 26.09.2011 - 17:15
la source
8

je l'ai suivi

Étape 1 Mettez d'abord à jour votre référentiel en exécutant

.

sudo apt-get update

Étape 2 Il y a un bogue dans l'ancienne version de lightdm, nous devons donc le mettre à niveau. Pour cela, lancez

sudo apt-get install lightdm

Étape 3 Nous devons maintenant modifier la configuration des vers. Étape 3a Ouvrez /etc/default/grub avec votre éditeur préféré et modifiez-le

.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

à

GRUB_CMDLINE_LINUX_DEFAULT="text"

Étape 3b : ajoutez également le commentaire GRUB_HIDDEN_TIMEOUT = 0 Cette ligne permet de masquer le menu GRUB

Étape 4 Nous allons maintenant mettre à niveau la configuration de GRUB

sudo update-grub

Étape 5 Ubuntu 11.10 Desktop Edition utilise lightdm pour l'interface graphique. Nous devons désactiver le même

sudo update-rc.d -f lightdm remove

Étape 6 redémarrez maintenant votre ordinateur.

Trouvé sur Désactiver le démarrage de l'interface graphique dans Ubuntu 11.10

    
réponse donnée Vidyadhar 12.01.2012 - 17:25
la source
4

Oui, il est possible de dire au système de démarrer dans la console au moment du démarrage en modifiant la commande grub. Lorsque vous atteignez le menu de menu, mettez en surbrillance l'entrée Ubuntu et appuyez sur e .

Vous verrez du texte tel que dans l'image ci-dessous:

Modifiezletextequietsplashentexte.AppuyezsurF10pourlancerleprogramme.(Source: rolling-ubuntu ). J'ai testé cela sur mon système, 14.04, démarré dans la console de texte, pas de lightdm en vue. Commencé à lightdm avec sudo initctl start lightdm

Pour éviter de le faire à chaque fois, vous pouvez ajouter une entrée de groupe permanente avec l'option proposée dans cette réponse

Une autre suggestion consiste à modifier le niveau d'exécution par défaut et les niveaux d'exécution auxquels lightdm démarre / s'arrête, comme suggéré par autre réponse sur le même poste

    
réponse donnée Sergiy Kolodyazhnyy 09.04.2015 - 08:15
la source
4

J'ai remarqué que ce fil de discussion tourne autour du fait que vous utilisez LightDM en tant que gestionnaire d'affichage. Bien que cela puisse être le DM / welcomer habituel, cela ne fait pas partie de la question initiale. (Et il n'a pas précisé ..)

Dans mon cas:

J'utilise KDE / KDM sur mon serveur. Au lieu de cela, je désactive simplement le démarrage / service de démarrage sous le niveau d'exécution 2:

/etc/init/kdm.conf : (kdm: 4: 4.8.5-0ubuntu0.3, version récente: 1.5-0ubuntu7.2)

Rechercher:

start on ((filesystem

changer

           and runlevel [!06]

à

           and runlevel [!026]

En supposant que votre niveau d’exécution par défaut soit 2 lors du redémarrage récent, vous disposerez d’une console et non de KDM. Ensuite, vous pouvez exécuter DM / DE manuellement en cas de besoin = Utilisez 'startx' / etc. Pour que la machine retourne à la console et quitte complètement le serveur X après cela, utilisez simplement 'déconnexion'.

Les autres scripts dm .confs sont similaires. (J'ai configuré mon serveur de cette manière… pour pouvoir travailler avec une interface graphique de temps en temps, mais sans extraire de ressources lorsque vous n'utilisez / pas ou tout simplement un redémarrage.)

MODIFIER

(Mon système actuel: Upstart 1.12.1 / Ubuntu 14.04)

Pour résoudre ce problème récemment, il suffit de désactiver le gestionnaire d'affichage à partir du démarrage:

echo "manual" | sudo tee -a /etc/init/{service}.override

Pour lightdm:

 echo  "manual" | sudo tee -a /etc/init/lightdm.override

Cela peut être n'importe quel service de / etc / init, y compris kdm / gdm. 'startx' à exécuter à la suite d'un redémarrage.

ref:
Comment désactiver lightdm?
Comment activer ou désactiver les services?

    
réponse donnée bshea 06.10.2013 - 19:49
la source
2

Les étapes sont les suivantes:

Personnaliser la configuration de grub 2:

  • sudo nano /etc/default/grub , pour ouvrir le fichier avec le privilège root,

Recherchez la ligne

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

et remplacez-le par

GRUB_CMDLINE_LINUX_DEFAULT=”text”

Enregistrez les modifications (appuyez sur ctrl + o puis sur entrée) et fermez le fichier (ctrl + x).

Pour appliquer la nouvelle configuration, procédez comme suit

  • sudo update-grub

Maintenant, redémarrez votre PC

  • sudo reboot

Vous voilà ... Un écran de connexion texte-graphique ... Fournissez vos informations d'identification pour vous connecter au tty (tty1 par défaut). Vous pouvez changer le tty avec crtl + alt + [F1 à F6] pour tty1 à tty6. Vous pouvez également démarrer la session X (session X11), l'interface utilisateur graphique, avec sudo start lightdm (ctrl + alt + F7).

PS: si vous souhaitez annuler les modifications apportées , suivez le lien suivant:

.

Comment revenir à l'interface graphique en tant qu'interface par défaut à partir de la CLI sur le bureau Ubuntu?

    
réponse donnée precise 07.11.2013 - 20:09
la source
2

Vous pouvez également empêcher le noyau de modifier les modes vidéo, ce qui peut poser problème, en particulier si vous ne voyez pas l'invite de connexion ou si elle est partiellement hors écran. Ajoutez le paramètre GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" à / etc / default / grub:

#GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
#GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
#for text mode boot up... and also uncomment the "console" terminal
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
#GRUB_CMDLINE_LINUX="text"
GRUB_TERMINAL=console

Testé avec Ubuntu Server 16.04.1

    
réponse donnée PrgWiz 02.11.2016 - 16:49
la source
2

J'ai suivi les actions suivantes:

  1. Mettez tout d'abord à jour votre référentiel en exécutant

    sudo apt-get update
    
  2. Il y a un bogue dans l'ancienne version de lightdm, nous devons donc mettre à jour le même. Pour cela, lancez

    sudo apt-get install lightdm
    
  3. Nous devons maintenant modifier la configuration de grub.

    Ouvrez /etc/default/grub avec votre éditeur favori et modifiez-le

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    à

    GRUB_CMDLINE_LINUX_DEFAULT="text"
    

    Voir aussi le commentaire GRUB_HIDDEN_TIMEOUT=0 Cette ligne permet de masquer le menu GRUB

  4. Nous allons maintenant mettre à niveau la configuration de GRUB

    sudo update-grub
    
  5. Redémarrez maintenant votre ordinateur.

réponse donnée Vidyadhar 12.01.2012 - 17:30
la source
1

Lorsque vous installez Ubuntu-desktop, il configurera automatiquement lightdm pour qu'il démarre avec le système. Vous devrez le désactiver (probablement en éditant /etc/rc.local ) et utiliser startx pour exécuter l'interface graphique lorsque vous en aurez besoin.

    
réponse donnée RolandiXor 14.11.2011 - 15:34
la source
1

Si vous utilisez Lubuntu 15.05 avec Systemd pour gérer les processus d’amorçage, il est possible de démarrer à partir de la console, puis de démarrer l’environnement graphique ultérieurement à partir de la console. Suivez ces étapes:

  1. suivez les modifications susmentionnées apportées à Bruno par Bruno:
    Modifiez /etc/default/grub avec votre éditeur favori, par exemple: nano:

    sudo nano /etc/default/grub
    

    Découvrez cette ligne:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    Changez-le en:

    GRUB_CMDLINE_LINUX_DEFAULT="text"
    

    Mettre à jour Grub:

    sudo update-grub
    
  2. Bruno a suggéré sudo systemctl enable multi-user.target --force . L’utilisation de force me dérangeait donc j’ai préféré sudo systemctl set-default multi-user.target . ouvrir un terminal et faire sudo systemctl set-default multi-user.target

  3. le redémarrage vous amènera à la console en demandant un mot de passe

  4. lorsque vous souhaitez entrer dans un environnement graphique, entrez sudo systemctl start lightdm . Vous serez dirigé vers la fenêtre de connexion de lightdm.

  5. utilisez la combinaison de touches ctrl et F1 pour revenir à la console où vous vous trouviez et quitter si vous le souhaitez. (Je sors du mode console comme d'habitude jusqu'au prochain démarrage) Ctrl Alt F7 pour revenir à la connexion lightdm. ou ctrl alt F1 à F7 par besoin ou par désir.

réponse donnée javajazz 09.04.2015 - 19:41
la source
-2

Pour Ubuntu 14.04, Trusty Tahr et Ubuntu 12.04 Precise Pangolin, systemd a été ajouté à un PPA tiers. Il est donc facile de le tester sur les derniers systèmes Ubuntu LTS. Tout ce que vous avez à faire est d’ajouter le ppa à votre système

sudo add-apt-repository ppa:pitti/systemd
sudo apt-get update
sudo apt-get dist-upgrade 

Maintenant, ouvrez le fichier /etc/default/grub en utilisant n’importe quel éditeur de texte (j’ai utilisé gedit ici) avec le privilège sudo via Terminal pour le modifier comme suit:

sudo -H gedit /etc/default/grub

changez la ligne GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" en GRUB_CMDLINE_LINUX_DEFAULT = "init=/lib/systemd/systemd"

enregistrer le fichier et mettre à jour le Grub:

sudo update-grub

Ensuite, redémarrez maintenant le système va démarrer dans la console texte tty1 .

Pour vous connecter à nouveau à l'interface graphique, exécutez à nouveau

sudo start lightdm

Remarque: n'utilisez pas startx ou Ctrl + Alt + F7 Pour Ubuntu 15.04 utilisant systemd , utilisez sudo service lightdm start .

    
réponse donnée Mudit Kapil 08.04.2015 - 19:26
la source

Lire d'autres questions sur les étiquettes