Problème avec le redémarrage d'Apache 2 [dupliquer]

74

J'essaie de redémarrer Apache 2:

sudo service apache2 restart

Mais obtenez l'erreur ci-dessous:

* Restarting web server apache2 

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1.

Set the 'ServerName' directive globally to suppress this message

J'ai essayé de changer

sudo gedit /etc/apache2/httpd.conf

Un fichier vierge apparaît et j'ai ajouté ceci:

ServerName localhost

Mais cette erreur ne disparaît pas!

Comment puis-je résoudre ce problème?

    
posée Hamed Kamrava 06.08.2013 - 15:42
la source

4 réponses

111

J'ai trouvé ceci: Comment redémarrer / recharger Apache quand il ne peut pas déterminer le nom de domaine?

  

Bonne nouvelle! Apache redémarre avec succès. Apache n'est pas sûr   d'où vous voulez servir, donc il choisit votre localhost (127.0.0.1)   par défaut. Pour éviter que ce message n'apparaisse, précisez que vous   vouloir servir à partir de localhost (127.0.0.1) en ajoutant la ligne suivante   dans votre fichier /etc/apache2/apache2.conf :

ServerName localhost
    
réponse donnée Meintjes 06.08.2013 - 15:52
la source
34

Pour ce faire, spécifiez ServerName localhost dans vos fichiers de configuration en dehors des sections de l’hôte virtuel.

D'autres réponses suggèrent que vous devriez modifier /etc/apache2/httpd.conf . Ce fichier est écrasé lorsque apache est mis à niveau depuis apt. Pour la configuration d'Apache que vous ne souhaitez pas remplacer, vous devez créer un nouveau fichier. Voici la "manière Debian" de modifier cette configuration:

# create the configuration file in the "available" section
echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf
# enable it by creating a symlink to it from the "enabled" section
sudo a2enconf servername
# restart the server
sudo service apache2 restart
    
réponse donnée Stephen Ostermiller 10.03.2014 - 21:03
la source
4

Votre adresse IP hôte local doit être 127.0.0.1, au lieu de 127.0.1.1. Veuillez configurer correctement votre fichier /etc/hosts . Ensuite, éditez le fichier httpd.conf :

sudo -H gedit /etc/apache2/httpd.conf

Lorsqu'un fichier vierge apparaît, ajoutez cette ligne, puis enregistrez:

ServerName localhost
    
réponse donnée Masabza 02.03.2014 - 13:36
la source
0

Voici une autre solution:

Avant:

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos.wks.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

Ajout de 192.168.226.131 centos.wks.local dans le fichier /etc/hosts

Remarque: 192.168.226.131 correspond à l'adresse IP de mon serveur Apache.

Après:

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
    
réponse donnée Rahul Patil 06.08.2013 - 16:02
la source

Lire d'autres questions sur les étiquettes