périphérique Bluetooth couplé et connecté (pas de son)

17

J'ai un casque Bluetooth qui fonctionne très bien avec Windows 8 et Android 4.2, mais sous Ubuntu (13.10), cela ne semble pas fonctionner. J'ai installé Blueman, il a été associé et connecté avec succès lorsque j'ai essayé le dissipateur audio, mais il ne s'affiche toujours pas dans mes paramètres audio ni dans PulseAudio que j'ai installé et essayé. Tout ce qu'il y a dans mes paramètres sonores est "Sortie analogique". J'ai essayé plusieurs correctifs comme changer et ajouter des choses dans /etc/bluetooth/audio.conf sans succès. J'ai également redémarré le service Bluetooth plusieurs fois dans le processus.

Faites-moi savoir si vous avez besoin de plus d'informations de ma part et de mon système.

Cordialement, Michael.

    
posée Michael 06.11.2013 - 16:27
la source

6 réponses

9

J'ai le même problème , après avoir couplé le casque, je En utilisant la commande pulseaudio -k , le périphérique apparaît dans les paramètres de son et cela fonctionne.

Ce n’est pas une bonne solution, mais c’était ce que j’avais jusqu’à présent.

    
réponse donnée Eduardo 06.11.2013 - 17:55
la source
12

Je suis sur Ubuntu gnome 16.04. La solution consiste à activer la détection automatique, à relier le casque à nouveau et à le sélectionner dans la liste des périphériques audio de sortie.

  1. Remplacez #AutoEnable=false par AutoEnable=true dans /etc/bluetooth/main.conf (remarquez que la nouvelle ligne n'est pas commentée)
  2. Dissocier le casque
  3. Redémarrez le service Bluetooth sudo /etc/init.d/bluetooth restart
  4. Rebranchez votre casque et connectez-le
  5. Accédez aux paramètres sonores. À partir de l'onglet Périphérique de sortie, vous devriez maintenant voir le kit oreillette avec d'autres périphériques de sortie tels que des haut-parleurs internes.
  6. Choisissez-le comme périphérique de sortie audio.
réponse donnée KelzOKO 23.04.2016 - 12:10
la source
7

Ce qui suit a fonctionné pour moi.

Il y a une option dans /etc/bluetooth/audio.conf appelé AutoConnect=true . Assurez-vous que cela ne soit pas commenté (c'est-à-dire pas de hachage) (changez #AutoConnect=true à AutoConnect=true )

Cela permettra à pulseaudio de reconnaître le périphérique.

Remarque : pour Ubuntu 14, le fichier s'appelle /etc/bluetooth/main.conf .

    
réponse donnée kviggy0 11.06.2015 - 13:41
la source
6

Je suis sur Ubuntu GNOME 16.04 et j'ai trouvé une solution qui fonctionne parfaitement ici:

lien

Sur l'utilisateur Ubuntu, gdm et non Debian-gdm, voici les instructions exactes:

  

Afin d'empêcher GDM de capturer le récepteur A2DP au démarrage de la session,   éditez /var/lib/gdm3/.config/pulse/client.conf (ou créez-le si   n'existe pas):

autospawn = no
daemon-binary = /bin/true
     

Après cela, vous devez accorder l’accès à ce fichier à gdm :

     

$ chown gdm:gdm /var/lib/gdm3/.config/pulse/client.conf

     

Pour connecter automatiquement a2dp à certains périphériques, ajoutez ceci à    /etc/pulse/default.pa :

     

load-module module-switch-on-connect

     

Redémarrer.

     

Le périphérique audio (casque Bluetooth) doit maintenant être accessible via   Pavucontrol et gestionnaire de périphériques audio standard.

    
réponse donnée mswiszcz 23.06.2016 - 20:42
la source
5

J'ai le même problème sur Lubuntu 13.10 avec blueman et un adaptateur de haut-parleur sans fil. Pour moi, les points suivants ont été corrigés:

Insérer load-module module-switch-on-connect dans /etc/pulse/default.pa

Commande pulseaudio -k

Commande pactl load-module module-bluetooth-discover

Ce module n'est pas chargé automatiquement, vous devez le charger manuellement. Je n'ai pas trouvé de moyen plus pratique.

    
réponse donnée farael 11.02.2014 - 18:03
la source
0

La seule chose qui a fonctionné pour moi sur Ubuntu 16.04 est de redémarrer le service Bluetooth, puis de reconnecter le haut-parleur:

sudo /etc/init.d/bluetooth restart

Cela semble m'arriver chaque fois que je réveille l'ordinateur de suspendre.

    
réponse donnée LondonRob 08.03.2018 - 11:49
la source

Lire d'autres questions sur les étiquettes