Comment ajouter des boutons minimiser / agrandir aux fenêtres shell GNOME?

71

Juste installé Ubuntu 12.04, alors je l'ai fait

sudo apt-get install gnome-shell

et windows ont seulement un bouton de fermeture, comment puis-je activer minimiser / maximiser? L'ancien éditeur gconf ne semble pas fonctionner car il comporte les trois boutons dans la configuration.

    
posée iotrip 27.04.2012 - 03:25
la source

14 réponses

83

Vous avez besoin d'un outil de réglage de gnome.

Cliquez sur le bouton Télécharger pour installer avec Ubuntu Software Center:

Ou vous pouvez installer dans Terminal:

sudo apt-get update; sudo apt-get install gnome-tweak-tool

Ensuite, ouvrez Paramètres avancés pour modifier les boutons Réduire et Agrandir.

    
réponse donnée wojox 27.04.2012 - 03:31
la source
43

Installer dconf-editor :

sudo apt-get install dconf-tools
dconf-editor

Puis accédez à:

org.gnome.shell.overrides >> button-layout

et définissez la valeur sur:

close,minimize,maximize: **OR** :maximize, minimize,close

Notez que vous pouvez également effectuer cette opération depuis la console:

gsettings set org.gnome.shell.overrides button-layout close,minimize,maximize: 

Dans les versions actuelles de Gnome, vous devrez peut-être utiliser ceci à la place:

gsettings set org.gnome.desktop.wm.preferences button-layout 'close,minimize,maximize:'
    
réponse donnée vanlong441 30.04.2012 - 20:25
la source
16

C'est très simple les gars, tapez simplement la commande suivante dans le terminal, cela a fonctionné pour moi:

gsettings set  org.gnome.shell.overrides button-layout ':minimize,maximize,close'

Dans Ubuntu 17.10 (et Debian 9 Stretch) avec la commande gnome 3.26.1:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'

(merci à Ohto Nordberg's répondre ).

    
réponse donnée user161127 23.05.2013 - 14:52
la source
4

J'ai eu le même problème là où ma fenêtre Ubuntu 12.04 ne montrait que le bouton de fermeture. Je me rends compte qu'il est possible de cliquer avec le bouton droit sur la barre de menus pour obtenir les fonctionnalités de minimisation et de maximisation manquantes, mais je voulais que les boutons soient de retour.

J'allais installer Ubuntu Tweak mais j'ai trouvé l'application "Paramètres avancés". Je suis juste allé à l'onglet "Shell" et définissez "Disposition des boutons sur la barre de titre" de "Fermer seulement" à "Tous". Cela a restauré les boutons manquants sur mes fenêtres.

J'espère que cette solution alternative aidera les personnes ayant le même problème.

    
réponse donnée alastair5555 24.02.2013 - 03:57
la source
3

J'ai trouvé cette page lorsque je cherchais une réponse à cette question. Je pensais que certaines personnes apprécieraient cette information.

Voici la commande du terminal pour ceux qui sont deux paresseux pour ouvrir un lien. Je voulais juste faire crédit au contributeur original de cette information.

gconftool -s /apps/metacity/general/button_layout -t string menu:minimize,maximize,close 
    
réponse donnée Curt 05.07.2012 - 21:59
la source
3

Pour Ubuntu 14.04 + , vous devrez peut-être exécuter les opérations suivantes:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DecorationLayout': <':minimize,maximize,close'>}"
    
réponse donnée ash1991 20.04.2015 - 18:41
la source
2

Le 12.04 et 14.04, la réponse donnée par @ user161127 a bien fonctionné pour moi (en entrant les informations suivantes dans le terminal)

gsettings set org.gnome.shell.overrides button-layout ':minimize,maximize,close'

Cependant, le 16.04, je devais utiliser le chemin donné par @JivanAmara à la place:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'
    
réponse donnée desilvai 06.08.2016 - 21:12
la source
1

Installez ubuntu tweak.Open tweak ubuntu et allez dans Tweaks & gt; Window et définissez "off" dans le bouton Fermer uniquement. Mais je n’aimais pas ce type de solution bien que je partage cette solution.

    
réponse donnée Anindya Biswas 27.04.2012 - 09:46
la source
1

Pour maximiser, vous pouvez double-cliquer sur le cadre de la fenêtre avec le bouton gauche. Pour minimiser, cliquez une fois sur le bouton du milieu du cadre de la fenêtre.

    
réponse donnée guest 10.01.2016 - 10:12
la source
0

Au lieu des boutons, vous pouvez toujours réduire / agrandir les fenêtres en cliquant avec le bouton droit de la souris sur leur barre de titre et en sélectionnant l'entrée appropriée dans le menu.

    
réponse donnée Christopher Kyle Horton 27.04.2012 - 07:04
la source
0

Dans Gnome tweak tool - & gt; Cliquez sur Shell dans la colonne de gauche puis, dans la colonne de droite, sélectionnez Arrangement des boutons dans la barre de titre, sélectionnez "tous" au lieu de "Fermer uniquement".

    
réponse donnée Sachin Malhotra 20.05.2012 - 02:52
la source
0

Les solutions dconf-tool editor décrites par vanlong441 et par Todd Partridge a fonctionné pour moi. La seule chose à ajouter est que vous pouvez modifier le côté des boutons de la fenêtre en déplaçant : dans la chaîne et en modifiant l'ordre des boutons en déplaçant leurs noms. (Utile pour les préférences personnelles et aussi la farce).

    
réponse donnée user83965 17.08.2012 - 19:56
la source
0

Dans Ubuntu Gnome 17.04, utilisez

dconf-editor

pour ouvrir l'éditeur et vous pouvez le trouver ici:

    
réponse donnée Isengo 09.11.2017 - 08:34
la source
-1

Pour aligner les boutons à droite, placez les deux points au début:

gsettings set org.gnome.shell.overrides button-layout :minimize,maximize,close
    
réponse donnée nvd 17.06.2014 - 12:22
la source

Lire d'autres questions sur les étiquettes