Comment désactiver le son de batterie sur l'écran de connexion?

110

Je m'attendais à ce que Système ▸ Administration ▸ Écran de connexion ▸ Lire le son de connexion pour le contrôler, mais le décocher ne l'empêche pas de jouer.

    
posée ændrük 05.02.2011 - 19:05
la source

16 réponses

57

Le son de démarrage peut être désactivé en modifiant la configuration d'Unity Greeter. Exécuter ce qui suit à partir d'un terminal fera cela:

echo -e '[com.canonical.unity-greeter]\nplay-ready-sound = false' \
    | sudo tee -a /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Si vous utilisez Ubuntu 12.04 LTS, assurez-vous d’avoir les mises à jour installées car cette fonctionnalité a été ajoutée dans une mise à jour.

    
réponse donnée Andrejs Cainikovs 25.04.2016 - 23:34
la source
58

Pour Ubuntu 12.04 +

Way LightDM

Également connu sous le nom de FluteFlute Slap, le LightDM Way implique la déconnexion et, sur l’écran de connexion du LightDM, vous pouvez modifier le volume ou même couper le son.

Dans le Greeter d’identification, vous pouvez voir le volume en haut à droite. Le réglage du volume n’affecte pas le volume au démarrage de la session, vous pouvez donc MUET le son dans le Greeter sans couper le son lorsque votre session commence:

Tweak Way Ubuntu

La méthode Ubuntu Tweak implique le téléchargement de l’application Ubuntu Tweak et la désactivation du son à partir de là. Procédez comme suit et vous pouvez le faire de cette façon:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Ouvrez Ubuntu Tweak et dans l'onglet Tweak sélectionnez l'option "Paramètres de connexion", vous devriez voir l'option Play Login Sound. Vous devez cliquer sur le bouton Verrouiller ci-dessus pour pouvoir changer cela.

Pour Ubuntu 11.10 et au-dessous

Aller à System -> Preferences -> Startup Applications

Désactiver celui appelé Son de connexion GNOME

(décochez la case et cliquez sur Fermer)

vous pouvez aussi aller à System -> Preferences -> Sound et désactiver l’ensemble du système audio (comme les sons Windows, les alertes, etc.)

Dans les anciennes versions, vous pouviez accéder à la partie Préférence sonore et sélectionner chaque son et ce que vous vouliez faire. Il a été supprimé autour de 9.04 ou 9.10. Ce serait bien si cela revenait.

    
réponse donnée Luis Alvarado 05.02.2011 - 19:20
la source
53

12.04 - 16.10 (LightDM)

Voici ce qui a fonctionné pour moi après avoir installé 12.04 la semaine dernière.

Les étapes sont celles-ci, adaptées de lien :

gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Ajoutez ces lignes:

[com.canonical.unity-greeter]
play-ready-sound = false

Enregistrer, puis exécutez:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Redémarrez et appréciez.

    
réponse donnée K. P. MacGregor 10.09.2012 - 13:11
la source
20

11.10 (LightDM et GDM)

Solution rapide:

Ouvrez un terminal et exécutez la commande

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

Le son de batterie lightdm pour le système prêt peut être désactivé de la même manière

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  
    
réponse donnée RobinJ 15.10.2011 - 13:23
la source
11

pour 12.04

Par défaut, il est désactivé. Pour l'activer, ouvrez un terminal et lancez

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Puis changez la valeur de X-GNOME-Autostart-enabled à "true", c'est-à-dire X-GNOME-Autostart-enabled=true

pour 11.10

Saisissez un terminal gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop et remplacez la valeur NoDisplay de true par false :

Allez maintenant à vos applications de démarrage et vous devriez voir et pouvoir désactiver l’option nécessaire:

    
réponse donnée Bruno Pereira 15.10.2011 - 13:26
la source
10

10.10 (GDM)

Il semble y avoir un bogue dans l'écran de connexion à ce sujet. Je ne trouve pas de rapport officiel, cependant, ce post du forum confirme réparer.

Accédez à l'écran Système / Administration / Connexion. Débloquez-le, puis cochez "Lire le son de connexion".

Fermez la fenêtre, puis retournez dans l’application, déverrouillez-la, puis décochez la même option.

    
réponse donnée Scaine 05.02.2011 - 20:43
la source
7

Si vous utilisez GDM avec 12.04

Pour désactiver les sons de connexion, la clé event-sounds sous org.gnome.desktop.sound pour l'utilisateur gdm doit être définie sur false.

Pour cela, nous devons d’abord donner à GDM la propriété de son propre répertoire personnel. Ouvrez un terminal et tapez: sudo chown -R gdm:gdm /var/lib/gdm

Puis lancez:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

et déconnexion (ou redémarrage).

Si vous utilisez LightDM avec 12.04

Ouvrez un terminal avec Ctrl + Alt + T et tapez / collez le texte suivant, une ligne à la fois:

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter play-ready-sound false
exit

Cela désactive le paramètre play-ready-sound de l’utilisateur écran de connexion / gestionnaire de bureau (lightdm).

    
réponse donnée ish 10.09.2012 - 12:15
la source
5

11.10 (LightDM et GDM)

Pour supprimer le son de démarrage:

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

Pour activer le son de démarrage

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

Pour supprimer le son de connexion (après vous être connecté):

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

Pour l'activer à nouveau:

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
    
réponse donnée Vibhav Pant 07.03.2012 - 09:03
la source
3

11.10 (LightDM et GDM)

Cela devrait fonctionner pour vous.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Puis changez le NoDisplay = sur false, ect.

ou pour le supprimer:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg
    
réponse donnée Ringtail 07.03.2012 - 09:02
la source
3

11.10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false
    
réponse donnée blueyed 30.09.2011 - 09:13
la source
1

12.10 (GDM)

Rien de ce qui précède ne fonctionne pour moi avec gdm. Si je désactive le son prêt pour le système (les bongos), il produit toujours un son de batterie court (un temps).

La façon de le désactiver est la suivante:

  • Démarrez, entrez dans gdm.
  • Basculer vers la console ( Ctrl + Alt + F1 )
  • Connexion
  • Entrez:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Revenez à gdm ( Ctrl + Alt + F8 )

  • Désactiver le son dans la console de mixage. Je l'ai coupé dans "Lecture" et "Périphériques de sortie".
  • Fermez le mixeur, vous risquez d’avoir une erreur lors de l’écriture du fichier de configuration, c’est inoffensif.
  • Revenez à la console et entrez

    sudo service gdm restart
    

    pour tester et exit pour vous déconnecter.

réponse donnée jdm 17.07.2012 - 18:02
la source
1

11.04 et antérieurs (GDM)

Exécutez cette commande dans un terminal?

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

    
réponse donnée Jorge Castro 11.09.2012 - 05:49
la source
1

12.10 (LightDM)

Exécutez la même commande Jorge Castro a donné , mais uniquement avec gdm remplacé par lightdm :

sudo -u lightdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
    
réponse donnée C Schilder 27.06.2012 - 09:51
la source
1

Le moyen le plus simple est de couper le son dans le message d'accueil. Cliquez simplement sur le volume et cliquez sur "muet".

Cela mettra le son en sourdine uniquement dans l’autre.

    
réponse donnée Pilot6 15.06.2015 - 12:48
la source
0

Ouvrez les préférences des applications de démarrage en effectuant une recherche dans le tiret,

Ou du rouage,

Trouvez l’entrée pour GNOME Login Sound et décochez la case pour la désactiver ou sélectionnez-la pour l’activer puis fermez.

    
réponse donnée Mark Rooney 07.03.2012 - 10:48
la source
0

12.04 (LightDM)

Le son de bongo LightDM ne peut pas être désactivé via une option de GUI au 12.04 et il y a un rapport de bogue ici:

Les méthodes de ligne de commande ci-dessus peuvent le désactiver.

Le son après la connexion peut facilement être désactivé avec les réponses ci-dessus.

    
réponse donnée Eric Nemchik 07.04.2012 - 04:04
la source

Lire d'autres questions sur les étiquettes