"ctrl + espace" a été appelé pour invoquer une méthode d'entrée et ne fonctionne pas dans Emacs ou Eclipse auto-complete

81

Dans Emacs exécuté dans le terminal, ctrl + espace est une touche de raccourci standard pour sélectionner une région. Mais sous Ubuntu 12.04, il invoquera une méthode de saisie pour une langue autre que l'anglais. Je me demandais si je pouvais le réserver uniquement pour Emacs?

Sous System Settings -> Keyboard -> Shortcuts , je n'ai pas pu trouver à quel ctrl + espace a été lié. Étrange.

D’autres programmes, en particulier auto-complets dans Eclipse, semblent également avoir un problème avec ctrl + espace .

    
posée Tim 16.01.2013 - 00:55
la source

7 réponses

119

Il semble que vous ayez Ibus en cours d'exécution, qui utilise Ctrl + Espace par défaut pour activer / désactiver l'éditeur d'entrée.

Vous pouvez modifier la touche de raccourci qui lui est affectée dans les préférences d'Ibus.

Si Ibus est exécuté dans la barre de menus, vous pouvez cliquer avec le bouton droit pour choisir Préférences dans le menu. Si Ibus ne s'exécute pas dans la barre de menus, vous pouvez lancer la boîte de dialogue Préférences à partir du tableau de bord en exécutant Méthodes de saisie du clavier ou depuis le terminal avec ibus-setup .

Mise à jour pour 14.04

ibus-setup n'est plus disponible pour 14.04. Les fonctions de l'ancien ibus-setup sont plutôt intégrées dans Paramètres système & gt; & gt; Entrée de texte .

La commutation des entrées est maintenant définie par défaut sur Super + Espace , mais Ibus peut toujours voler le focus dans l'espace + keybinding et causent d'autres problèmes système, notamment l'auto-complétion dans Eclipse.

L'intégration de la commutation des entrées Ibus dans les nouveaux paramètres de saisie de texte est toujours en cours, et cela pose problème car l'ancien paramètre existe toujours dans les coulisses.

Si vous avez mis à jour à partir de 12.04, ibus-settings devrait toujours être disponible.

Au 14.04, vous pouvez modifier les paramètres directement sous la forme dconf-editor .

S'il n'est pas installé:

sudo apt install dconf-editor

Accédez ensuite à Desktop & gt; & gt; ibus & gt; & gt; général & gt; & gt; raccourci clavier . Le paramètre trigger et triggers affichera toujours 'control + space'. Modifiez ces paramètres en prenant soin de laisser les parenthèses vides [] in triggers .

    
réponse donnée chaskes 16.01.2013 - 01:59
la source
10

Désactiver le déclencheur IBUS en utilisant la ligne de commande:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

Ou si cela ne fonctionne pas, essayez si le premier produit une erreur:

gsettings set org.freedesktop.ibus.general.hotkey triggers []
    
réponse donnée aba 24.06.2014 - 09:46
la source
4

ibus ne me cause que des maux de tête. Chaque fois que j'essaie de modifier les paramètres, lorsque je redémarre, le Ctrl + Espace revient. Voici ma solution:

sudo apt-get purge ibus
sudo killall ibus

Maintenant, tout fonctionne jusqu'à ce qu'Ubuntu décide de sa prochaine bêtise. Peut-être que la lettre «o» correspondra à la mise hors tension de l'ordinateur?

    
réponse donnée Eyal 11.02.2015 - 13:47
la source
2

Après la mise à niveau vers Ubuntu 14.04, j'ai eu le même problème. Ce que j'ai fait.
Dans les préférences d'Ibus: System > Preferences > Keyboard Input Methods .
Il y a une option: Next input method il a été défini sur ctrl + espace, je l'ai supprimé et ensuite tout a recommencé à fonctionner.

    
réponse donnée wmlynarski 24.07.2014 - 11:04
la source
1

Ubuntu Studio 14.04 (XFCE) ici. Je n'ai pas eu de problème avec Autocomplete ( Ctrl + Space ), mais avec Copy Line ( Ctrl + Alt + Down ).

Cela a fonctionné pour moi:

  • Ouvrez le gestionnaire Windows: xfwm4-settings
  • Cliquez sur l'onglet Clavier
  • Faites défiler jusqu'à une action en conflit
  • Cliquez sur le bouton Effacer ou modifiez l’action en un autre raccourci
réponse donnée luboskrnac 04.04.2015 - 13:34
la source
0

J'ai Ubuntu 14.04 GNOME avec LXDE. Apparemment, ce bureau a ibus-setup. Donc, pour moi, changer le paramètre ibus était la bonne solution. Peut-être que seule Unity a supprimé l'application ibus-setup.

    
réponse donnée JamesH 28.12.2014 - 05:28
la source
0

Le changement de dconf-editor n'était pas suffisant pour moi. J'ai la source d'entrée Mozc (japonais) installée.

Sur Ubuntu 16.04, je devais aussi:

  1. Allez dans Paramètres système - & gt; Entrée de texte
  2. Cliquez sur Mozc pour mettre en évidence
  3. Cliquez sur l'icône de clé / tournevis ci-dessous
  4. Onglet Global Config
  5. Le premier paramètre, "Méthode d'entrée de déclenchement", était CTRL_SPACE. Je l'ai cliqué, puis j'ai appuyé sur Escape pour désactiver la reliure.
réponse donnée TalkLittle 08.09.2016 - 19:18
la source

Lire d'autres questions sur les étiquettes