Mise à jour vers 13.10 maintenant les paramètres de l'horloge sont tous désactivés et l'horloge ne s'affiche pas

64

J'ai mis à jour vers 13.10 et maintenant je n'ai pas l'horloge de menu standard, dont j'ai besoin pour travailler.

J'ai vérifié et 'indicator-datetime' est installé. J'ai même désinstallé / réinstallé cette applet sans succès.

De plus, mes paramètres "horloge" sous Préférences Système sont tous désactivés. Je ne peux rien changer.

Est-ce que quelqu'un sait comment récupérer l'ancienne horloge de menu?

Sinon, existe-t-il une autre application d'horloge de menu que je peux télécharger?

Modifier 1

Merci pour les réponses

  1. J'ai redémarré plusieurs fois et cela n'a pas résolu le problème.

  2. Je viens de lancer la mise à jour 13.10 aujourd'hui. Mais je l'ai encore fait tourner il y a quelques minutes. J'ai environ 200 Ko de mises à jour aléatoires. Le problème est toujours présent après un redémarrage.

  3. # apt-cache policy indicator-datetime indicator-datetime: Installed: 13.10.0+13.10.20131016.2-0ubuntu1 Candidate: 13.10.0+13.10.20131016.2-0ubuntu1 Version table: *** 13.10.0+13.10.20131016.2-0ubuntu1 0 500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages 100 /var/lib/dpkg/status

Modifier 2

Je crois que le problème est lié aux "raretés" qui changent le systray en quelque sorte ... lien

Ou systray a disparu , mais je n’ai pas encore trouvé cette solution.

Modifier 3

En raison d’une suggestion de RolandiXor, je vérifie les fichiers binaires. Mon système manque de 'libical.so.0' mais il a 'libical.so.1'.

ldd /usr/lib/x86_64-linux-gnu/indicator-datetime-service
libical.so.0 => not found

Est-ce que quelqu'un sait comment obtenir le binaire libical.so.0 dont le service datetime a besoin mais qu'il n'installe pas?

    
posée kervin 18.10.2013 - 04:08
la source

4 réponses

122

Il existe un rapport de bogue pour cela dans Launchpad .

Solution rapide:
Ouvrir le terminal (ctrl + alt + T) et taper

killall unity-panel-service
    
réponse donnée wranvaud 18.10.2013 - 15:20
la source
4

J'ai eu le même problème. J'ai effectué un redémarrage et mon horloge est de retour.

    
réponse donnée rheide 18.10.2013 - 05:14
la source
1

J'ai trouvé le problème. J'ai construit quelques bibliothèques à partir de sources plus tôt dans /usr/local/lib . indicator-datetime-service a trouvé ces bibliothèques avant les bibliothèques système dans /usr/lib pour une raison quelconque. Il n'aurait pas dû faire ça.

L'une de ces bibliothèques a récupéré l'ancienne dépendance libical.so.0 qui n'était plus disponible. Lorsque j'ai supprimé toutes les bibliothèques liées à GNOME / Evolution dans /usr/local/lib , je pouvais recommencer le service indicator-datetime-service et mon horloge était visible.

Alors aussi, essayez ...

ldd --verbose /usr/lib/x86_64-linux-gnu/indicator-datetime-service

Recherchez les messages "non trouvés" dans la sortie. Si vous avez un problème de dépendance à la bibliothèque, il sera probablement affiché dans cette sortie.

    
réponse donnée kervin 05.11.2013 - 18:33
la source
0

J'ai eu le même problème, (aucune horloge affichée et paramètres désactivés) Je devais sélectionner le serveur par défaut pour la mise à jour dans les Préférences Système. Redémarrez, et l'horloge était de retour.

    
réponse donnée benja 21.10.2013 - 13:15
la source

Lire d'autres questions sur les étiquettes