Polices vilaines dans Netbeans - Comment puis-je lui faire utiliser la police système?

67

J'ai de la difficulté à faire en sorte que la police Netbeans soit belle, cela a toujours été un problème depuis que j'ai essayé Ubuntu ~ 8. Pour certaines raisons, les polices ne semblent pas avoir un lissage de sous-pixels dans Netbeans uniquement, pour le reste des applications, elles sont parfaites.

Regardez à quel point la capture d'écran est moche:

Ce n’est pas seulement la zone de code, mais chaque police de l’application se présente de cette manière. Je regardais autour de moi et, apparemment, l'ajout de la ligne suivante au fichier .bashrc devrait résoudre le problème, mais dans mon cas, cela n'a pas été fait:

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd'

Je pense que cela ne concerne que les applications Java, mais je n'ai pas pu tester une autre application Java pour vérifier les polices.

Est-ce que quelqu'un sait ce que je peux faire pour résoudre ce problème? Comment puis-je faire en sorte que Netbeans utilise la police système?

    
posée javiervd 30.03.2011 - 07:58
la source

16 réponses

38

Comme cela a été indiqué dans les commentaires, il s’agit d’un problème avec les applications Java Swing sous Linux. Swing utilise les paramètres de lissage des polices de Gnome (désactivés, niveaux de gris ou sous-pixels) - il ignore toutefois les paramètres d’indication. Il utilise toujours des indices complets, et si vous utilisez Ubuntu avec peu ou pas d'indices de polices (comme la plupart des utilisateurs le font par défaut), la police sera considérablement différente de celle des autres applications. Les applications SWT comme Eclipse sont correctes, mais si vous aimez Netbeans, cela ne vous aidera pas.

Avertissement: Pour la solution de contournement suivante, je ne parle que de la police d’éditeur, car dans un environnement de développement intégré, c’est ce qui est important pour moi. Vous pourriez également l'appliquer aux polices de menu, etc., mais cela pourrait être un peu exagéré.

La seule solution utilisable que j'ai trouvée ici : utilisez Fontforge pour modifier la police de votre éditeur et supprimer toutes les informations police elle-même, puis enregistrez-la en tant que nouvelle police et utilisez-la dans Netbeans.

  1. sudo apt-get install fontforge
  2. Lancer Fontforge
  3. Ouvrez la police de votre choix
  4. Ctrl + A ou edit -> Select -> Select all pour sélectionner tous les caractères
  5. Conseils ⇒ Effacer les instructions
  6. Ctrl + Shift + F ou element -> font info pour ouvrir les informations sur la police
  7. Renommez la police (par exemple, le nom d'origine + '_nohints')
  8. Enregistrez la police modifiée dans le répertoire .fonts de votre domicile, via file -> generate fonts , en veillant à utiliser un format lu par Ubuntu (voir l'étape suivante)
  9. Effacer le cache de police fc-cache -rv - en suivant sa sortie pour vous assurer que votre nouveau fichier de police a été récupéré (par exemple, .sfd ne le fait pas, mais .ttf le fait).
  10. Exécutez Netbeans et utilisez la police que vous avez créée en tant que police d’éditeur

Non, pas parfait et oui, un peu compliqué, mais toujours un monde de différence. J'espère que ça aide.

    
réponse donnée nem75 21.04.2011 - 23:12
la source
16

Ajouter

--laf Nimbus -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

ou

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal

au fichier: netbeans.config. Vous pouvez le trouver dans $ NETBEANS_HOME / etc / folder. Réduisez la taille de votre police d’application à partir des préférences système.

Source

    
réponse donnée user24789 11.09.2011 - 10:03
la source
7

Je sais que c'est une vieille question, mais dans ma quête du même problème, j'ai essayé tous les trucs ici sans chance. Je pensais que j'allais devoir vivre avec un texte terrible dans netbeans.

Puis j'ai trouvé ceci: lien

Fondamentalement: Ubuntu 13.10, Netbeans (7.3), patches de police Infinality pour le freetype, OpenJDK7, et patches pour corriger la gestion des polices de Swings. Et ça "a juste fonctionné" !!!

Copié ici au cas où ce lien mourrait:

  1. installer freetype

    $ sudo apt-get install libfreetype6
    
  2. installer le patch infinality

    $ sudo add-apt-repository ppa:no1wantdthisname/ppa
    $ sudo apt-get update
    $ sudo apt-get install fontconfig-infinality
    

    Je devais faire ce qui suit après:

    $ sudo rm /etc/fonts/conf.avail/52-infinality.conf
    $ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf
    

    Pour utiliser Windows 7 comme le rendu de polices, procédez comme suit:

    $ sudo /etc/fonts/infinality/infctl.sh setstyle win7
    

    Définissez USE_STYLE sur "WINDOWS7" dans /etc/profile.d/infinality-settings.sh

  3. installer la police fixe OpenJDK

    $ sudo add-apt-repository ppa:no1wantdthisname/openjdk-fontfix
    $ sudo apt-get update
    $ sudo apt-get install openjdk-7-jdk
    

    Dans .../etc/netbeans.conf ,

    netbeans_default_options inclut: -J-Dawt.useSystemAAFontSettings=lcd et -J-Dsun.java2d.xrender=true"

    et définir netbeans_jdkhome="/usr/lib/jvm/java-1.7.0-openjdk-amd64"

Cela a changé mes polices Netbeans des années 1990 acceptables à nos jours. Et je peux maintenant utiliser Inconsolata comme police de l'éditeur Netbeans et elle est super.

Capture d'écran telle que demandée: (le texte réel est plus clair que cette capture. Quelque chose dans la capture le rend légèrement flou).

    
réponse donnée Chris Holt 31.01.2014 - 06:28
la source
5

L’anti-aliasing des polices ne fonctionne pas correctement dans les applications Ubuntu Java Swing.

Ajouter:

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

à netbeans.config à la fin de la chaîne netbeans_default_options .

Vous pouvez trouver le fichier de configuration dans le dossier $ NETBEANS_HOME / etc / (p. ex. /home/<user_name>/<neatbeans_folder>/etc/netbeans.conf )

Exemple:

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true -J-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd"
    
réponse donnée R. Oosterholt 24.01.2014 - 10:53
la source
2

Ce n'est pas si grave cette police ..

Cependant, il s’agit d’une application Java et d’un moyen particulier de gérer les polices.

Si vous voulez seulement changer la taille de la police, vous pouvez lancer Netbeans avec " - paramètre "fontsize" :

netbeans --fontsize 12

Si vous voulez changer le type de police, il est un peu plus difficile de modifier les paramètres d'environnement, et cet article explique très bien:

lien

Ceci est pour ArchLinux mais je pense que cela fonctionnera aussi dans Ubuntu car Java est un logiciel universel.

    
réponse donnée Pisu 10.10.2011 - 23:52
la source
2

J'ai eu le même problème sur Ubuntu 12.04 et Netbeans 7.2.

J'ai essayé d'ajouter -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd à netbeans.conf mais cela n'a pas résolu le problème.

Ensuite, j'ai vu le commentaire concernant la hauteur de ligne à bogue 215785 de Netbeans . La définition de la hauteur de ligne de l'éditeur à 1.0 avec les paramètres AA dans netbeans.conf a résolu mon problème.

    
réponse donnée Caner 01.09.2012 - 15:48
la source
1

J'ai pu faire cela comme ça (j'utilise Ubuntu 12.10, également sur Ubuntu 13.04):


Étape 1 (Cela fonctionne probablement dans toutes les versions d'Ubuntu):

J'ai d'abord nettoyé les menus en utilisant ce plugin Tools -> Plugins -> Settings -> Add :

http://java-swing-ayatana.googlecode.com/files/netbeans-catalog.xml

Une fois cet emplacement ajouté, vous devez installer le plug-in en recherchant Java Ayatana (la description sera en espagnol). Cela rendra le menu supérieur et le menu contextuel identiques à ceux du système d'exploitation.


Étape 2 (Je ne sais pas si cela fonctionnera dans toutes les versions d'Ubuntu):

Ensuite, vous voulez probablement que les polices des projets soient plus jolies, ce que j'ai fait pour les corriger a été exécuté dans le terminal: sudo apt-get install gnome-tweak-tool Je l'ai lancé et j'ai choisi un autre default font Maintenant, Netbeans est joli!

Voici une capture d'écran:

    
réponse donnée Get Off My Lawn 22.12.2012 - 23:49
la source
1

Juste vu ce posts et essayé de résoudre le problème de mes polices, j'avais aussi problème, je pouvais choisir seulement 4 polices toutes étaient boiteuses, et je me demandais ce que les netbeans donnent seulement 4 polices à choisir et aussi la boîte de sélecteur de polices, Je suis un grand fan de netbeans et je savais que je pouvais trouver une solution ici.

de toute façon j'ai suivi tous les guid possibles. J'utilise Ubuntu 13.10 et netbeans 7.3 (oui j'aime les choses instables)

  1. créer un dossier .font dans mon dossier utilisateur.
  2. copié toutes les polices que j'avais dans ce dossier.
  3. a ajouté la ligne suivante au fichier netbeans.conf

trouvez-le en exécutant:

locate netbeans.conf

modifiez-le et ajoutez ce qui suit dans les guillemets comme suggéré ci-dessus

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal
  1. lancez la mise à jour de netbeans qui, je pense, a fait la magie maintenant, j'ai un beau sélecteur de polices et j'ai plus de polices à choisir, puis du code à écrire (blague inattendue).

J'espère que cela vous aidera.

    
réponse donnée talsibony 01.01.2014 - 15:24
la source
0
#!/bin/sh

gsettings set org.gnome.desktop.interface font-name 'Ubuntu 10'
sh /home/xxx/netbeans-7.2/bin/netbeans &
sleep 5
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 11'
    
réponse donnée demonige 19.09.2012 - 13:53
la source
0

Personnellement, je pense que l’apparence par défaut de Netbeans sous Linux est un peu décevante, surtout si l’on considère qu’elle est agréable sur les autres plates-formes. Heureusement, changer le look & amp; feel (LAF) peut se faire facilement depuis l’EDI. Selon votre sélection, cela améliorera souvent l'apparence des polices.

Pour modifier le LAF, procédez comme suit: Cliquez sur Outils & gt; & gt; Les options Dans la boîte de dialogue, sélectionnez Apparence puis l'onglet Apparence Il suffit de sélectionner l'un des LAF. Ma préférence est Nimbus, mais vous préférez peut-être autre chose.

Il existe également deux plugins "Dark LAF": Dark Metal et Dark Nimbus.

    
réponse donnée Larry Hignight 24.07.2014 - 03:12
la source
0

En allant plus loin dans les méthodes manuelles, j'ai préparé une police dédiée nommée "Ubuntu Mono Nohinting" pour résoudre un problème de rendu avec les applications Java Swing telles que NetBeans IDE, IntelliJ IDEA et PyCharm. Les informations sur les polices ont été supprimées de la famille de polices Ubuntu Mono originale.

Comment installer

  • téléchargez le fichier zip à partir d'ici
  • l'extraire
  • ouvrez * .ttf avec Visionneuse de polices à installer.
  • ou vous pouvez copier manuellement * .ttf dans ~/.local/share/fonts/ .

Comment utiliser

  • Sélectionnez "Ubuntu Mono Nohinting" dans la configuration des éditeurs.

Captures d'écran

Police Ubuntu Mono avec le thème PyCharm Monokai

Police Ubuntu Mono Nohinting avec le thème PyCharm Monokai

    
réponse donnée Nobuto Murata 11.04.2015 - 18:15
la source
0

J'ai moi-même fait quelque chose de différent: dans mon cas, en parlant de NetBeans version 8.0.1 , le problème était que le JDK était installé sur le système (Oracle JDK 8.0). Après avoir migré vers OpenJDK 8, des polices plus fines sont apparues dans les éléments de l’interface utilisateur.

Je ne sais pas si c'est une bonne réponse, car cela pourrait ne pas fonctionner partout, mais certainement en essayant de changer de JDK (que ce soit OpenJDK ou Oracle JDK), vous pourriez voir une différence.

    
réponse donnée spectre 21.12.2015 - 18:18
la source
0

Ajoutez le code suivant à la fin du fichier netbeans_default_options votre netbeans.conf .

-J-Dawt.useSystemAAFontSettings=on

Cela utilisera les polices système.

    
réponse donnée Kevin RED 29.11.2017 - 13:25
la source
0

J'ai essayé littéralement toutes les solutions que je pouvais trouver et aucune ne fonctionnait, sauf en utilisant un JDK par défaut différent pour NetBeans.

Oracle JDK ne rend pas bien les polices. OpenJDK ne semble pas non plus fonctionner pour NetBeans mais fait des merveilles pour IntelliJ et ses frères et sœurs.

Celui qui a fonctionné pour NetBeans s'appelle TuxJDK , qui est essentiellement OpenJDK amélioré pour les développeurs Java travaillant sous Linux. L’une des améliorations est le excellent rendu des polices .

Voici comment l'utiliser:

  1. Téléchargez le fichier binaire TuxJDK depuis ici . ("tuxjdk-static-8.92.03.tar.xz" au moment de l'écriture)
  2. Extrayez le fichier tar.xz où vous voulez.
  3. Copiez l'emplacement du répertoire TuxJDK.
  4. Ouvrez netbeans.conf situé dans NetBeansInstallationDirectory / etc /.
  5. Recherchez la ligne commençant par "netbeans_jdkhome" et remplacez le chemin par celui copié à l’étape 3.
  6. Lancez-vous et NetBeans et traitez vos yeux avec de belles polices!

Avant: NetBeans avant d’utiliser TuxJDK

Après: NetBeans après avoir utilisé TuxJDK

    
réponse donnée Rohit Awate 23.03.2018 - 17:26
la source
0

Installez simplement zulu jdk à partir de lien :)

    
réponse donnée Arun 30.03.2018 - 14:39
la source
-1
J'avais le même problème sur Mint 12. Je l'ai résolu en entrant les "Paramètres avancés" - "gt" et en réduisant la police par défaut de 11 à 10. J'ai réduit toutes les polices de la liste à la cohérence.

Il doit y avoir un problème avec la police Cantarell 11.

    
réponse donnée Alan B. Dee 23.12.2011 - 19:25
la source

Lire d'autres questions sur les étiquettes