Ubuntu 15.10 et 16.04 continuent à geler de façon aléatoire

78

Ce problème, je l’avais avec 15.10 et il est toujours là après la mise à jour de 16.04. Le système entier se bloque, plus aucune entrée clavier / souris ne fonctionne. J'ai essayé diverses combinaisons de clavier (trouvées sur Internet, comme Alt + SysRq + REISUB et autres), mais aucune d'entre elles n'a réellement fonctionné. Le système ne répond plus du tout, seul un arrêt forcé fonctionne à ce stade. Il est intéressant de noter que je ne peux pas corréler ce gel avec un programme ou une application spécifique, car le système se bloque parfois même en effectuant les opérations les plus simples, telles que l’ouverture du terminal ou la recherche Unity.

Je serais intéressé si un journal enregistré contient des informations utiles sur ces blocages.

Merci.

    
posée Radu Erdei 24.04.2016 - 11:07
la source

6 réponses

44

Je rencontrais un problème similaire sur mon Ubuntu 16.04. Il gèlait beaucoup au hasard et je devais effectuer un arrêt forcé à chaque fois.

Mettre à niveau le noyau vers 4.7-rc3 n'a pas fonctionné pour moi!

J'ai découvert qu'aucune zone de mémoire d'échange n'avait été allouée ( sudo swapon --show ne renvoyait rien et free -h indiquait qu'un espace de 0 octets était alloué à la mémoire d'échange) pour mon compte. Ubuntu OS (j'ai un système à double démarrage: Windows 7 et Ubuntu 16.04). J'ai alloué de l'espace d'échange pour Ubuntu et devinez quoi, , le problème a disparu! J'espère que cela t'aides. :)

Modifier : je me suis trompé! Ce problème n’a pas été résolu et n’a rien à voir avec la mémoire swap, bien que l’allocation de mémoire swap ait apparemment corrigé un autre type de blocage dans lequel un accès permanent au disque dur se produit pendant le gel et dans lequel il est possible de tuer le dernier processus de manière forcée % du clavier) pour récupérer du gel.

Cependant, ce problème (où rien ne fonctionne sauf un arrêt forcé fonctionne pour récupérer du gel) peut être lié au noyau et si la mise à niveau du noyau ne peut pas résoudre le problème, alors une solution de contournement pourrait être pour ajouter la déclaration alt+sysrq+F dans le fichier de configuration grub :

ÉTAPES

  1. intel_idle.max_cstate=1
  2. Il existe une ligne dans laquelle: sudo nano /etc/default/grub (comme celui-ci), à remplacer par: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  3. Enregistrez-le (CTRL + O)
  4. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
  5. sudo update-grub

J'essaierai ceci si je fais face au problème à nouveau (puisque dans mon cas, ce problème est maintenant très rare, il ne s'est produit qu'une seule fois dans la semaine après l'allocation d'échange, ce qui a conduit à la confusion), mais certaines personnes ont résolu ce problème. genre de problème par cette solution de contournement.

Mise à jour tardive: En fait, j'ai essayé la solution de contournement mentionnée ci-dessus quelques semaines après la publication de la modification (probablement parce que le problème est réapparu à nouveau, mais ce n'était pas fréquent, à coup sûr). Après avoir modifié le fichier grub, le problème a été résolu complètement et je n’ai rencontré aucun type de gel par la suite. Cette solution de contournement semble donc être une bonne solution! :) Désolé pour la mise à jour tardive.

    
réponse donnée Snehasish Karmakar 08.07.2016 - 22:07
la source
11

Allez à "synaptic-settings-repositories-drivers supplémentaires". Voir si vous avez un bouton radio "Inconnu Inconnu" Si vous avez, alors sélectionnez-le comme je l'ai dans l'image. Deux semaines, je n'ai pas eu un gel.

    
réponse donnée user3783628 13.09.2017 - 18:40
la source
10

La mise à jour du noyau a fonctionné pour moi. Je soupçonne que le problème était lié aux graphiques car j'ai remarqué un avertissement lors de la mise à niveau. J'ai suivi les étapes à l'adresse link pour mettre à jour le noyau, puis téléchargé le firmware manquant. Toutes les étapes détaillées ci-dessous.

Téléchargez les fichiers nécessaires:

wget kernel.ubuntu.com/~kernel-ppa/mainline/v4.7-rc3-yakkety/linux-headers-4.7.0-040700rc3_4.7.0-040700rc3.201606121131_all.deb 
wget kernel.ubuntu.com/~kernel-ppa/mainline/v4.7-rc3-yakkety/linux-headers-4.7.0-040700rc3-generic_4.7.0-040700rc3.201606121131_i386.deb 
wget kernel.ubuntu.com/~kernel-ppa/mainline/v4.7-rc3-yakkety/linux-image-4.7.0-040700rc3-generic_4.7.0-040700rc3.201606121131_i386.deb

Une fois les fichiers téléchargés, installez-les avec dpkg :

sudo dpkg -i linux-headers-4.7*.deb linux-image-4.7*.deb

Recherchez les avertissements dans la sortie. Je suis tombé sur l'avertissement: W: Possible missing firmware /lib/firmware/i915/skl_guc_ver6.bin for module i915

Téléchargez ce module manquant et copiez-le dans le dossier indiqué:

wget https://ftp2.halpanet.org/source/_dev/linux-firmware.git/i915/skl_guc_ver6.bin
sudo cp skl_guc_ver6.bin /lib/firmware/i915/

Cela n'est peut-être pas nécessaire, mais j'ai réinstallé le noyau v4.7 après avoir copié le module. Cette fois, l'avertissement ne s'est pas affiché:

sudo dpkg -i linux-headers-4.7*.deb linux-image-4.7*.deb

Une fois réinstallé, mettez à jour GRUB et redémarrez:

sudo update-grub
sudo reboot

Après cela, mon installation Ubuntu 16.04 s’est bien déroulée sur le noyau 4.7RC3.

    
réponse donnée Daniel 19.06.2016 - 22:59
la source
2

Essayez de mettre à jour votre noyau. J'avais installé Ubuntu 16.04 et le problème était persistant.

Je pensais que c’était mon ordinateur portable et j’ai retiré Ubuntu et installé Lubuntu. Après un moment, il a gelé aussi.

J'ai mis à jour mon noyau et le problème a été résolu immédiatement. Dites-moi si vous avez besoin d’aide pour mettre à jour votre noyau.

    
réponse donnée germain rwibutso 29.04.2016 - 12:56
la source
2

Ma réponse n’est pas une solution permanente, mais elle devrait résoudre le problème lorsqu’elle se présente. Avant de continuer, permettez-moi de dire que cette question a été posée et que de nombreuses versions ont été résolues. Les réponses fournies ici sont des choses que j'ai moi-même tentées mais qui ne se sont pas avérées permanentes.

Après les mises à jour, etc., ces modifications ont été annulées et par désagrément, j’ai choisi de ne plus les modifier. De plus, certaines des réponses fournies ici et dans les autres discussions sur ce sujet ne m'ont pas du tout aidé.

Donc, si vous continuez à rencontrer un problème, veuillez essayer

Ctrl + Alt + F1
Ctrl + Alt + F7

Ceci devrait résoudre temporairement le problème. Avant que les gens ne votent, votez pour cela et j’accepte qu’ils le feront. Tenez compte de l’ancienneté de ce problème et du fait qu’il continue de se poser. Je répète que je vis cela depuis assez longtemps et que, pour l’instant, c’est le seul moyen que j’ai pu résoudre immédiatement.

    
réponse donnée Afflicted 18.05.2017 - 02:28
la source
2

Re: gel de l'écran avec Ubuntu 16.04

Cela n’a commencé que récemment avec moi. Après avoir regardé sur mon écran, j’ai remarqué que le processus Web Content prenait presque tout le temps processeur et beaucoup de mémoire jusqu’à épuisement de mes 6 Go.

Je l'ai résolu en utilisant les procédures suivantes, après avoir supprimé une extension de l'éditeur de cookies:

1 Sous la préférence Firefox: acceptez les cookies tiers uniquement à partir des sites Web visités!

2 modifiez cela dans GRUB

Ubuntu 15.10 et 16.04 gardent le gel de manière aléatoire

There is a line in that: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (like this), replace with: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

3 Mon SWAP n'était pas utilisé du tout! J'ai doublé mon espace d'échange avec celui de ma mémoire (12 Go)

lien

Je gèlerais encore ou fonctionnerais très lentement, enfin résolu avec ceci:

4 J'ai installé noscript depuis Firefox / Tools / extensions et n'autorise qu'un petit nombre de sites à exécuter JS.

noscript.net/forums

    
réponse donnée John Brown 10.04.2018 - 05:38
la source

Lire d'autres questions sur les étiquettes