Pourquoi Firefox ne peut-il pas exécuter les fichiers locaux .swf?

65

Mon objectif est d’exécuter des fichiers .swf via Firefox et NON un lecteur autonome.

Lorsque vous essayez d’exécuter des fichiers .swf locaux sur Firefox 29.0 (actuellement sur 14.04), le navigateur ouvre la fenêtre d’invite Ouvrir avec / Enregistrer le fichier même si le plug-in Flash est installé sur le navigateur. Cliquez avec le bouton droit sur le fichier et cliquez sur Ouvrir avec ... & gt; Firefox permet au navigateur d'ouvrir un nouvel onglet, puis l'invite à ouvrir à nouveau avec / Enregistrer le fichier. En sélectionnant Firefox via cette fenêtre d'invite, Firefox restera ouvert à nouveau dans un nouvel onglet.

Lorsque vous accédez aux fichiers .swf en ligne, ils s'exécutent normalement et Firefox affiche même l'indicateur de plug-in d'aspect Lego dans la barre d'adresse indiquant que "Adobe Flash" est activé pour l'adresse à laquelle j'accède. / p>

Dans l'onglet Applications des préférences de Firefox, les fichiers SWF sont actuellement définis sur "Utiliser Shockwave Flash (dans Firefox)", je ne comprends donc pas pourquoi il ne fera pas ce qu'il dit pour les fichiers locaux.

MISE À JOUR: Apparemment, Firefox a séparé les entrées "Shockwave Flash File" dans l'onglet Applications de ses préférences pour différents types de mimes. J'ai trouvé une solution de contournement que j'ai saisie ci-dessous.

    
posée maki57 07.06.2014 - 20:39
la source

2 réponses

49

Une autre option consiste à créer ~/.mime.types dans le répertoire de base avec le contenu suivant:

application/x-shockwave-flash       swf swfl

De cette façon, il ne sera pas écrasé lors de la mise à niveau du système.

Si vous voulez, vous pouvez copier, coller et exécuter cette commande pour ce faire:

echo 'application/x-shockwave-flash       swf swfl' >> .mime.types

Aucune autre commande nécessaire, même pas un redémarrage du navigateur.

    
réponse donnée Aleh 01.12.2014 - 23:52
la source
63

Vous avez trouvé une solution de contournement ici basée sur un thread Arch ici . D'après ce que j'ai compris, il n'y a qu'un problème avec Firefox qui ne prend pas correctement en charge un certain type MIME.

Modifiez /usr/share/mime/packages/freedesktop.org.xml en tant que root et remplacez ce qui suit:

<mime-type type="application/vnd.adobe.flash.movie">

Avec:

<mime-type type="application/x-shockwave-flash">

Et puis exécutez:

sudo update-mime-database /usr/share/mime

Les fichiers .swf locaux fonctionnent correctement maintenant.

    
réponse donnée maki57 09.06.2014 - 19:24
la source

Lire d'autres questions sur les étiquettes