Comment puis-je désactiver le bouton central de la souris en cliquant sur Coller?

96

Est-il possible de désactiver le comportement du bouton du bouton central de la souris qui est ici par défaut sur gnome?

J'ai une molette de souris sensible et chaque fois que je fais défiler des textes, il colle parfois des choses au hasard dans le texte. Je perds beaucoup de crédibilité lorsque j'envoie un fichier à quelqu'un qui a des extraits de texte aléatoires collés partout.

J'ai vu un solution qui associe le bouton central de la souris à un bouton de la souris inexistant, mais cela implique de supprimer complètement le bouton central de la souris (pas de fermeture par tabulation, ouverture automatique des liens dans un nouvel onglet, etc. ). Je voudrais garder le bouton central de la souris actif, désactivez simplement le comportement de collage.

Cela se produit également lorsque je fais défiler le texte avec mon pavé tactile (touchez accidentellement deux doigts sans bouger, bam.)

Donc, le problème ne sera pas résolu en changeant simplement pour une nouvelle souris (en fait, je crois que cela se produit plus souvent avec mon pavé tactile qu'avec ma souris).

    
posée levesque 21.09.2010 - 17:26
la source

21 réponse

15

Pour une solution au problème, consultez ce guide. J'ai écrit: lien

Ou plus directement, voici le correctif pour désactiver la fonctionnalité "Coller avec le bouton central de la souris" dans GTK: lien

    
réponse donnée Jelle Geerts 17.09.2011 - 23:27
la source
33

Jared Robinson a proposé une solution simple qui fonctionne sur ma machine:

Exécutez la commande suivante:

xmodmap -e "pointer = 1 25 3 4 5 6 7 8 9"

Pour conserver ce comportement, modifiez ~ / .Xmodmap et ajoutez

pointer = 1 25 3 4 5 6 7 8 9
    
réponse donnée Jay Goldfarb 06.08.2011 - 02:32
la source
23

Je me rends compte que ce n’est pas exactement la réponse que vous voulez, mais vous pouvez la désactiver dans Firefox (par exemple, si la fonctionnalité ne vous dérange pas, mais que vous souhaitez toujours cliquer sur Firefox pour ouvrir des liens dans de nouveaux onglets) / p>

À propos de: config, set

middlemouse.contentLoadURL false
middlemouse.paste false

Pas ce que vous avez demandé, mais comme cette question est liée à quelques endroits, j'espère que quelqu'un trouve cette réponse utile.

    
réponse donnée Ben 21.01.2012 - 10:11
la source
18

Ce n'est actuellement pas possible - bien que, comme vous l'avez mentionné, il existe des moyens de désactiver le bouton MOUSE 3 - ou de le remapper - aucun de ceux-là n'atteint la source du problème. La sélection primaire X11.

Bien que ce ne soit pas une solution, j'espère que cette explication le fera clairement savoir. Dans Ubuntu, il y a deux presse-papiers au travail. Un, que tout le monde connaît, le presse-papiers freedesktop.org (capture de la commande Ctrl + C ). - X11. Le serveur X (X11) gère trois autres presse-papiers: Sélection primaire , Sélection secondaire et Presse-papiers . Lorsque vous sélectionnez du texte avec votre pointeur, il est copié dans un tampon dans le XServer, la sélection principale, et attend le collage à l'aide du bouton Souris 3. Les deux autres ont été conçus pour être utilisés par d'autres applications dans le but de partager un presse-papiers commun entre les applications. Dans ce cas, le gestionnaire de presse-papiers freedesktop.org dans Ubuntu le fait déjà pour nous.

Dans la mesure de mes recherches, je ne peux pas trouver un moyen de désactiver le gestionnaire de sélection X11. Il n'y a pas d'indicateurs de compilation, d'applications ou de valeurs de configuration pouvant désactiver cette option. Il existe différentes manières d’envisager chaque application (la majorité de ces applications étant en ligne de commande), mais rien à l’échelle mondiale.

Je me rends compte que ce n’est pas une solution idéale - mais semble être la vérité sur le problème. La seule solution pertinente que je pourrais rassembler est en fait un hack, créez un script qui exécute une boucle while infinie qui remplace simplement la sélection primaire par une valeur nulle.

Installez d'abord xsel (Outil de manipulation de la sélection X) sudo apt-get install xsel

Le code est le suivant:

while(true)
do
    echo -n | xsel -n -i
    sleep 0.5
done

Si vous placez ceci dans un script et l'ajoutez à vos scripts de démarrage, cela ne devrait pas poser de problème.

    
réponse donnée Marco Ceppi 23.09.2010 - 20:56
la source
15

J'utilise gnome-tweak-tool pour désactiver le collage du bouton du milieu dans Ubuntu 16.04.

sudo apt install gnome-tweak-tool

Recherchez "tweak tool" dans les applications installées. Exécute-le.

Ou tapez simplement gnome-tweak-tool dans un terminal.

Allez dans "Clavier et souris" - & gt; "Coller un clic du milieu" Éteignez.

C'est tout. Testé sur Ubuntu 16.04

    
réponse donnée Sunny127 15.01.2017 - 13:03
la source
14

D'une certaine manière, je me suis retrouvé sans aucun fichier xmodmap sur mon installation Ubuntu, alors j'ai dû trouver une approche différente de ce problème.

Consultez la commande xinput .

xinput list | grep -i mouse

qui répertorie les informations relatives à votre souris. Il montre que ma souris est "Dell Premium USB Optical Mouse" et que je possède également une "émulation de bouton de souris Macintosh". Armé de cette information, je peux

xinput get-button-map "Dell Premium USB Optical Mouse"

qui me donne une liste qui ressemble à

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18

Voici les connaissances utiles et requises. Ma souris a théoriquement 18 boutons. L'action par défaut de chaque bouton porte le même nom que son numéro de bouton. En d'autres termes, le bouton 1 effectue l'action 1, le bouton 4 effectue l'action 4, etc. L'action 0 signifie "désactivé".

La position dans la liste indique la fonction attribuée à ce bouton. Donc, si ma carte lisait

1 3 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 

cela signifierait que le bouton 1 (position 1) effectue l'action 1 (bouton gauche normal), le bouton 2 (position 2) action 3 (bouton central) et le bouton 3 (position 3) action 2 (bouton droit). / p>

Pour faire une souris gaucher, il suffirait d'une carte de boutons qui commence

3 2 1 4 5 .....

Ou, dans votre cas, il semble que vous vouliez que le bouton du milieu fasse la même chose que le bouton 1 (bouton de gauche) pour que votre carte doive démarrer

1 1 3 ....

Je réinitialise les mappages des boutons de la souris:

xinput set-button-map "Dell Premium USB Optical Mouse" 1 1 3 5 6 6 7 8 9 10 11 12 13 14 15 16 17 18

Dans votre cas, vous pouvez avoir un nombre différent de boutons mappés et une carte de boutons spéciale déjà définie. De même, votre souris a également un nom différent. Tout d'abord, obtenez le "nom" de votre souris. Ensuite, utilisez l'opération get-button-map pour trouver la carte du bouton de base. enfin, utilisez l'option set-button-map en modifiant le bouton 2 pour effectuer l'action 1.

Ce n’est pas un changement permanent. J'ai ajouté le code nécessaire à mon .bashrc afin qu'il s'exécute chaque fois que je me connecte ou que j'ouvre un terminal.

J'espère que ça aide.

    
réponse donnée Wes Miller 12.01.2012 - 13:58
la source
4

Je suggère d’utiliser l’un d’entre eux, qui fonctionne le mieux pour moi:

en utilisant xbindkeys: chaque fois que le bouton du milieu est pressé, effacez le presse-papier primaire. Au moins sur mon système, il est effacé avant le collage. Détails: créer xbindkeys-config:

xbindkeys --defaults > $HOME/.xbindkeysrc

Collez le nouveau raccourci clavier suivant:

"xclip -i /dev/null"    
    b:2''

Rechargez les clés xbind (par exemple, killall xbindkeys, xbindkeys). Fait.

en utilisant xdotool: Effacer le presse-papiers sur le changement de focus de la fenêtre (devrait fonctionner avec la plupart des gestionnaires de fenêtres). Détails: Exécutez la commande suivante:

xdotool search --onlyvisible . behave %@ focus exec xclip -i /dev/null

Notez qu'avec cette commande, vous pouvez toujours utiliser le presse-papiers primaire dans la même fenêtre ou appuyer sur middlemouse sur une autre fenêtre AVANT de la focaliser (si "focus suit mouse" ou quelque chose n'est pas activé). p>     

réponse donnée spawn 22.02.2016 - 12:10
la source
3

Le meilleur moyen que j'ai trouvé jusqu'à présent est d'utiliser EasyStroke, qui intercepte globalement les clics du bouton central et permet de se comporter comme bouton central uniquement dans certaines applications.

Vous pouvez ajouter un "groupe" dans EasyStroke pour appliquer cette interception dans plusieurs applications à la fois. Je me suis fixé pour désactiver le clic du milieu dans certains de mes éditeurs de texte, IDE et MATLAB uniquement et fonctionne comme prévu.

Référence: lien

Complete EasyStroke How-To: lien

    
réponse donnée dbdq 03.02.2013 - 13:13
la source
2

Ce comportement du bouton du bouton central de la souris est une fonctionnalité du serveur X (et de gpm sur la console texte) et, à ma connaissance, X.org ne peut pas être configuré pour le désactiver. changez le mappage des boutons physiques de la souris comme d'autres l'ont déjà suggéré.

Les chances sont bonnes que vous puissiez configurer votre pavé tactile pour éviter les clics intermédiaires indésirables, voir les paramètres de gpointing-device (non installé par défaut) ou la page de manuel synaptics si vous préférez utiliser votre éditeur pour la configuration.

    
réponse donnée Florian Diesch 23.09.2010 - 20:52
la source
2

le lien ci-dessous a résolu le problème pour moi.

lien

la page référencée par le lien ci-dessus contient une section sur la façon de désactiver le collage de la souris du milieu sur la molette, en exécutant quelques commandes que l'utilisateur peut extraire du mappage des boutons de la souris. comme expliqué dans la page j'ai désactivé le bouton du milieu en exécutant la commande:

$ xinput set-button-map 4 1 0 3
    
réponse donnée Ahmad Bawaneh 05.01.2014 - 15:38
la source
1

J'ai eu le même problème il y a quelques mois et je l'ai résolu en changeant la souris! Mais, comme vous, j'étais frustré par le fait que le simple problème de la cartographie des boutons ne puisse pas être résolu de manière élégante par un correctif logiciel. Heureusement, j'ai eu le problème sur mon ordinateur de travail et mon employeur possède une variété de contrôleurs de souris de rechange. C'était un correctif sans frais!

Je pense qu’une bonne implémentation matérielle de la souris ne devrait pas envoyer de clics au milieu tout en faisant défiler. Récemment, j'ai trouvé ce comportement ennuyeux même avec Windows!

Maintenant que j'ai corrigé le bogue matériel avec la solution matérielle appropriée (changez la souris), j'ai même commencé une addiction à "coller sur un comportement de clic central"

Bon linuxing!

Cordialement,

    
réponse donnée Jonathan 16.08.2012 - 20:44
la source
1

SW: Ubuntu 14.04, avec Gnome en recul. HW: J'ai un ordinateur portable et le bouton du milieu est en fait la souris sur l'ordinateur portable. Solution: Allez dans le centre Ubuntu SW et téléchargez Unity Tweak Tool. Commencez Tweak Tool. Sous les paramètres de la souris, il est possible d'activer / désactiver l'insertion de clics au milieu. Passez une bonne journée.

    
réponse donnée user2712329 12.09.2014 - 01:32
la source
1

J'ai essayé l'astuce de redirection xinput, en changeant le bouton central de la souris (en fait une roue) pour qu'il agisse comme le bouton gauche de la souris. Cela fonctionne toujours comme une roue, et a (apparemment) cessé de coller des choses dans des endroits aléatoires au milieu de mon code source pendant que je défilais.

Dans mon cas, la commande était

xinput set-button-map "PixArt USB Optical Mouse" 1 1 3 4 5 6 7 8 9 10 11 12 13 14 15 16

mais YMMV par modèle de souris.

    
réponse donnée Stephen Bloch 03.12.2014 - 21:13
la source
1

Je peux avoir une réponse partielle pour vous, si vous utilisez un lenovo X ... avec point de contact / pavé tactile. Il y a un bug "connu" avec les boutons de la souris synaptics. Si vous essayez une souris USB et sans aucun problème, mais avec la souris à pavé tactile / tactile (intégrée au clavier), vous avez des réponses aléatoires qui peuvent supprimer des bandes de texte au fur et à mesure de la frappe.

lien

Si cela correspond à votre situation, ajoutez votre nom à la liste des personnes ayant identifié ce bogue, à ce rapport de bogue. Peut-être que si nous sommes nombreux à en faire état, cela serait corrigé.

    
réponse donnée Jont Allen 15.07.2016 - 01:19
la source
0

C'est plus qu'une fonctionnalité gnome, je pense que ça fonctionne presque partout, ça marche aussi dans la console, et je pense que ça fonctionnait même dans mon "Linux from Scratch".

Donc, c'est vraiment une fonctionnalité de base peut-être même quelque part dans le noyau.

BTW: C'est vraiment utile, et ce n’est pas le collage comme Ctrl + V, tout ce qui est marqué avec le curseur va dans un second stockage et avec middleclick peut coller, ce que vous avez marqué en dernier.

    
réponse donnée phiphi 23.09.2010 - 20:08
la source
0

En utilisant ce que j'ai appris dans les articles ci-dessus, ce bash one-liner fonctionne parfaitement pour moi ...

mouse_id=$(xinput list | grep 'Mouse' | awk '{print }' | sed 's/[^0-9]//g') && xinput set-button-map "$mouse_id" 1 0 3
    
réponse donnée Scott 04.12.2013 - 17:42
la source
0

Vous pouvez essayer d’émuler une souris à deux boutons. Avec une souris à deux boutons, vous collez en cliquant sur les deux boutons de la souris en même temps (plutôt que sur la molette).

Installer les paramètres de gpointing-device:

sudo aptitude install gpointing-device-settings

lien

Sinon, si vous ne souhaitez pas installer les paramètres de gpointing-device et que vous n'êtes pas dérangé par les options de ligne de commande, voir lien Sur cette page du wiki, il existe plusieurs options de ligne de commande / configuration, choisissez celle que vous préférez.

    
réponse donnée Panther 12.01.2012 - 19:47
la source
-1

C'est une bonne question pour laquelle je n’ai pas encore de réponse. Une solution rapide et sale consiste à le remapper sur 0, mais sur 1. De cette façon, il tourne au milieu "clic" pour faire un clic gauche, et n'affecte pas votre scroller ... C'est le meilleur que je puisse imaginer.

Remarque: cette information provient des forums Ubuntu , et non de ma propre aubaine! :)

    
réponse donnée Tiede 23.09.2010 - 19:49
la source
-1

Si vous utilisez Chrome / Chromium, vous pouvez installer une extension qui vous permettra de faire défiler la plupart des pages Web.

Lien d'extension AutoScroll:

lien

    
réponse donnée Robert Coleman 28.11.2011 - 07:43
la source
-1
Y'all pourrait simplement et rapidement résoudre ce problème comme je viens de le faire en dévissant la souris, en prenant une pince à bec effilé et en tirant physiquement le bouton central de la souris. Garanti pour résoudre le problème - en supposant que vous ne l'utilisez jamais de toute façon - comme moi.

    
réponse donnée Kevin McCracken 17.03.2016 - 15:44
la source
-3

as-tu regardé gpm? Plus d'infos sur lien . Disponible via sudo aptitude install gpm sur lucid. Je ne vois pas le programme disable-paste dans le paquet ubuntu, cependant, l'option -A peut être utile.

    
réponse donnée koushik 21.09.2010 - 18:27
la source

Lire d'autres questions sur les étiquettes