Comment empêcher les programmes de se lancer de manière optimale?

16

Chaque fois que je lance un programme, disons firefox, il démarre au maximum, comment puis-je empêcher que cela se produise. C'est tellement ridicule qu'ils ont cela comme défaut.

    
posée Scott 06.05.2011 - 04:15
la source

5 réponses

11

Juste pour signaler que le pourcentage d’auto-maximisation est maintenant configurable dans 11.10 dans ccsm (le gestionnaire de paramètres CompizConfig). Idiotiquement, il est codé en dur en 11.04, malgré le fait qu'il y ait eu des problèmes avec ce pourcentage (à l'origine, 60%, se plaignaient, et la réponse était pour changer la valeur plutôt que de faire la chose évidente de la rendre configurable car cela va clairement être utilisateur et système- spécifique). Je n'ai pas trouvé de moyen pratique de sauvegarder le correctif vers 11.04. (Vous pouvez toujours mettre à jour, bien sûr.)

Mais le 11.10:

  • Installez ccsm si vous ne l'avez pas déjà (bizarrement, il n'est pas installé par défaut)
  • Exécuter
  • Allez dans Bureau
  • Cliquez sur Plugin Ubuntu Unity
  • Accédez à l'onglet Expérimental et vous devriez voir ceci: Définissez la valeur Augmenter automatiquement la valeur sur 100% pour la désactiver complètement ou sur un pourcentage plus élevé si vous aimez le comportement, mais que la valeur par défaut de 75% est incorrecte.

Sources:

réponse donnée T.J. Crowder 23.10.2011 - 12:54
la source
8

Pour résoudre ce problème avec Unity 2d, procédez comme suit:

gconftool -s /apps/metacity/general/auto_maximize_windows -t bool false

Ou lancez gconf-editor et changez cette clé en false.

Cela me contrariait aussi. :( Le correctif est différent pour l'unité 2d que pour l'unité 3D,

    
réponse donnée ldrn 20.05.2011 - 04:02
la source
4

Unity a été conçu pour maximiser automatiquement les fenêtres si elles occupent une certaine quantité d’écran. À ma connaissance, toutes les fenêtres ne le font pas, mais la plupart le feront. Actuellement, vous ne pouvez pas désactiver cette option dans Unity 2D, mais vous pouvez désactiver la grille dans ccsm ou modifier les valeurs à votre convenance pour éviter cette maximisation.

En principe, vous pouvez désactiver le bord supérieur (définissez-le sur none) pour éviter la maximisation automatique de Windows.

    
réponse donnée RolandiXor 11.05.2011 - 03:01
la source
3

Trouvé dans ce sujet , testé, et cela semble être vrai.

  

Vous devez ouvrir l'application, redimensionner la fenêtre pour qu'elle soit inférieure à 75% de la taille de l'écran, puis fermez l'application.   Par défaut, toute fenêtre supérieure à 75% sera maximale lors de l'ouverture. - mc4man

En outre, selon le même thread, ce comportement ne peut être modifié qu'en modifiant l'unité source et la recompilation. Pas la réponse que nous aimerions entendre ...

    
réponse donnée Dorkus1218 06.05.2011 - 04:58
la source
3

Installez "Advanced Desktop Effect Settings" (ccsm) via le centre de logiciels et lancez-le.

Faites défiler jusqu'à "Window Management" et désélectionnez "Snapping Windows" et "Grid". Cela désactivera l'accrochage sur les bords de l'écran et maximisera lorsque vous atteindrez les coins.

En outre, vous pouvez décider si Windows doit être centré, positionné intelligemment ou s’il doit toujours être agrandi, etc. dans "Placer Windows", également sous "Gestion des fenêtres"

    
réponse donnée K. Hendrik 11.05.2011 - 02:29
la source

Lire d'autres questions sur les étiquettes