L'audio a cessé de fonctionner soudainement au 12.04

15

Mon audio ne fonctionne plus dans Xubuntu 12.04 après avoir fonctionné correctement pendant environ un an. Cela s'est produit juste après avoir visité le site Web suivant et installé une application de navigateur audio pour télécharger des échantillons de voix afin de créer un programme de reconnaissance vocale open-source: lien

Je ne sais pas si c'est ce qui a causé le problème, mais l'audio a cessé de fonctionner au même moment où j'ai installé cette application Web.

Lorsque je tape dans le terminal

pulseaudio -D

Je reçois ce qui suit:

E: [pulseaudio] main.c: Daemon startup failed.

J'ai essayé le suivant:

sudo apt-get purge pulseaudio
sudo apt-get install pulseaudio

Quand je tape "pulseaudio" à l'invite de commande, j'obtiens:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
    
posée Ben 12.09.2012 - 04:47
la source

8 réponses

6

Cela m'est arrivé aussi. Je pense que la raison principale est que le démon pulseaudio n'est pas tué correctement.

Première exécution de pulseaudio --kill puis de pulseaudio --start .

Cela a résolu le problème pour moi.

    
réponse donnée user111874 23.02.2013 - 02:47
la source
4

Il y a deux solutions possibles, voici les deux méthodes que j'ai essayées (je ne suis pas sûr de savoir lequel des deux a résolu le problème.)

Fix 1

J'ai branché des écouteurs et tué pulseaudio :

pulseaudio --kill

alors je l'ai recommencé:

pulseaudio --start

Cela semblait résoudre le problème à partir de là.

Fix 2

Utiliser pavucontrol à la place:

sudo apt-get install pavucontrol
pavucontrol
    
réponse donnée Sam Mearns 26.04.2014 - 15:36
la source
2

Ceci est une mise à jour pour 13.10.

J'ai utilisé le pavucontrol:

sudo apt-get install pavucontrol
pavucontrol
    
réponse donnée user205795 21.10.2013 - 21:54
la source
1

Cela a fonctionné pour moi

sudo /usr/bin/amixer set Master toggle

J'ai essayé toutes les autres choses suggérées dans ce sujet, et rien n'a fonctionné.

    
réponse donnée bjarque 08.03.2015 - 20:14
la source
1

Les étapes qui ont résolu un problème identique sur mon Ubuntu 16.04 étaient les suivantes:

rm -R ~/.config/pulse   # or rename this folder
sudo systemctl reboot   # logout and login doesn't do the job
    
réponse donnée pa4080 13.03.2018 - 10:22
la source
0

Vous pouvez essayer de supprimer ou de renommer le répertoire .pulse de votre homefolder, de votre déconnexion et de votre reconnexion. Un nouveau répertoire .pulse sera créé automatiquement par pulse, vous aurez donc probablement une configuration utile. Cela m'a aidé à plusieurs reprises lorsque j'ai eu des problèmes de pouls.

    
réponse donnée gemue2010 12.09.2012 - 06:21
la source
0

J'ai corrigé mon propre problème en saisissant simplement "alsamixer" sur la ligne de commande et en jouant avec certains paramètres tels que la désactivation de plusieurs commandes de volume pour différents composants et la résolution du problème. Probablement le logiciel de voxforge.org a coupé quelques contrôles de volume sur mon ordinateur et n'a pas réussi à les réactiver par la suite. Merci pour l'aide, tout le monde!

Donc, ma solution était:

alsamixer

et réactiver les différents contrôles de volume jusqu’à ce que le son revienne. Essayez également de basculer entre les cartes son avec F6. (Il est utile d’avoir une vidéo sur YouTube en arrière-plan ou de la musique sur une liste de lecture pour savoir quand le son est enfin de retour.)

    
réponse donnée Ben 28.09.2012 - 03:16
la source
0

J'ai le même problème:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

et supprimer / installer pulseaudio n'a pas aidé. Enfin, j'ai découvert que mon répertoire .pulse dans $HOME était manquant. Donc j'ai fait:

cd $HOME
mkdir .pulse
pulseaudio --kill
pulseaudio --start

et redémarré mon ubuntu. Après c'était bien.

    
réponse donnée ahe_borriglione 22.09.2017 - 09:19
la source

Lire d'autres questions sur les étiquettes