Comment réinitialiser le gestionnaire de protocole externe dans Chrome?

17

Il y a quelque temps, j'ai sélectionné "Ne rien faire" lorsque Chrome m'a demandé comment gérer une URL spécifique. Maintenant, je veux que Chrome lance xdg-open, qui peut à nouveau lancer l'application correcte, mais je n'arrive pas à comprendre comment annuler ma sélection "Ne rien faire". Des idées?

Merci!

    
posée Emil Lunde 14.05.2014 - 06:32
la source

2 réponses

14

J'ai trouvé un la solution à Windows, et il s'avère que cela fonctionne également sur Ubuntu:

  1. Fermer Chrome
  2. Ouvrez ~/.config/google-chrome/Local State dans un éditeur de texte.
  3. Recherchez protocol_handler .
  4. Pour que Chrome vous demande comment gérer à nouveau un protocole spécifique, supprimez la ligne correspondant à ce protocole dans la liste des schémas exclus.
  5. Enregistrer et quitter.

Mise à jour: protocol_handler a été déplacé dans le fichier Preferences dans le sous-répertoire Default . Si vous utilisez plusieurs profils, le fichier se trouve également dans les dossiers Profile 2 , Profile 3 , etc.

    
réponse donnée Emil Lunde 14.05.2014 - 07:04
la source
1

Sous Windows, ce paramètre semble maintenant être situé à

~/AppData/Local/Google/Chrome/User Data/Default/Preferences

Faites une recherche sur excluded_schemes . Ce sera un dictionnaire de noms de protocoles personnalisés défini sur true ou false . Recherchez le protocole personnalisé souhaité dans le dictionnaire et supprimez-le, enregistrez le fichier, puis redémarrez Chrome.

    
réponse donnée Brendan Abel 17.07.2017 - 20:29
la source

Lire d'autres questions sur les étiquettes