Comment activer l'hibernation?

416

Dans Ubuntu 12.04 et versions ultérieures, le mode veille prolongée a été désactivé par défaut dans policykit . Comment puis-je le réactiver?

    
posée Dima 12.01.2012 - 01:10
la source

10 réponses

335

Si cette réponse ne fonctionne pas dans Ubuntu 13.10, consultez ici une autre réponse

Vous pouvez suivre la documentation officielle ici . La mise en veille prolongée a été désactivée le 12.04 pour les machines non certifiées avec Ubuntu.

Afin d’activer le mode veille prolongée, vous devez tester s’il fonctionne correctement en exécutant sudo pm-hibernate dans un terminal. Le système va essayer d'hiberner. Si vous pouvez redémarrer le système, vous pouvez plus ou moins ajouter une substitution.

Pour ce faire, commencez l’édition:

sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Remplissez-le avec ceci:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Ou dans 14.04 et plus tard:

[Re-enable hibernate by default for login1]
  Identity=unix-user:*
  Action=org.freedesktop.login1.hibernate
  ResultActive=yes

[Re-enable hibernate for multiple users by default in logind]
  Identity=unix-user:*
  Action=org.freedesktop.login1.hibernate-multiple-sessions
  ResultActive=yes

Enregistrez en appuyant sur Ctrl - O puis entrez puis quittez nano en appuyant sur Ctrl - X .

Redémarrer et la veille prolongée est de retour!

Ou exécutez killall unity-panel-service pour simplement réinitialiser le menu.

Certains utilisateurs devront alors exécuter sudo update-grub pour que l'option de mise en veille prolongée soit disponible dans le menu Power. Certains utilisateurs devront peut-être au moins se déconnecter, puis se connecter pour le faire apparaître dans le menu d'alimentation (en haut à droite).

    
réponse donnée Dima 13.04.2017 - 14:24
la source
44

Tout d'abord, vous devez tester votre machine pour prendre en charge l'hibernation. Testez-le avec la commande:

 sudo pm-hibernate
 # or for newer Ubuntus like 17.04
 sudo systemctl hibernate

Ubuntu 16.04 et supérieur

Pour activer l'interface, vous devrez exécuter sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla et remplir avec:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes

Ubuntu 14.04 et 15.04

Pour activer l'interface, vous devez exécuter sudo nano /etc/polkit-1/localauthority.conf.d/52-enable-hibernation.conf pour Ubuntu 14.04 et 15.04 et remplir avec:

[Re-enable hibernate by default]
  Identity=unix-user:*
  Action=org.freedesktop.upower.hibernate
  ResultActive=yes

[Re-enable hibernate by default for login1]
  Identity=unix-user:*
  Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.hibernate-multiple-sessions
  ResultActive=yes

Il a plusieurs strophes, car vous pouvez avoir plusieurs utilisateurs (cela ne dépend pas de plusieurs utilisateurs ou de haut en tant que gestionnaire au lieu de login1)

p.s .: dernière documentation officielle lien

    
réponse donnée morhook 23.06.2014 - 21:17
la source
32

De plus, pour ceux qui veulent désactiver le bouton Suspendre (pour diverses raisons), procédez de manière analogue ...

Choisissez n’importe quel nom de fichier, mais c’est un nom de fichier / convention:

sudoedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.disable-suspend.pkla

Remplissez-le avec ceci:

[Disable suspend by default]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no

Ctrl + O , Entrez , Ctrl + X

Pas besoin de redémarrer, ça devrait disparaître dès que vous êtes dans le menu d’arrêt.

    
réponse donnée nacs 23.06.2012 - 02:56
la source
14

Encore une chose:

Lorsque vous souhaitez ajouter l’option Veille prolongée au panneau XFCE , vous devez cliquer avec le bouton droit de la souris sur votre nom (topright) et sélectionner properties .

Après cela, un écran apparaît:

Assurez-vous de cocher Hibernate comme je l’ai fait.

    
réponse donnée mreq 01.04.2013 - 10:04
la source
14

Tout d'abord, je vous recommande de tester si votre ordinateur portable prend en charge l'hibernation, car la raison pour laquelle l'hibernation est désactivée par défaut est que certaines machines ont parfois des résultats fatals. Testez votre machine en

Ctrl + Alt + T puis sudo pm-hibernate

Votre machine doit hiberner. Réveillez votre machine après l'hibernation et observez si elle se comporte mal ou si elle agit normalement. Si vous constatez une anomalie après l'hibernation, je vous conseille de ne pas poursuivre la procédure suivante. Cependant, si cela fonctionne correctement, continuez à activer l'hibernation par

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Modifiez le fichier ouvert et ajoutez les lignes suivantes:

[Re-enable hibernation]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Après cela, redémarrez votre ordinateur et, une fois connecté, vous devriez voir une option de veille prolongée dans le coin supérieur droit des paramètres.

    
réponse donnée kelvinelove 10.10.2013 - 16:13
la source
6

Si la réponse avec /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla ne fonctionne pas comme dans mon cas, n'oubliez pas de supprimer le fichier par:

sudo rm /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Et essayez d’utiliser TuxOnIce .

D'abord, assurez-vous d'avoir assez de swap. Il devrait être de la même taille ou plus grand que la quantité de votre RAM. Utilisez la commande

free

règle Swap & gt; Mem. Si ce n'est pas le cas, agrandissez votre taille de swap. Puis installez TuxOnIce by

sudo add-apt-repository ppa:tuxonice/ppa
sudo apt-get update
sudo apt-get install tuxonice-userui linux-generic-tuxonice linux-headers-generic-tuxonice

Ensuite, vous pouvez essayer de faire un test de mise en veille prolongée exécuté par:

sudo pm-hibernate

N'oubliez pas de sauvegarder votre travail avant de le faire.

Si tout s’est bien passé, votre ordinateur s’éteindra. Après l'avoir allumé, vous obtiendrez votre bureau dans l'état où vous l'aviez laissé avant l'hibernation.

    
réponse donnée Dee 10.10.2013 - 15:49
la source
5

Activation de la veille prolongée avec un script

J'ai traduit ci-dessus les réponses aux scripts bash . Cela rend l’installation sur plusieurs machines moins fastidieuse.

Script enable-hibernate :

#!/bin/bash
#http://askubuntu.com/a/94963/164341
cat << '_EOF_' |sudo tee /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
[Enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
_EOF_
clear
echo
echo 'Hibernate enabled.'
echo

Script disable-suspend :

#!/bin/bash
#http://askubuntu.com/a/154821/164341
cat << '_EOF_' |sudo tee /etc/polkit-1/localauthority/50-local.d/com.ubuntu.disable-suspend.pkla
[Disable suspend by default]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no
_EOF_
clear
echo
echo 'Suspend disabled.'
echo

Remarque: N'oubliez pas de chmod +x les deux scripts pour les rendre exécutables.

    
réponse donnée Serge Stroobandt 18.02.2014 - 16:27
la source
4

Une commande simple qui fait exactement la même chose que la réponse acceptée, sauf de manière non interactive:

cat <<EOF | sudo tee /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
EOF
    
réponse donnée kiri 24.10.2013 - 05:52
la source
2

En 12.04, j'ai activé avec succès l’option Veille prolongée dans le menu des indicateurs pour mettre en veille prolongée. Mais je n'ai toujours pas réussi à sortir de l'hibernation. J'ai suivi ces étapes pour résoudre ce problème:

Activer la veille prolongée en 12.04

Pour activer Hibernate, j'ai suivi cette réponse de Dima.

Après avoir activé la mise en veille prolongée, je pouvais hiberner. Mais le problème est que je ne peux pas réussir à quitter l'hibernation. Chaque fois que je démarre mon PC à partir de la veille prolongée, il démarre comme un démarrage normal. Donc, j'ai dû faire ces choses pour pouvoir quitter l'hibernation.

Les correctifs pour pouvoir reprendre la mise en veille prolongée

Il y a deux façons de résoudre ce problème.

1. Modification du fichier /etc/initramfs-tools/conf.d/resume

  1. Premièrement, obtenez l’UUID de la partition de swap.

     sudo blkid | grep swap
    

    Cela affichera une ligne similaire à celle-ci:

    /dev/sda12: UUID="a14f3380-810e-49a7-b42e-72169e66c432" TYPE="swap"
    

    La ligne actuelle ne correspondra pas à cela. Copiez la valeur de UUID entre "..." guillemet double.

  2. Ouvrez le fichier de reprise

    gksudo gedit /etc/initramfs-tools/conf.d/resume
    

    Et dans ce fichier, ajoutez une ligne comme celle-ci

    RESUME=UUID=a14f3380-810e-49a7-b42e-72169e66c432
    

    N'oubliez pas de remplacer la valeur UUID réelle obtenue à l'étape 1. Enregistrez le fichier et quittez gedit

  3. Ensuite, dans le terminal, exécutez cette commande

    sudo update-initramfs -u
    

Vous pourrez maintenant reprendre la veille prolongée

2. Modification du fichier /etc/default/grub .

  1. Ouvrez un terminal et exécutez la commande ci-dessous pour l'ouvrir

    gksudo gedit / etc / default / grub

  2. Il y aura une ligne comme GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" . Modifiez la ligne pour insérer RESUME=UUID=<your-uuid-value-here> après le mot splash .

    Par exemple dans mon cas, la ligne ressemble à ceci après édition

     GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=a14f3380-810e-49a7-b42e-72169e66c432" 
    

    Assurez-vous que vous avez utilisé la valeur UUID obtenue de la commande sudo blkid | grep swap .

  3. Ensuite, faites cette commande

     sudo update-grub
    

Cela vous permet également de reprendre votre hibernation avec succès.

Testé sur deux installations Ubuntu, les deux fonctionnaient

    
réponse donnée Anwar 19.09.2012 - 12:51
la source
0

J'ai Ubuntu Gnome 17.04 amd64 sur mon ordinateur portable. J'ai fait ce qui suit pour activer l'hibernation:

$ sudo apt-get install hibernate ( source )

Ceci a également installé libx86-1 uswsusp vbetool

Ensuite, je pourrais hiberner avec sudo systemctl hibernate . Il n'y a pas d'exécutable pm-hibernate dans mon chemin.

$ sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Inséré: ( source )

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit
ResultActive=yes

Install lien

    
réponse donnée ominug 29.04.2017 - 22:21
la source

Lire d'autres questions sur les étiquettes