Comment monter des dossiers partagés dans Ubuntu à l'aide des outils VMware?

116

Experts J'ai installé avec succès les outils VMware pour Ubuntu. Tout semble fonctionner correctement, mais les dossiers partagés ne sont pas montés automatiquement.
Comment les amener à travailler?

Si je lance vmware-hgfsclient dans le terminal, j'obtiens la liste des dossiers partagés, mais ls -l /mnt/hgfs est vide. En fait, il n'y a pas de hgfs dir dans /mnt . Je sais que je devrais probablement utiliser l'outil vmware-hgfsclient , mais je ne sais vraiment pas comment.

P.S. Je ne demanderais pas si je pouvais comprendre l'aide de vmware-hgfsclient que j'ai lue.

Des suggestions?

    
posée V-Light 06.03.2011 - 18:22
la source

13 réponses

82

Je me suis installé sur un hôte Windows 7 avec Ubuntu 11.04 Desktop sur lequel VMware Tools est installé.

Paramètres de la machine virtuelle

  • Partage de dossier = Toujours activé
  • Assurez-vous d'avoir au moins un dossier partagé entre l'hôte et l'invité

Sur l'invité Ubuntu

  • vérifiez / mnt / hgfs que vous pouvez accéder à votre dossier partagé.

    Si vous ne voyez pas vos dossiers partagés (montés automatiquement) dans /mnt/hgfs , exécutez les outils de configuration VMware:

    sudo vmware-config-tools.pl

  • mettez à jour votre fstab en utilisant les détails ci-dessous:

    gksu gedit /etc/fstab

    (J'utilise le bureau ubuntu, utilisez donc un autre éditeur de texte pour entrer la ligne suivante à la fin du fichier)

    .host:/{shared-folder} /{path-to-mount-on} vmhgfs defaults,ttl=5,uid=1000,gid=1000 0 0

  • Redémarrez votre vm (vous devrez peut-être redémarrer plusieurs fois ou recevoir un message d'erreur indiquant que vous ne parvenez pas à monter, ignorez simplement l'erreur et redémarrez)

réponse donnée Azizur Rahman 09.05.2011 - 01:03
la source
34

lancez vmware-config-tools.pl, AGAIN!

Référer: lien

    
réponse donnée ltd911 08.09.2011 - 18:38
la source
16

[UPDATE 2017-05-18] Cette réponse est obsolète pour Ubuntu plus récent que 15.10 (Wiley) . L'exécutable -8 & siteurl = manpages.ubuntu.com% 2F & ref = & amp; ss = 1872j594816j10 "> vmware-hgfsmounter n'est pas disponible dans Ubuntu depuis 16.04LTS (xenial). Bien que hgfsmounter soit toujours disponible disponible sur d'autres distributions Linux, depuis le La fonction hgfsmounter est toujours disponible dans le code source en amont sur GitHub . Si quelqu'un a mis à jour des informations, veuillez commenter ou éditer cette réponse, au lieu de voter en aval, car je pense que cette réponse est toujours valable pour les anciennes versions d'Ubuntu.

Cette réponse suppose également que vous n'utilisez pas VMWare Tools de VMWare mais que vous utilisez plutôt open-vm-tools de votre distribution Linux . VMWare a décidé de soutenir cette option en 2015. Voir KB2073803. Par conséquent, cette réponse suppose également que votre version d'Ubuntu peut installer les outils open-vm-tools à partir de son référentiel de logiciels.

OUTDATED FOR UBUNTU & gt; 15h10 (Wiley)

Cela a fonctionné pour moi en utilisant open-vm-tools du Ubuntu Software Center (trusty-14.04LTS montré - voir s'il vous plaît mise à jour ci-dessus) :

cd /mnt
sudo mkdir hgfs
sudo vmware-hgfsmounter .host:/'vmware-hgfsclient' /mnt/hgfs

en supposant bien sûr que j'avais déjà activé un dossier partagé depuis la machine hôte dans les paramètres de VMware Player.

Notez que vmware-hgfsclient renvoie la liste des dossiers partagés. activés dans les paramètres de VMware Player. Cette fonction est disponible à la fois pour open-vm-tools et vmware-tools.

Notez également que vmware-hgfsmounter est équivalent à

mount -t vmhgfs .host:/win7share /mnt/hgfs

ou pour ajouter à votre fichier /etc/fstab

.host:/win7share /mnt/hgfs vmhgfs defaults 0 0

La fonction vmware-hgfsmounter n’est pas disponible à l’aide des vmware-tools officiels de VMware livré avec le lecteur VMware actuel . Par conséquent, comme le suggère la réponse acceptée , l'exécution de vmware-config-tools.pl -d corrige le problème.

    
réponse donnée Mark Mikofski 03.01.2013 - 06:43
la source
7

J'ai eu ce problème exact. Il s’est avéré que le service informatique avait installé une ancienne version des outils VMWare avec un module de noyau vmhgfs non fonctionnel.

Ma solution consistait à exécuter la configuration avec le paramètre clobber-kernel-modules pour remplacer le module vmhgfs existant.

 sudo vmware-config-tools.pl -d --clobber-kernel-modules=vmhgfs

Le -d sélectionne toutes les valeurs par défaut pour vous (supprimez-le si vous ne voulez pas les valeurs par défaut).

    
réponse donnée extabgrad 05.09.2013 - 12:13
la source
6

open-vm-tools ne créerait pas des modules de noyau jusqu’à la première installation de linux-headers-virtual (associé bien sûr à linux-image-virtual ). dès que j'ai installé le package des en-têtes, dpkg-reconfigure open-vm-tools a abouti à la création et au chargement des modules du noyau, en particulier du module vmhgfs .

    
réponse donnée pjs 10.06.2013 - 18:45
la source
6

J'ai eu un problème similaire. Le dossier / mnt / hgfs / est de nouveau apparu lorsque j'ai assuré que open-vm avait été désinstallé. Comme suit

sudo apt-get purge open-vm-tools
sudo apt-get purge open-vm-tools-dkms

et réinstallé vmware-tools

    
réponse donnée Peretz 02.11.2011 - 16:32
la source
5

vmware-tools-patches a fonctionné pour moi; donner un coup si rien ne fonctionne

  

Je l'ai testé sur une nouvelle installation (installation facile) d'ubuntu 16.10 sur vmware workstation 12 pro

  1. Allez à lien
  2. Suivez les instructions Quickest Start données ici. Reproduit ici:

    $ git clone https://github.com/rasa/vmware-tools-patches.git
    $ cd vmware-tools-patches
    $ ./patched-open-vm-tools.sh
    
réponse donnée Dheeraj Bhaskar 28.11.2016 - 10:39
la source
4

Vous devez d’abord installer les outils VMWare, après quoi vmware-config-tools peut être utilisé globalement. Pour un guide plus détaillé, vous pouvez voir ici .

    
réponse donnée Trung-Hieu Le 22.10.2012 - 04:01
la source
3

J'ai eu le même problème mais je pense que je viens de progresser.

Tapez vmware-hfgs , puis appuyez sur la touche <Tab> qui vous indiquera qu'il existe également une commande vmware-hgfsmounter . Si vous appelez cela sans aucune option, il affichera une aide qui vous indiquera comment l'appeler dans le cadre de la commande 'mount'. En utilisant cette information, j'ai ensuite réalisé ce qui fonctionnait pour moi:

cd /mnt
sudo mkdir win7share
sudo mount -t vmhgfs .host:/win7share /mnt/win7share

J'ai ensuite pu accéder au partage Win 7 et copier des fichiers vers et à partir de là.

Si vous voulez rendre cela permanent, je pense que vous devrez éditer le fichier /etc/fstab mais je ne peux pas encore vous aider.

    
réponse donnée snth 18.03.2011 - 14:32
la source
3

(s'applique au partage de fichiers Mac VMware Fusion et Ubuntu) Quand on vous demande dans vmware-config-tools.pl si vous voulez HGFS, dites oui! (La valeur par défaut est «non» et vous avez peut-être sauté dessus lorsque vous appuyez sur entrez ). Cela devrait vous donner /mnt/hgfs après l'installation des outils.

    
réponse donnée user99347 20.10.2012 - 23:56
la source
3

Si vous ne pouvez pas encore monter les dossiers partagés après avoir installé vmware-tools , voici la résolution.

Auparavant, je ne pouvais pas monter le dossier partagé Windows après avoir installé les outils vmware. Je n'ai vu aucun dossier sous / mnt / hgfs.

Finalement, j'ai résolu ce problème de montage de dossier de partage en installant open-vm-dkms .

Voici les étapes:

  1. Assurer la configuration du dossier partagé dans VMWare Player

  2. Installez open-vm0dkms:

    sudo apt-get install open-vm-dkms
    
  3. Cliquez sur "Entrée" pour autoriser la valeur par défaut

  4. Montez le dossier partagé Windows sur Ubuntu VM:

    sudo mount  -t  vmhgfs  .host:/     /mnt/hgfs 
    
  5. vérifier si le montage est réussi

    df -kh
    

    Vous devriez voir:

    .host:/         57657252 50247088   7410164  88% /mnt/hgfs
    

    Vérifiez également si des dossiers sous / mnt / hgfs. Vous devriez voir les dossiers sous lesquels.

  6. Montage automatique du dossier partagé au démarrage

    Il existe un script de démarrage appelé "open-vm-tools" dans le dossier /etc/init.d/. Ajoutez simplement la ligne ci-dessous dans la fonction de démarrage.

    sudo mount  -t  vmhgfs  .host:/     /mnt/hgfs
    

J'espère que ça peut aider.

    
réponse donnée konglee28 19.04.2014 - 12:16
la source
2

J'ai remarqué que la plupart des réponses sont assez anciennes.

Ce qui a fonctionné pour moi sur Ubunt 18.04 (bionic) est:

sudo vmhgfs-fuse .host:/ /mnt/hgfs/ -o allow_other -o uid=1000

Cela a monté comme par magie tous les dossiers partagés pour moi. Vous devrez peut-être le faire pour un dossier spécifique au lieu de .host:/ . Dans ce cas, vous pouvez trouver le nom du partage avec vmware-hgfsclient .

Si vous souhaitez les monter au démarrage:

# Use shared folders between VMWare guest and host
#+goes in /etc/fstab
.host:/    /mnt/hgfs/    fuse.vmhgfs-fuse    defaults,allow_other,uid=1000     0    0

Je choisis de les monter à la demande et de les faire ignorer par sudo mount -a et les autres avec l'option noauto , car j'ai remarqué que les partages avaient un impact sur les performances de la machine virtuelle.

J'ai bien sûr fait sudo apt-get install open-vm-tools open-vm-tools-desktop au préalable. Il n'a pas fallu autre chose pour autant que je puisse m'en souvenir. Cependant, d'autres ont déclaré qu'un sudo apt-get install build-essential module-assistant linux-headers-virtual linux-image-virtual && dpkg-reconfigure open-vm-tools était nécessaire.

    
réponse donnée con-f-use 02.07.2018 - 22:51
la source
0

Une solution à ce problème consiste à éditer 'inode.c' et à modifier la ligne '888' pour supprimer l’appel de fonction 'compat_truncate' (responsable de ce problème sur les noyaux 3.8.x). Ce fichier se trouve dans 'vmware-tools-distrib', vous devez donc suivre les étapes suivantes:

Extrayez VMWare-Tools (vous obtiendrez probablement un dossier appelé vmware-tools-distrib). Alors:

 cd /vmware-tools-distrib/lib/modules/source
 tar xf vmhgfs.tar
 cd vmhgfs-only/
 sudo gedit inode.c

Passez à la ligne 888:

 result = compat_vmtruncate(inode, newSize);

Et changez-le en:

 result = 0;

Enregistrez ensuite le fichier et quittez gedit.

 cd ..
 rm -rf vmhgfs.tar
 tar cf vmhgfs.tar vmhgfs-only/
 rm -rf vmhgfs-only/

Relancez maintenant la procédure d’installation. Cela a fonctionné pour moi dans Xubuntu 13.04.

Src: lien

    
réponse donnée Mahmoud M. Abdel-Fattah 01.09.2013 - 14:03
la source

Lire d'autres questions sur les étiquettes