Définir les préférences de setxkbmap au démarrage

14

J'essaie de mettre la touche Ctrl gauche avec les majuscules en permanence. Mais avec Ubuntu natif clavier de configuration switcher xmodmap n'a pas persisté ( cette question ). Alors maintenant, je me suis contenté d'abandonner le commutateur natif et d'utiliser plutôt la commande setxkbmap. J'ai créé un script:

#!/bin/bash
setxkbmap -model pc104 -layout us,ru -option grp:alt_shift_toggle -option ctrl:swapcaps

Cela fonctionne comme je veux. Mais maintenant je veux le lancer automatiquement au démarrage du système. Mais si je mets cela sous Sturtup Applications, cela ne fonctionne pas. Apparemment, quelque chose réinitialise xkb map après mon script au démarrage.

Est-ce que quelqu'un sait ce qui déclenche la réinitialisation de xkb et comment s'en débarrasser?

    
posée lompy 25.01.2014 - 12:01
la source

1 réponse

21

Enfin, après de nombreuses recherches, voici ce que j'ai trouvé pour Ubuntu 13.10:

$ sudo apt-get install dconf-tools
$ dconf-editor

naviguez vers org & gt; & gt; gnome & gt; & gt; desktop & gt; & gt; sources d'entrée

Placez vos options sous xkb-options sous forme de liste. Ex: ['altwin: ctrl_alt_win', '.. etc ..'

Fermez ensuite l'éditeur dconf. Les changements devraient venir directement vivre.

... Je posterais une capture d'écran mais ma réputation sur ce forum n'est pas assez élevée, merci de prendre quelques points;)

Réf:

réponse donnée user76369 12.03.2014 - 02:16
la source

Lire d'autres questions sur les étiquettes