Comment définir le lundi comme premier jour de la semaine dans l'applet Calendrier GNOME?

72

Quelle est la méthode recommandée pour changer le premier jour de la semaine en lundi (au lieu de dimanche, comme dans la capture d'écran ci-dessous)?

Jenetrouvaisriendanslespréférencesdel'horloge,nidanslesystème->PréférencesouSystème->Administration.

Celaaprobablementquelquechoseàvoiravecdesréglagesdeparamètresrégionaux,doncvoicilasortie(éventuellementpertinente)delocale:

LANG=en_US.utf8LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
...
LC_ALL=

NB : je souhaite conserver l'anglais comme langue d'interface utilisateur à la fois dans GNOME et en ligne de commande. Les dates sont actuellement affichées comme ceci (par exemple ls -l ): 2010-10-06 15:32 , et je souhaite également le conserver tel quel.

    
posée Jonik 11.10.2010 - 17:37
la source

5 réponses

60

Voici une autre solution, à partir des forums Ubuntu . Je pense que c'est un peu plus propre et plus robuste: cela n'implique pas de personnaliser les fichiers de paramètres régionaux d'Ubuntu (uniquement les paramètres que vous êtes censé modifier).

Gnome calendar applet adheres to your locale settings. In Ubuntu, you can assign locale components by editing the file /etc/default/locale. Here is what I've got there:

LANG="en_US.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"

Which means: I want software messages in American, but time, paper size and units in British i.e.weeks starting with Mondays, A4, metric.

Fournitures de service pour artm qui a publié ce message!

Bien sûr, LC_TIME="en_GB.UTF-8" est le paramètre approprié pour que les semaines commencent le lundi.

Vous devez vous déconnecter et vous reconnecter pour que la modification soit prise en compte.

    
réponse donnée Jonik 12.10.2010 - 17:03
la source
19

La meilleure solution pour moi consiste à le faire, utilisateur par utilisateur, dans mon propre répertoire personnel. De cette façon, je n'ai pas à éditer un fichier système. (Bien entendu, si vous souhaitez utiliser ce paramètre pour tous les utilisateurs de votre système, vous êtes évidemment obligé de modifier les fichiers système.)

Je modifie le fichier ~/.xsessionrc pour qu'il contienne la ligne "export LC_TIME = en_GB.utf8". C'est ça.

    
réponse donnée Victor 19.10.2011 - 16:07
la source
6

Sous Ubuntu 12.04 (et les versions ultérieures, je suppose), le moyen le plus simple semble être: Paramètres système > Support linguistique, puis cliquez sur l'onglet Formats régionaux et choisissez dans la liste déroulante.
Dans mon cas, j’ai choisi «Anglais (Irlande)», ce qui m’a donné le lundi comme premier jour du calendrier, les formats numériques corrects et la devise, ainsi que d’autres goodies :)
Si vous ne trouvez pas la bonne option, vous devrez peut-être installer une langue (l’autre onglet de la même fenêtre).

    
réponse donnée Kamal 23.03.2014 - 20:15
la source
5

Les formats d'heure et de date dans Ubuntu sont contrôlés par les paramètres régionaux. Tout d’abord, vous devez connaître les paramètres régionaux actuellement utilisés pour contrôler vos paramètres d’heure et de date. Ouvrez un terminal et entrez la commande suivante.

locale | grep LC_TIME

Vous devriez voir un résultat qui ressemble à quelque chose comme

LC_TIME=en_US.UTF-8

Accédez au répertoire de paramètres régionaux et copiez le fichier de paramètres régionaux en cours pour créer un nouveau fichier personnalisé. Ajustez le pour vos paramètres régionaux.

cd /usr/share/i18n/locales
sudo cp en_US en_US_custom

Modifiez maintenant le nouveau fichier personnalisé.

sudo gedit en_US_custom

Et changer

first_weekday 1

à

first_weekday 2

Ensuite, apportez les modifications dans / etc / environment pour qu'elles pointent vers votre nouveau fichier personnalisé.

sudo gedit /etc/environment

Ajoutez une ligne comme celle-ci au bas du fichier en veillant à l'ajuster au fichier de paramètres régionaux personnalisé que vous souhaitez utiliser.

LC_TIME="en_US_custom.UTF-8"

Source: lien

    
réponse donnée Ondra Žižka 08.11.2012 - 11:15
la source
4

Sur cette page, les paramètres doivent aller dans .pam_environment ou .profile . lien

Mon .profile par défaut est la recherche de .bashrc , j'ai donc ajouté ces lignes à mon .bashrc puisque je l'ai déjà sous contrôle de source.

#Change first day of week to Monday
export LC_TIME=en_GB.UTF-8
#Change to metric system
export LC_MEASUREMENT=en_GB.UTF-8

Je cours 14.04.1

UPDATE: 15/01/16 Ubuntu 14.04.03

La présence de ces lignes dans mon .bashrc a cessé de fonctionner plus tôt cette année. Déplacer les mêmes lignes vers .pam_environment ou .profile ne fonctionne pas. Il s’agit d’un paramètre utilisateur, et non du système.

    
réponse donnée Antonios Hadjigeorgalis 09.12.2014 - 17:48
la source

Lire d'autres questions sur les étiquettes