Comment puis-je supprimer le second Unity Launcher en double sur une configuration à double écran?

146

Sur mon écran double écran, j'ai un Unity Launcher sur l’écran de gauche et aussi sur l’écran de droite. Les deux fonctionnent parfaitement bien.

Cependant, je ne veux pas que ce deuxième lanceur soit présent sur mon écran droit. Comment pourrais-je supprimer cela? Si cela est important, j'utilise des pilotes NVIDIA avec une configuration TwinView.

    
posée Eugene van der Merwe 25.02.2012 - 09:46
la source

6 réponses

216

Vous pouvez maintenant.

Ouvrez les préférences d’affichage, puis choisissez entre le lanceur sur un seul écran ou tous.

Cette boîte de dialogue permet également d’activer ou de désactiver les bords adhésifs (c.-à-d. le ralentissement de la souris) entre les écrans.

    
réponse donnée jrg 31.03.2012 - 19:46
la source
33

Le ralentissement est une fonctionnalité permettant d'utiliser le lanceur lorsqu'il est configuré pour se masquer automatiquement. Je pense que c'est un bug qui est utilisé quand le lanceur est toujours visible. Je l'ai signalé sur Launchpad.net, où les bogues sont classés, et vous voudrez peut-être le définir pour vous affecter. Vous pouvez le trouver ici: lien

En attendant, vous pouvez le configurer vous-même en utilisant /apps/compiz-1/plugins/unityshell/screen0/options/overcome_pressure et /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity dans gconf-editor

Vous pouvez également configurer ces paramètres dans CCSM (Gestionnaire de paramètres Compiz Config), dans l'onglet Unity Plugin, Expérimental

    
réponse donnée Jo-Erlend Schinstad 03.03.2012 - 21:44
la source
8

Je viens de trouver un paramètre dans gconf-editor qui vous permettra de définir le lanceur uniquement sur votre bureau principal: /apps/compiz-1/plugins/unityshell/screen0/options/num_launchers . Si vous le définissez sur 1, le lanceur Unity sera uniquement affiché sur le bureau principal. Si vous le définissez sur 0, le lanceur sera disponible sur tous les ordinateurs de bureau.

En plus de ce réglage, je règle également la pression de dépassement ( /apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1 ) et la vitesse d'arrêt ( /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20 ).

    
réponse donnée Todd Wallentine 17.05.2012 - 15:27
la source
4

J'ai résolu en utilisant disper. Tapez dans un terminal:

sudo apt-get install disper

Après avoir résolu le problème avec la méthode proposée par Paŭlo Ebermann ou nvidia-settings ou tout ce qui fonctionne pour vous, tapez un terminal:

disper --export < /path-to-my-file/my-disper-file.metamode

my-file.metamode est comme suit:

backend: nvidia
associated displays: DFP-0, DFP-1
metamode: DFP-0: 1366x768 @1366x768 +1920+312, DFP-1: 1920x1080 @1920x1080 +0+0
scaling: stretched, stretched
xinerama info order: DFP-1, DFP-0

La troisième ligne tient compte du positionnement particulier de deux écrans de hauteurs différentes. Votre cas peut être plus simple. Vous pouvez essayer de créer le fichier correspondant à votre configuration (sans utiliser d'autres méthodes + disper --export). Le point important est l'ordre des écrans dans les deuxième et dernière lignes.

Vous pouvez utiliser le script et le lancer au démarrage:

#!/bin/sh
#Auto switch single/extend display with disper on Multiple Monitor.
lines=$(disper -l | wc -l)
display_count=$((lines / 2))
if [ $display_count -eq "1" ]; then
   disper -s
else
   disper --import < /path-to-my-file/my-disper-file.metamode
fi

Cela a fonctionné avec ma carte graphique nvidia (à la fois précise et quantique).

J'espère que ça aide.

    
réponse donnée cesare sodi 26.10.2012 - 12:14
la source
3

J'ai essayé les paramètres combinés ci-dessus:

/apps/compiz-1/plugins/unityshell/screen0/options/num_launchers=1
/apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1
/apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20

Cela a surtout été un succès pour moi. Un lanceur apparaît uniquement sur l'écran principal et la souris passe d'un écran à l'autre sans hésitation excessive. Cependant, j'ai trouvé que le lanceur restant ne révélerait pas sans utiliser la super clé. Cela peut être corrigé en définissant les éléments suivants:

/apps/compiz-1/plugins/unityshell/screen0/options/reveal_pressure=1

BTW c'est avec les pilotes NVidia.

    
réponse donnée David Sowerby 15.07.2012 - 11:59
la source
0

Changer simplement /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity en 1 a résolu le problème pour moi ... Je ne voulais pas forcément supprimer la deuxième barre des tâches, je n'aimais pas la pause quand je passais d'un écran à l'autre.

    
réponse donnée brbcoding 03.08.2012 - 22:17
la source

Lire d'autres questions sur les étiquettes