Comment activer la connexion automatique dans LightDM?

64

Je souhaite que l'utilisateur foo se connecte automatiquement avec LightDM (utilisé par Ubuntu depuis la version 11.10). Comment pourrais-je faire ça?

    
posée htorque 29.06.2011 - 11:51
la source

11 réponses

43

Vous pouvez le faire sans modifier les fichiers de configuration: accédez à Paramètres système & gt; Comptes d'utilisateur, cliquez sur "Déverrouiller" et entrez votre mot de passe, puis cliquez sur le bouton à côté de "Connexion automatique":

'

    
réponse donnée Alin Andrei 06.09.2011 - 17:14
la source
64

Une alternative à la réponse d'Alin est de créer un fichier /etc/lightdm/lightdm.conf et d'ajouter le contenu suivant:

[SeatDefaults]
autologin-user=<YOUR USER>
autologin-user-timeout=0
user-session=ubuntu
# Uncomment the following, if running Unity
#greeter-session=unity-greeter

La prochaine fois que vous démarrez, la connexion automatique devrait fonctionner comme prévu.

    
réponse donnée htorque 29.06.2011 - 11:51
la source
17

Pour Ubuntu 14.04, créez le fichier:

/etc/lightdm/lightdm.conf.d/12-autologin.conf

et ajoutez:

[SeatDefaults]
autologin-user=youruser
    
réponse donnée nkef 28.04.2014 - 14:02
la source
13

Vous pouvez facilement faire cela avec lightdm-set-defaults si vous préférez ne pas éditer lightdm.conf manuellement:

sudo /usr/lib/lightdm/lightdm-set-defaults --autologin "$USER"

Il ne définira pas le délai d'expiration de la connexion automatique, mais la valeur par défaut est 0 dans le code, vous n'avez donc pas besoin de la définir.

    
réponse donnée mfisch 06.12.2012 - 20:49
la source
5
gksu gedit /etc/lightdm/lightdm.conf

ajouter des lignes:

autologin-user=username
autologin-user-timeout=0

exemple:

[SeatDefaults]

user-session=ubuntu

greeter-session=unity-greeter

autologin-user=alan

autologin-user-timeout=0
    
réponse donnée Alan 25.03.2013 - 14:46
la source
3

Ouvrez les paramètres, sélectionnez "comptes d'utilisateurs". Cliquez sur le bouton de déverrouillage, puis changez le commutateur de connexion automatique sur "On"

    
réponse donnée luyangliuable 02.11.2012 - 07:09
la source
1

Recherchez l'application "Comptes d'utilisateurs". Sélectionnez le compte que vous souhaitez autologin Basculez le commutateur de connexion automatique sur On

Cela devrait faire le travail.

    
réponse donnée Fernando 16.10.2011 - 21:01
la source
1

Je peux confirmer que cela fonctionne pour 16.04.
À l'aide de votre éditeur favori, modifiez /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf .
Ajoutez autologin-user=xxxx au fichier, par exemple:

[Seat:*]
greeter-session=lightdm-gtk-greeter
autologin-user=wmurphy

N'oubliez pas de définir également l'option Non demandé pour la connexion sous Utilisateurs et groupes .

    
réponse donnée Wari Murphy 03.06.2017 - 11:19
la source
0

J'ai eu le même problème, je l'ai résolu en procédant comme suit:

  1. connectez-vous en tant que root: sudo su
  2. entrez le fichier:

    sudo nano /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
    
  3. en bas ajouter:

    autologin-user=xxxx
    
  4. enregistrez le contenu du fichier, puis quittez et redémarrez.

Cela devrait vraiment marcher.

    
réponse donnée SH ShaHad 20.11.2017 - 10:09
la source
0

J'ai 12.10 xubuntu. Dans les utilisateurs et les groupes, choisissez votre utilisateur et cliquez sur le mot "Modifier ..." à côté de "Mot de passe:" (ça ne ressemble pas à un bouton, ce qui pourrait être un peu trompeur). Là, vous pouvez changer le mot de passe, ou au bas de la case "Ne pas demander le mot de passe lors de la connexion".

J'espère que ça marche.

    
réponse donnée Chris 16.01.2013 - 15:37
la source
0

Je viens juste de découvrir que je dois installer ubuntu-desktop avant que lightdm puisse fonctionner. Cela a résolu mon problème en essayant de faire en sorte que lightdm se connecte sans entrer en boucle.

La raison pour laquelle le système doit se mettre en boucle est que lightdm a besoin du bureau ubuntu avant de pouvoir fonctionner.

sudo apt-get install ubuntu-desktop
    
réponse donnée Faron 12.06.2013 - 01:11
la source

Lire d'autres questions sur les étiquettes