Comment changer la taille de police par défaut de XTerm?

68

La police XTerm est très petite. Comment puis-je le définir plus grand?

    
posée Sudo 09.07.2012 - 19:35
la source

7 réponses

79

Si vous n'en avez pas déjà un, créez un fichier dans votre répertoire personnel nommé .Xresources pour stocker vos préférences pour différents programmes X. Ajouter une ligne au fichier tel que

xterm*font:     *-fixed-*-*-*-18-*

Ceci informe xterm d’utiliser la police "fixe" à la taille 18.

À partir de là, vous pouvez soit redémarrer X, soit exécuter xrdb -merge ~/.Xresources dans un terminal pour intégrer les modifications que vous avez apportées. Tous les nouveaux xterm s devraient maintenant avoir le changement de police.

Si vous exécutez man xterm et descendez dans la section RESSOURCES, vous pouvez trouver une multitude d’options xterm supplémentaires et configurables.

    
réponse donnée noffle 09.07.2012 - 21:33
la source
37

Utilisez les paramètres -fa et -fs:

xterm -fa 'Monospace' -fs 14
    
réponse donnée nvd 15.08.2014 - 16:17
la source
36

Vous pouvez également cliquer avec le bouton droit de la souris tout en maintenant la touche Ctrl enfoncée pour modifier temporairement la taille de la police

    
réponse donnée dolzenko 05.11.2013 - 15:24
la source
7

Après avoir utilisé /etc/X11/app-defaults/XTerm fichier et page de manuel pour Xterm, j'ai trouvé deux méthodes.

Méthode 1: Une méthode plus simple mais non permanente: maintenez la touche Ctrl enfoncée et cliquez avec le bouton droit de la souris. Cela devrait faire apparaître un menu pour les polices VT, qui reste activé aussi longtemps que vous maintenez la touche clic droit. Vous devriez voir 7 choix, le plus grand étant énorme, ce que j'utilise parce que ma vision n'est pas exactement bonne.

Source: page de manuel xterm (1), partie Polices VT, qui indique "Le paramètre fontMenu s’affiche lorsque la touche" control "et        Les trois boutons du pointeur sont enfoncés dans une fenêtre. "

Méthode 2: permanente. Parcourez /etc/X11/app-defaults/XTerm , trouvez les lignes de tailles telles que *VT100.font1: , choisissez-en une et écrivez quelque part xterm*font: 10x20 (10x20, encore une fois, c'est mon choix pour les raisons que j'ai déjà indiquées).

À propos de mon système: j'exécute Ubuntu 13.10

    
réponse donnée Sergiy Kolodyazhnyy 06.08.2014 - 10:36
la source
3

vous pouvez aussi simplement les tester avec:

  

xterm -fn "- -clean - - * - - - * - - - * - - - * - * "

après sel avec xfontsel

    
réponse donnée pat 23.03.2013 - 23:34
la source
1

Une autre option, ajoutez-la à votre ~/.Xresources pour créer des raccourcis clavier permettant de modifier la taille de la police:

XTerm.vt100.translations: #override \n\
  Ctrl <Key> minus: smaller-vt-font() \n\
  Ctrl <Key> plus: larger-vt-font()

Si vous utilisez uxterm, veillez à utiliser UXTerm.vt100.translations à la place.

Ensuite, vous pouvez utiliser ctrl + + pour augmenter la taille de la police ou ctrl + - pour diminuer la taille , comme vous pouvez le faire avec ctrl + right-click et en sélectionnant l'une des autres options de taille de police.

    
réponse donnée Matthew 29.09.2017 - 20:08
la source
0

La création du fichier .Xresources avec des lignes de code spécifiées (fourni dans la réponse par noffle) a résolu le problème, mais au redémarrage, les paramètres ont été perdus à nouveau.

Si les paramètres spécifiés dans le fichier .Xresource ne sont pas reflétés automatiquement, essayez d’ajouter la ligne ci-dessous à ~/.bashrc .

[[ -f ~/.Xresources ]] && xrdb -merge ~/.Xresources
    
réponse donnée Jerin 12.01.2018 - 23:26
la source

Lire d'autres questions sur les étiquettes