"Exiger l'installation de paquets non approuvés" lors de la mise à niveau avec le gestionnaire de mise à jour

65

Il n'a pas corrigé l'erreur. Alors, comment puis-je réparer ma mise à jour de l'interface graphique?

Pour chaque logiciel, je dois l'installer à partir de la ligne de commande car j'ai eu la même erreur lors de l'installation du logiciel depuis Ubuntu Software Center.

    
posée One Zero 29.03.2012 - 13:55
la source

7 réponses

63
  1. Ecrivez dans un terminal: sudo apt-get update && sudo apt-get upgrade ou modifiez les paramètres de Update Manager (essayez d’abord si vous avez déjà configuré Update Manager).

  2. Lancez Update Manager et réessayez.

Exécuter la mise à jour via un terminal permet d’autoriser ou non les packages non approuvés.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Si vous faites confiance à la source du package, tapez y .

    
réponse donnée Zlatan 29.03.2012 - 19:14
la source
43

Cela se produit en raison de l’absence de certaines clés GPG. Pour résoudre ce problème, ouvrez un terminal et exécutez les commandes ci-dessous:

sudo apt-get update

Vous obtiendrez une erreur indiquant que certaines clés publiques ne sont pas disponibles. Notez la chaîne de clé (après le NO_PUBKEY; par exemple: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Remplacez le XXXXX par la chaîne de caractères

par exemple: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

par exemple: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Maintenant, essayez à nouveau de mettre à jour votre système.

Voici un article similaire: "Nécessite d'installer des mises à jour non fiables" Erreur dans Update Manager

J'espère que ça aide.

    
réponse donnée aneeshep 01.12.2010 - 10:05
la source
13

Vous pouvez l’installer via la ligne de commande: sudo apt-get install --allow-unauthenticated exiv2 .

Pour "faire confiance" de manière permanente au référentiel, exécutez ceci: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update . Je crois que c'est le PPA que vous utilisez.

    
réponse donnée evgeny 01.12.2010 - 10:12
la source
5

En réponse à votre question, vous ne pouvez pas "corriger" la mise à jour de l'interface graphique (par exemple Update Manager), car il est évident que cette application ne permet pas actuellement d'installer des packages non fiables. Si vous souhaitez installer des packages non fiables, vous devez le faire sur la ligne de commande.

Il existe cependant deux manières d’empêcher Update Manager de signaler cette erreur: supprimez le logiciel non approuvé de votre système OU approuvez le référentiel en question, comme indiqué dans la réponse à l’autre. question ( Les mises à jour ne sont pas installées en raison de "packages non approuvés" ) .

La première étape consiste à trouver le référentiel à l'origine du problème. Vous pouvez le découvrir en tapant apt-cache policy ambiance-colors sur la ligne de commande.

Cependant, un rapide google révèle que ambiance-colors et radiance-colors proviennent de ppa:ravefinity-project . Vous devriez donc pouvoir résoudre votre problème en tapant

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

extrait de lien

    
réponse donnée stackex humanoid 10.06.2012 - 22:06
la source
1

pourquoi cela signifie-t-il que les paquets que vous tentez d’installer sont des logiciels tiers. Si vous voulez les installer, activez la case à cocher Canonical sur les autres onglets du logiciel, puis réessayez. installation

J'espère que ça aide.

    
réponse donnée Ten-Coin 29.03.2012 - 19:21
la source
1

J'ai eu le même problème. Pour moi, cette commande a fonctionné:

sudo apt-get update --fix-missing

L'avantage de cette solution par rapport aux autres solutions est sa simplicité. Vous pouvez continuer à utiliser l'interface graphique et vous n'avez pas besoin de savoir quel référentiel est brisé. J'ai trouvé la solution ici dans un commentaire. Je ne connais pas assez Ubuntu pour expliquer, mais je suppose que cela donne les clés nécessaires pour que tous les repos fonctionnent.

    
réponse donnée smoortema 20.09.2013 - 10:58
la source
0

Votre question n'est pas claire: vous "corrigez votre mise à jour de l'interface graphique" en corrigeant l'erreur. L'autre question vous montrera ce qu'il faut faire.

Vous pouvez désélectionner l’une de vos mises à jour en fonction d’une source non fiable, ou vous pouvez aller de l’avant et utiliser la ligne de commande pour faire confiance en permanence à cette source particulière. Une fois que vous en avez terminé, le message ne s'affiche pas. Si vous faites ce dernier, le message n'apparaîtra plus jamais pour cette source spécifique.

    
réponse donnée Mei 29.03.2012 - 19:04
la source

Lire d'autres questions sur les étiquettes