Le réseau sans fil ne fonctionne pas après la reprise dans Ubuntu 14.04

78

[Mise à jour]:
Le même problème existe dans Kubuntu et est résolu de la même manière.
[Résolu]:
En appliquant la commande suivante nmcli nm , j'ai obtenu ce qui suit:

Avant de suspendre

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled  

comme vous pouvez le voir l'état est connecté et le reste est activé et en cours d'exécution

Après la suspension

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         asleep          enabled         enabled    enabled         disabled

comme vous pouvez le voir, l'état est endormi, ce qui signifie que notre cher gestionnaire de réseau est toujours en train de faire la sieste, alors pour résoudre, utilisez la ligne de commande suivante:
sudo nmcli nm sleep false
Cela indique au gestionnaire de réseau de réveiller l'enfer. faire ce permanent:
créer un script dans /etc/pm/sleep.d contenant les éléments suivants (et ne pas oublier de marquer le script comme exécutable):

#!/bin/sh

case "" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

Merci à this

Le problème initial:

Je viens de télécharger Ubuntu 14.04 et installé sur mon ordinateur portable: ASUS X61SL avec processeur Intel P8400 Core2Duo x64.
Lorsque je ferme le couvercle, le système est suspendu, mais lorsque j'ouvre à nouveau le couvercle et que je reprends, le réseau sans fil n'est pas activé (le réseau dans son ensemble est désactivé) et lorsque je sélectionne "Activer le réseau", rien ne se passe. Voici les informations sur ma carte sans fil:

$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)  

Ce problème n’était pas présent dans Ubuntu 13.04, Linux Mint Debian Edition ou Debian 7 wheezy (GNOME ou KDE).

Modifier: quelques tests avec les résultats suivants:
Le problème affecte mes réseaux sans fil et câblés.
Remarque: je dois ajouter la ligne pci=nomsi à grub pour pouvoir démarrer. Lorsque vous vous déconnectez manuellement, suspendez puis reprenez puis connectez-vous tout fonctionne correctement.
Lorsque vous suspendez directement pendant que vous êtes connecté, le problème se produit.
Le verrouillage et la suspension posent le même problème que la suspension directe.
Ce problème semble également affecter la fonction de déconnexion: si vous choisissez de vous déconnecter du menu utilisateur dans le panneau d’unité, vous ne vous déconnecterez pas, mais si vous utilisez la ligne de commande gnome-session-quit --logout , vous pouvez vous déconnecter.
Maintenant avec lshw -C network output:
Normal (réseau entièrement fonctionnel):

  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A ip=6.6.6.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Après la reprise ("/etc/pm/config.d" ne contient pas "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Lorsque j'ai ajouté le fichier unload_modules au répertoire "/etc/pm/config.d" comme suggéré par ici , après vous être déconnecté, suspendre, reprendre, puis connectez-vous au réseau, mais je ne peux pas me connecter à mon réseau sans fil.
Encore une fois le résultat de lshw -C network Après la reprise ("/etc/pm/config.d" contient "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Le contenu de 'unload_modules "où:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"
SUSPEND_MODULES="$SUSPEND_MODULES sis190"

Où "ath9k" est mon module sans fil et "sis190" est mon module Ethernet.

    
posée Ossama Nasser 22.04.2014 - 15:13
la source

5 réponses

27

Les réponses ci-dessus n'ont pas fonctionné pour moi le 14.10. Après quelques essais et erreurs, je me suis retrouvé avec ceci,

#!/bin/sh

case "" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on ;;
esac

Mettez ceci dans /etc/pm/sleep.d/10_resume_wifi
Rendez-le exécutable sudo chmod 755 /etc/pm/sleep.d/10_resume_wifi et le problème devrait être résolu immédiatement.

    
réponse donnée Owais Lone 13.04.2015 - 22:03
la source
21

J'ai une solution mais c'est juste pour redémarrer votre gestionnaire de réseau.

sudo service network-manager restart

Ce n’est pas la solution permanente.

    
réponse donnée hmjha 20.03.2016 - 11:40
la source
4

Le script qui a finalement fonctionné pour moi:

$ cat /etc/pm/sleep.d/10_resume_wifi 
#!/bin/sh

case "" in
  resume|thaw) nmcli nm sleep false ;;
esac

$ ll /etc/pm/sleep.d/10_resume_wifi
-rwxr-xr-x 1 root root 70 mars  31 09:09 /etc/pm/sleep.d/10_resume_wifi

L'autre réponse a des fautes de frappe (elles peuvent être corrigées, je sais), mais n'a jamais fonctionné pour moi de toute façon.

    
réponse donnée Augustin Riedinger 31.03.2015 - 09:21
la source
0

Cela a fonctionné pour moi sur Ubuntu 14.04 sur les ordinateurs portables Dell Precision.

Dans un terminal, entrez:

sudo nano /etc/pm/sleep.d/10_resume_wifi

Puis collez (ctrl + v):

#!/bin/sh
case "" in
resume|thaw)
    nmcli nm wifi on
    ;;
esac

Ensuite, rendez le script exécutable:

sudo chmod +x /etc/pm/sleep.d/10_resume_wifi

Testez suspendus et réveillez-vous pour voir le wifi!

    
réponse donnée FizxMike 15.05.2016 - 02:05
la source
-3

Avez-vous essayé de créer un autre script comme celui-ci, entrez kate:

#/bin/sh

    case ![1] in
        ./bin/sh
        network="true"
        nmcli nm -c sleep=false -network
    endasc

et enregistrez-le sous le fichier jsin7 dans / etc / network, et appelez-le network.d et cela pourrait fonctionner correctement.

    
réponse donnée Michael 30.05.2014 - 11:45
la source

Lire d'autres questions sur les étiquettes