Comment éviter le message "S to Skip" au démarrage?

61

Après avoir mis à niveau mon ordinateur portable de karmic à lucid, ma partition fat32 ne se montera pas automatiquement. Je reçois le message:

The disk drive for /osshare is not ready yet or not present
Continue to wait; or Press S to skip mounting or M for manual recovery

Ce qui est drôle, si je saute, alors /osshare/ est monté une fois que je me connecte.

J'ai une configuration similaire sur mon bureau et ça marche bien. Fstab sur le bureau:

UUID=4663-6853  /osshare        vfat    utf8,umask=007,gid=46 0       1

/etc/fstab sur un ordinateur portable:

UUID=1234-5678 /osshare vfat utf8,auto,rw,user 0 0 
    
posée Marty 28.07.2010 - 22:42
la source

4 réponses

78

Vous devez ajouter l’option nobootwait à votre /etc/fstab . Pour que ça ressemble à:

UUID=1234-5678 /osshare vfat utf8,auto,rw,user,nobootwait 0 0 

De fstab(5) :

  

Le programme mountall(8) qui monte le système de fichiers au démarrage reconnaît également des options supplémentaires que l’outil mount(8) ordinaire ne contient pas.          Ce sont: bootwait qui peut être appliqué aux systèmes de fichiers distants          monté en dehors de /usr ou /var , sans lequel mountall(8) ne serait pas          tenez la botte pour ceux-ci; nobootwait pouvant être appliqué à des systèmes de fichiers non distants pour indiquer explicitement à mountall(8) de ne pas résister          la botte pour eux;

    
réponse donnée qbi 31.07.2010 - 21:19
la source
10

Une autre option pour /etc/fstab montages semble être l'option " bg ", qui non seulement met en arrière le montage nfs , mais tente également des tentatives à intervalles réguliers après la fin du démarrage. Ainsi, lorsque le serveur nfs sera de nouveau en ligne, vos montages reviendront éventuellement en ligne.

    
réponse donnée Trevor 02.10.2012 - 20:43
la source
6

Il semblerait que vous ayez besoin d’éditer vos tables fstab car un disque supplémentaire perturbe votre démarrage, essayez ceci:

  1. Alt + F2
  2. Tapez gksudo nautilus et cliquez sur le bouton Exécuter
  3. Accédez à /etc/fstab
  4. Ouvrez le fichier et supprimez le lecteur supplémentaire qui lance
  5. Enregistrez le fichier lorsque vous avez terminé et fermez
  6. Redémarrer la machine

Cela devrait empêcher le lecteur supplémentaire d’interrompre votre processus de démarrage.

    
réponse donnée Victor9098 30.07.2010 - 05:42
la source
0

Je pense que vous devez changer les options de auto à noauto

    
réponse donnée Marco Ceppi 28.07.2010 - 22:46
la source

Lire d'autres questions sur les étiquettes