La prise casque ne fonctionne pas?

65

J'ai un Dell Studio XPS 1647 et les écouteurs ne fonctionnent pas (même si les haut-parleurs internes fonctionnent comme un charme), j'ai un dual boot Windows 7 et les écouteurs fonctionnent parfaitement bien ...

J'ai aussi essayé -adding en options snd-hda-intel model=eapd probe_mask=1 position_fix=1 .

J'ai vécu cela avec Oneric Ocelot et le dernier Pangolin précis (LTS).

    
posée lexical lemon 06.05.2012 - 06:36
la source

11 réponses

33

Enfin, les écouteurs fonctionnent! Suivez ceci ----- (Dell)

C'est tout:


Exécutez la commande suivante dans le terminal:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Faites défiler la liste et ajoutez ces lignes à la fin du fichier:

# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m6-amic

Ensuite, enregistrez, redémarrez et testez le son en utilisant des écouteurs et des haut-parleurs.

    
réponse donnée lexical lemon 08.01.2013 - 14:21
la source
61

J'ai eu le même problème. Après ces instructions ont fait fonctionner mon casque.

Ouvrez le terminal et entrez les commandes suivantes:

cd /usr/share/pulseaudio/alsa-mixer/paths/
sudo cp analog-output-headphones.conf analog-output-headphones.bak
sudo nano analog-output-headphones.conf

Recherchez la section intitulée [Element Speaker] et changez-la pour qu'elle ressemble à ceci:

[Element Speaker]
switch = on
volume = ignore

Enregistrez les modifications et quittez nano.

Créer une sauvegarde du fichier analog-output-headphones.conf corrigé:

sudo cp analog-output-headphones.conf analog-output-headphones.fixed

Maintenant, vous pouvez restaurer le correctif si une future installation ou une mise à jour le remplace.

Redémarrer.

Après le redémarrage, vous devrez peut-être retirer et réinsérer la prise casque pour la faire fonctionner. Une fois que cela fonctionne, vous serez en mesure de supprimer et d’insérer la fiche, et le comportement sera comme prévu.

    
réponse donnée Michael Cornelius 07.06.2012 - 06:00
la source
56

J'ai essayé toutes ces réponses. Voici le SEUL moyen qui a fonctionné pour moi (et il a été remarquablement rapide… après avoir passé des heures sur toutes les autres suggestions!). Allez dans le Terminal et saisissez simplement ceci:

$ alsactl restore

Et c'est ça! :)

    
réponse donnée Pepe Lebuntu 30.09.2016 - 08:10
la source
18

J'ai eu le même problème après avoir installé 16.06 Ubuntu Gnome dans mon Dell XPS. alors je résous ce problème par .......

sudo apt-get install pavucontrol

après l'installation du pavucontrol. ouvrez-le en tapant simplement le terminal pavucontrol.

puis allez à - & gt; Onglet Périphériques de sortie - & gt; changer de port

dans mon cas, le port sélectionné était Casque (branché) par défaut après la prise casque

changer le port casque (branché) en haut-parleurs (indisponible).

ceci est un correctif temporaire. Après avoir redémarré votre PC, vous devez recommencer.

    
réponse donnée habibun 15.08.2016 - 07:58
la source
4

La solution dans un commentaire ci-dessus de buzypy a fonctionné pour moi, sans aucun des autres éléments:

sudo alsa force-reload

rouvrez alors pavucontrol et modifiez l'option Headphones (unplugged) et redémarrez le programme qui jouait le son.

Ce sont des problèmes comme celui-ci qui empêchent les gens d’utiliser Ubuntu !

    
réponse donnée mjp 07.06.2017 - 22:16
la source
2

Sur mon ordinateur portable, un Lenovo G465, le son fonctionnait bien: chaque fois que je branche le casque, il est détecté et le son passe dans les écouteurs et coupe les haut-parleurs. Soudain, il a cessé de fonctionner. Quelque chose de bizarre s'est passé sans aucune modification, installation ou autre. J'ai lu que quelqu'un devait utiliser alsamixer pour l'activer: voilà: j'ai bricolé les volumes et les mutings et soudain, ça a recommencé à fonctionner comme avant !!! Je n'ai aucune explication, honnêtement.

    
réponse donnée Max 19.11.2012 - 14:07
la source
1

J'ai eu le même problème. J'ai fait comme ci-dessous

  • Allez dans Paramètres
  • Cliquez sur Paramètres audio sous la section matériel
  • Cliquez sur l'onglet de sortie (sélectionné automatiquement par le système)
  • En bas: définissez le volume de sortie sur 100%

Merci à lien

    
réponse donnée Venkat Kotra 06.05.2012 - 20:29
la source
1

Dans mon cas, pour un Dell E5450, il a été résolu après l'exécution:

sudo modprobe snd-hda-codec-idt
    
réponse donnée k0pernikus 01.12.2016 - 17:02
la source
1

Je l'ai eu aujourd'hui dans moyen facile :

Comment utiliser le casque dans Ubuntu:

  1. Installer la mise à jour pour Ubuntu.
  2. Installez GNOME alsa mixer.
  3. Branchez les deux haut-parleurs arrière et le casque avant.
  4. Dans ALSA: désactivez votre colonne avant, réactivez le son dans Headphone.
  5. Paramètre Go to Sound: désactivez le son créé par ALSA.
  6. Cliquez sur le bouton Test Sound pour accéder aux paramètres Test du son dans le son, cochez gauche et droite == & gt; SEUL CASQUE a le son, le haut-parleur sera silencieux.

    
réponse donnée nobjta_9x_tq 11.03.2017 - 05:50
la source
0

Je devais faire ce qui suit:

  1. Sortez de Google Chrome (j'essaie de faire jouer de la musique dans un onglet)
  2. dans un terminal, exécutez killall chrome - dira probablement "aucun trouvé" ou autre
  3. tuez pulseaudio avec pulseaudio -k à un terminal. (il devrait redémarrer silencieusement en arrière-plan, mais si non, essayez pulseaudio -d )
  4. exécute maintenant sudo alsa force-reload (Merci @mjp !!)
réponse donnée Lotus 03.08.2017 - 21:46
la source
0

Aucune des réponses précédentes n'a corrigé mon problème sur Ubuntu 18.04 LTS ni sur 16.04 LTS. Mon ordinateur utilise une carte mère Clevo et, heureusement, un développeur appelé Unrud a créé une solution facile appelée " init-headphone ", qui pour la distribution Ubuntu s'appelle " init-headphone-ubuntu ". Fondamentalement, il vous suffit d'installer le package ".deb" pour Ubuntu et cela, sans redémarrage requis (au moins, cela était vrai pour moi).

Pour être clair, à l’heure actuelle, Unrud n’a pas créé spécifiquement un package 18.04, alors j’ai utilisé le package 16.04 (Xenial) d’Unrud le 18.04 et cela a fonctionné comme un charme!

    
réponse donnée junktext 17.06.2018 - 20:17
la source

Lire d'autres questions sur les étiquettes