Comment installer le package deb Adobe Acrobat Reader téléchargé depuis le site Web Adobe?

91

Je suis nouveau sur Ubuntu, mais je crois que Ubuntu 11.10 est installé correctement. J'essaie d'installer Acroread en utilisant AdbeRdr9.4.6-1_i386linux_enu.deb que j'ai téléchargé sur le site Web d'Adobe. Comment puis-je le faire?

    
posée ubuntu_rookie 20.12.2011 - 04:56
la source

9 réponses

83

Toutes les versions d'Ubuntu antérieures à 13.10

Pour installer Adobe Acrobat, vous devez activer le référentiel partenaires canoniques dans l'onglet Sources de logiciels de Update Manager

Utilisez Dash et recherchez Sources de logiciels ou Logiciels & amp; Mises à jour dans 13.04 et versions ultérieures.

Si vous ne voyez pas ces options dans les sources de logiciels, vous pouvez utiliser la commande suivante depuis un terminal:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

Puis, dans un terminal, vous pouvez mettre à jour et installer Acrobat Reader:

sudo apt-get update
sudo apt-get install acroread

Il est fortement recommandé, du point de vue de la sécurité, d’utiliser la version dans les référentiels.

Si, pour une raison quelconque, vous souhaitez télécharger directement depuis Adobe et l’installer, les instructions suivantes s’appliquent:

Utiliser firefox pour accéder à:

Choisissez les options suivantes, comme indiqué dans l'image - c'est-à-dire téléchargez le package .deb

Lorsque vous cliquez sur le bouton Télécharger:

Par défaut, ouvrez-le dans Software Center, où vous pouvez l'installer.

Si vous avez configuré vos téléchargements pour les enregistrer automatiquement dans votre dossier Téléchargements:

cd ~/Downloads
sudo dpkg -i AdbeRdr*.deb
    
réponse donnée fossfreedom 20.12.2011 - 10:59
la source
79

REVISED: 2016-Nov ( libellé mineur seulement )

Pour Ubuntu 14.04 LTS, 16.04 LTS et 16.10, 32 ou 64 bits

[adapté de: lien ]

Adobe Reader 9 ne se trouve pas dans le référentiel "Partenaire" de 13.10 (ou version ultérieure).

  1. Téléchargez Adobe Reader (32 bits) depuis le site Adobe :

    D'ici: ftp. adobe.com .. reader .. 9.5.5

    Vérifiez MD5SUM après le téléchargement, saisissez

    md5sum AdbeRdr9.5.5-1_i386linux_enu.deb
    

    la sortie devrait être

    88036c68998d565c4365e2ad89b04d51 AdbeRdr9.5.5-1_i386linux_enu.deb
    
  2. Ouvrez une ligne de commande, accédez au répertoire contenant le fichier .deb .

  3. Installer le package, obligeant à accepter la version 32 bits et les erreurs éventuelles:

    sudo dpkg -i --force-architecture AdbeRdr9.5.5-1_i386linux_enu.deb
    sudo apt-get -f install
    
  4. Ajoutez les bibliothèques 32 bits manquantes: ( ignorez cette étape pour 32 bits )

    sudo apt-get install libxml2:i386 lib32stdc++6
    
  5. (Facultatif) Exécutez pour la première fois, pour afficher l’icône dans la barre de menus Unity.

    acroread <path>/<MyDocument>.pdf
    

Pour Ubuntu 12.04 LTS

  1. Ajouter le référentiel "Partenaire Canonical"

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner"
    
  2. Mettez à jour votre système

    sudo apt-get update
    
  3. Installez Adobe Reader et les extensions de police

    sudo apt-get -y install acroread acroread-fonts
    
  4. (Facultatif) Exécutez pour la première fois, pour afficher l’icône dans la barre de menus Unity.

    acroread <path>/<MyDocument>.pdf
    
réponse donnée david6 20.12.2011 - 05:05
la source
9

Pour saucy (13.10), vous pouvez inclure le référentiel partenaire raréfiant. Voici comment je l'ai fait:

sudo echo -e '# for acroread\ndeb http://archive.canonical.com/ubuntu/ raring partner' > /etc/apt/sources.list.d/raring-partner.list
sudo apt-get update
sudo apt-get install acroread

apt-cache show acroread
# Package: acroread
# Architecture: amd64
# Version: 9.5.5-1raring1
# Depends: debconf (>= 0.5) | debconf-2.0, acroread-bin, nspluginwrapper
# [...]

apt-cache policy acroread
# acroread:
#   Installiert:           9.5.5-1raring1
#   Installationskandidat: 9.5.5-1raring1
#   Versionstabelle:
#  *** 9.5.5-1raring1 0
#         500 http://archive.canonical.com/ubuntu/ raring/partner amd64 Packages
#         100 /var/lib/dpkg/status
    
réponse donnée MoreIT 22.01.2014 - 13:41
la source
2

Il semble qu'Adobe ne va pas prendre en charge Linux dans un avenir proche (voir l'article ici ), sauf s'il existe une augmentation du nombre d'utilisateurs de Linux demandant une assistance. Cela peut être fait en remplissant le formulaire de demande de fonctionnalité Adobe suivant: Formulaire de demande de fonctionnalité / rapport de bogue .

Vous pouvez également opter pour les lecteurs Foxit ou pdf maître , qui s’ouvrent plus rapidement et offrent plus de fonctionnalités gratuites que le lecteur Adobe.

    
réponse donnée Theodoros P. 02.03.2017 - 14:51
la source
2

Ubuntu 16.10 sur amd64 semble nécessiter

sudo apt-get -f install
sudo apt-get -y install adobereader-enu

Sans i386 en env 64-bit, acroread donne les erreurs file not found et GTK, donc lancez:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libncurses5:i386 libstdc++6:i386 libglib2.0-0:i386 libsoup2.4-1:i386 libgtk2.0-0:i386
sudo apt-get -y install libicu-dev:i386 gtk2-engines-murrine libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

Cela peut être redondant car le bac principal est i386

sudo apt-get -y install gtk2-engines gtk2-engines-* libgtkmm-2.4-1c2 libcanberra-gtk-module
    
réponse donnée jtm 14.04.2017 - 07:14
la source
1

Acroread est maintenant disponible dans le référentiel partenaire de Quantal.

Voir ce bug du Launchpad:

Il dit Précis dans le titre, mais il s’agit de précision, de quantification et de précision.

    
réponse donnée Mark Russell 12.03.2013 - 21:26
la source
0

Vous pouvez faire:

# sudo dpkg -i AdbeRdr9.4.6-1_i386linux_enu.deb

Mais je vous conseille d’être un meilleur lecteur de pdf. C'est le défaut en quantal.

    
réponse donnée Óscar García Amor 06.11.2012 - 12:41
la source
0

J'ai combiné les méthodes ci-dessus et je peux donc installer Adobe Acrobat Reader sur
Ubuntu 16.04 LTS Xenial Xerus et Ubuntu 18.04 LTS Bionic Beaver :

cd ~/Downloads
wget ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get -y install libxml2:i386 libcanberra-gtk-module:i386 \
gtk2-engines-murrine:i386 libatk-adaptor:i386

sudo apt-get install ./AdbeRdr9.5.5-1_i386linux_enu.deb

On peut alors le lancer avec acroread .

Remarque: ce qui rend Adobe Reader presque unique et utile - c'est sa recherche dans les fichiers (accessible en appuyant sur Ctrl + Shift + F ) .

    
réponse donnée N0rbert 05.05.2018 - 00:28
la source
0

La réponse de NOrbert a fonctionné pour moi, mais uniquement lorsque j'ai ajouté l'option --reinstall lors de l'installation du package acroread.

sudo apt-get install --reinstall ./AdbeRdr9.5.5-1_i386linux_enu.deb
    
réponse donnée Steve Newcomb 04.08.2018 - 21:24
la source

Lire d'autres questions sur les étiquettes