Comment réparer "sudo: impossible d'ouvrir ... Système de fichiers en lecture seule"?

110

Le titre n'est peut-être pas aussi descriptif que je le souhaiterais, mais ne pourrait pas en proposer un meilleur.

Le système de fichiers de mon serveur est entré en lecture seule. Et je ne comprends pas pourquoi il le fait et comment le résoudre.

Je peux SSH dans le serveur et lorsque j'essaie de démarrer apache2 par exemple, je reçois ce qui suit:

[email protected]:~$ sudo service apache2 start
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system
 * Starting web server apache2                                                                                                                                                                                                               (30)Read-only file system: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

Lorsque j'essaie de redémarrer le serveur, j'obtiens:

[email protected]:~$ sudo shutdown -r now
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system

Une fois que je le redémarre manuellement, il suffit de démarrer sans avertissement ni message indiquant que quelque chose ne va pas.

J'espère que quelqu'un pourrait me diriger dans la bonne direction pour résoudre ce problème.

    
posée John 07.10.2012 - 17:41
la source

16 réponses

50

Le système de fichiers sera généralement en lecture seule lorsque le système est en cours d'exécution s'il existe un problème de cohérence du système de fichiers. Ceci est spécifié dans fstab comme errors=remount-ro et se produira lorsqu'un accès FS échoue ou qu'un remontage d'urgence en lecture seule est demandé via Alt + SysRq + U . Vous pouvez exécuter:

sudo fsck -Af -M

pour forcer une vérification de tous les systèmes de fichiers. Comme l’indique l’une des autres réponses, le fait de regarder dmesg est également très utile.

Modifier: n'oubliez pas le -M sur la ligne de commande.

    
réponse donnée hexafraction 07.10.2012 - 17:58
la source
39

Voici la commande qui a résolu mon problème:

mount -o remount /

mieux qu'un redémarrage ou sudo fsck -Af

    
réponse donnée Sulliwane 30.01.2013 - 17:23
la source
31

La réponse par hexafraction n'a pas fonctionné pour moi. Chaque fois que j'ai essayé d’exécuter sudo fsck -Af -M , cela montrait juste

$ sudo fsck -Af -M
fsck from util-linux 2.20.1

et rien d'autre. Aucune erreur ou quoi que ce soit. Pour moi, démarrer sur un disque live et l'exécuter fonctionnait -

sudo fsck.ext4 -f /dev/sda1

Pourvu que la partition en question /dev/sda1 soit un système de fichiers ext4.

    
réponse donnée Bibhas 17.02.2014 - 16:44
la source
10

Essayez d'exécuter dmesg | grep "EXT4-fs error" pour voir si vous rencontrez des problèmes liés au système de fichiers / au système de journalisation lui-même. Je vous recommande de redémarrer votre système, alors. De plus, sudo fsck -Af answer by ObsessiveSSOℲ ne fera pas mal.

    
réponse donnée thiagowfx 24.06.2013 - 20:17
la source
9

Si vous voulez forcer votre système de fichiers racine à remonter en tant que rw, vous pouvez procéder comme suit.

mount -o remount,rw /
    
réponse donnée johnboiles 01.06.2015 - 07:07
la source
5

Notez que cela peut parfois être dû au fait que l’ordinateur oublie l’heure système - la vérification du disque échoue car les dates dans le journal sont dans LE FUTUR!

La configuration de l’heure du BIOS (et la vérification de la batterie du BIOS) ont résolu ce problème sans avoir à effectuer de récupération de disque.

    
réponse donnée Tony Cook 23.02.2016 - 03:15
la source
1

En général, linux met vos systèmes de fichiers en lecture seule lorsque des erreurs se produisent, en particulier des erreurs sur le disque ou le système de fichiers lui-même, des erreurs telles qu'une mauvaise entrée de journal par exemple.

Il vaut mieux vérifier votre dmesg pour les erreurs liées au disque.

Google déborde de discussions à ce sujet et vous pouvez choisir celles qui est plus proche de votre configuration, mais un regard sur dmesg suffit généralement.

    
réponse donnée axis 07.10.2012 - 17:58
la source
1

Si vous double-amorcez votre machine avec Ubuntu et Windows ensemble et que ce problème se produit, c’est parce que Windows change le système de fichiers, dans ce cas, cela peut faire l'affaire. Essayez de désactiver le démarrage rapide

  

Panneau de configuration & gt; Matériel et sons & gt; Options d'alimentation & gt; (à gauche) Choisissez ce que ferme le couvercle & gt; Modifier les paramètres actuellement indisponibles & gt; Décochez 'Activer le démarrage rapide'

Maintenant, démarrer dans Ubuntu résoudra le problème. J'espère que ça aide!

lien

    
réponse donnée Joyy 25.04.2018 - 10:03
la source
0

premier au Menu de récupération (lecture seule) sélectionner dpgk Réparer les paquets endommagés à la fin, le menu de récupération sera Menu de récupération (lecture / écriture) sélectionner Utilisateur de la fenêtre de commande root et vous pourrez l'utiliser en tant qu'utilisateur root!

    
réponse donnée nikolaos 15.08.2014 - 11:36
la source
0

Dans mon cas, il s’agissait de la stabilisation du RAID 1 après l’installation initiale. J'ai / boot et / sur s / w RAID1. Après avoir quitté le système du jour au lendemain et redémarré, tout fonctionne correctement. Richard

    
réponse donnée Richard Moore 08.12.2015 - 12:51
la source
0

Les paramètres de démarrage sont mal configurés (essayez de monter / as ext2 ) et non pas une erreur physique de la partition ou du disque.

dmesg | grep "error" m'a donné:

ext3-fs (sda2): error: couldn't mount because of unsupported optional features (240) 
ext2-fs (sda1): error: couldn't mount because of unsupported optional features (240) 
ext4-fs (sda2): mounted file system with ordered data mode: opts: (null)

Il a monté / en lecture seule en raison de la directive fstab error=mount-ro .

    
réponse donnée misiagogo 21.08.2016 - 08:22
la source
0

Pour moi, redémarrer un système pour résoudre ce problème

sudo reboot

comme il en a parlé.

    
réponse donnée Zaman Oof 14.03.2017 - 19:09
la source
0

Vérifiez si votre matériel est défectueux. Cette erreur est due à un desserrement du disque dur. Ran mount -o remount, rw / et ça a bien fonctionné.

    
réponse donnée Mwongera 15.06.2017 - 16:04
la source
0

Cela a fonctionné pour moi

D'abord, je liste les partitions:

sudo fdisk -l

Partitions

    Device Boot         Start         End      Blocks   Id  System
    /dev/sda1            2048      999423      498688   82  Linux swap / Solaris
    /dev/sda2          999424    83886079    41443328   83  Linux

J'ai donc corrigé la partition du système:

sudo fsck -f -y /dev/sda2
  

Seulement travaillé avec le paramètre f (force), le paramètre y est de   répondez oui dans toutes les questions

Et finalement j'ai redémarré la machine:

sudo reboot
    
réponse donnée Wictor Chaves 02.02.2018 - 12:46
la source
0

(Réponse précédente supprimée)

Modifier: le problème principal était du côté de Windows. Après la mise à jour de Windows 10, l’option «démarrage rapide» est automatiquement activée. En désactivant à nouveau cette option, puis en redémarrant la machine, le problème a disparu. Windows 10 m'a donné de gros maux de tête pendant des jours :(

L'option de démarrage rapide se trouve dans les options d'alimentation du panneau de commande. Désactiver ça !!! :)

    
réponse donnée sarthak-sopho 23.12.2017 - 09:18
la source
0

J'utilise la version 18.04 LTS et ce que j'ai fait, j'ai d'abord démonté mes disques endommagés, puis je suis entré dans l'application "Disks" en tapant dans le tableau de bord. De là, j'ai sélectionné le lecteur qui a été endommagé. Assurez-vous qu'il est démonté sinon il ne fonctionnera pas. Dans le menu d'options (la petite forme d'engrenage), et cliqué sur "réparer le système de fichiers". Boom! A travaillé comme un charme.

    
réponse donnée Cdadgy71 02.06.2018 - 14:07
la source

Lire d'autres questions sur les étiquettes