Ubuntu refuse de transmettre de l'audio via HDMI

64

Mon PC est connecté à des haut-parleurs et à un moniteur. De plus, il est connecté à mon téléviseur LCD Vizio 37 '. Lorsque j'étais sur Windows 7, je pouvais choisir de diffuser du son via HDMI. J'ai le choix dans Ubuntu mais aucun son n'est émis. Des idées? Je ne sais pas comment obtenir les spécifications du système sur Ubuntu, donc si vous en avez besoin, dites-moi comment les obtenir.

aplay -l output:

**** List of PLAYBACK Hardware Devices **** 
card 0: Intel [HDA Intel], 
device 0: ALC887 Analog [ALC887 Analog] 
Subdevices: 0/1 
Subdevice #0: 
subdevice #0 card 0: Intel [HDA Intel], device 3: ALC887 Digital [ALC887 Digital] Subdevices: 1/1 
Subdevice #0: subdevice #0 card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 
    
posée Michael 13.03.2012 - 08:13
la source

4 réponses

89

Avec le câble HDMI branché, exécutez l’utilitaire suivant:

speaker-test --channels 2 --rate 48000 --device hw:0,3

(pour d’autres, le hw: x, y est x = card, y = device)

Cela exécute juste un test sonore avec des rebonds statiques. Une fois qu'il a joué sur chaque haut-parleur, appuyez sur Ctrl + c pour l'arrêter, puis vérifiez vos paramètres audio pour voir si la sortie HDMI est maintenant répertoriée sous le périphérique interne.

C'était tout ce que je devais faire pour que ça marche. Si cela ne fonctionne pas pour vous, consultez ce tutoriel pour mettre à niveau alsa vers la version ppa.

    
réponse donnée Bryan Agee 01.04.2012 - 03:03
la source
60

Vous pouvez essayer d'installer le programme "PulseAudio Volume Control" ( sudo apt-get install pavucontrol )

Dans l'onglet Configuration , sélectionnez le profil mentionnant HDMI.

La sortie audio du bureau doit immédiatement passer en HDMI.

    
réponse donnée gsedej 24.12.2012 - 19:36
la source
3

J'ai eu des problèmes similaires et tous les forums que j'ai pu trouver parlaient de PulseAudio et AlsaMixer. Aucune de ces solutions n'a fonctionné pour moi.

J'ai finalement trouvé ma solution en mettant à jour mon pilote de cartes graphiques à partir duquel le câble HDMI était connecté en suivant les étapes ici .

Vous n’avez peut-être pas les mêmes cartes graphiques, mais vous pouvez essayer de mettre à jour votre pilote.

    
réponse donnée Leet 10.04.2016 - 14:50
la source
2

Installez GNOME alsa mixer qui se trouve dans le référentiel d’univers (activez le référentiel d’univers dans vos sources logicielles en exécutant Software & amp; Mises à jour et en vérifiant que la deuxième boîte est cochée) Logiciel.

lancez-le et vous verrez un écran comme celui-ci:

désactivez tout en désactivant les cases à cocher mute, puis cochez la case IEC958 .

    
réponse donnée Rajathithan Rajasekar 18.08.2013 - 17:25
la source

Lire d'autres questions sur les étiquettes