Qu'est-ce que "dist-upgrade" et pourquoi met-il à jour plus que "upgrade"?

340

Je me demandais pourquoi upgrade ne souhaitait parfois pas mettre à niveau certaines parties du système, alors que dist-upgrade le faisait. Voici un exemple après avoir exécuté apt-get upgrade :

apt-get upgrade :

rimmer@rimmer-Lenovo-IdeaPad-S10-2:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

versus apt-get dist-upgrade :

rimmer@rimmer-Lenovo-IdeaPad-S10-2:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-3.0.0-13 linux-headers-3.0.0-13-generic
  linux-image-3.0.0-13-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic
3 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 48.5 MB of archives.
After this operation, 215 MB of additional disk space will be used.
Do you want to continue [Y/n]?

En d'autres termes, pourquoi cela ne peut-il pas être effectué par upgrade ?

    
posée Richard Rodriguez 22.11.2011 - 07:03
la source

4 réponses

282

apt-get manual :

upgrade
   upgrade is used to install the newest versions of all packages
   currently installed on the system from the sources enumerated in
   /etc/apt/sources.list. Packages currently installed with new
   versions available are retrieved and upgraded; under no
   circumstances are currently installed packages removed, or packages
   not already installed retrieved and installed. New versions of
   currently installed packages that cannot be upgraded without
   changing the install status of another package will be left at
   their current version. An update must be performed first so that
   apt-get knows that new versions of packages are available.

dist-upgrade
   dist-upgrade in addition to performing the function of upgrade,
   also intelligently handles changing dependencies with new versions
   of packages; apt-get has a "smart" conflict resolution system, and
   it will attempt to upgrade the most important packages at the
   expense of less important ones if necessary. So, dist-upgrade
   command may remove some packages. The /etc/apt/sources.list file
   contains a list of locations from which to retrieve desired package
   files. See also apt_preferences(5) for a mechanism for overriding
   the general settings for individual packages.

Et avec l’outil apt plus récent disponible à partir du 14.04:

full-upgrade
   full-upgrade performs the function of upgrade but may also remove
   installed packages if that is required in order to resolve a
   package conflict.

Dans votre cas particulier, je vois, par exemple, que linux-headers est un paquet virtuel fourni à la fois par linux-headers-3.0.0-12 et linux-headers-3.0.0-13 et qui ressemble au type d'installation et de suppression de paquet géré par dist-upgrade , mais pas par upgrade .

    
réponse donnée jcollado 22.11.2011 - 07:57
la source
117

apt-get upgrade est limité au cas où les packages doivent être remplacés par des versions plus récentes, mais aucun package ne doit être ajouté ou supprimé. Une nouvelle version de Firefox, par exemple, devrait pouvoir être installée avec apt-get upgrade .

Cependant, apt-get upgrade refusera de travailler lorsque des ajouts ou des suppressions sont requis par les versions mises à jour. Par exemple, lorsque le noyau linux-image-3.2.0-10-generic est installé et que linux-image-3.2.0-11-generic apparaît, le package linux-image-generic est mis à jour pour dépendre de la nouvelle version. Pour installer le nouveau noyau, vous devez exécuter apt-get dist-upgrade .

Remarquez comment apt-get upgrade dira que les paquets du noyau ont été held back . C'est le repère pour utiliser apt-get dist-upgrade .

    
réponse donnée pablomme 27.01.2012 - 17:34
la source
32

En principe, la mise à niveau ne mettra à niveau que les packages existants d’une version à une autre. Il n'installe ou ne supprime pas les packages, même si cela est nécessaire pour mettre à niveau les autres. Dans le cas des mises à jour du noyau, la mise à niveau du paquetage linux-generic nécessite l’installation du nouveau paquetage linux-3.0.0-13-generic, et comme la mise à niveau refuse d’installer ou de supprimer des paquets, il refuse de mettre à jour linux-generic.

Parfois, plusieurs incompatibilités entre les packages nécessitent la suppression de certains packages pour mettre à jour d’autres, ce qui nécessitera également une mise à niveau. Les mises à jour du noyau nécessiteront toujours une mise à niveau distale en raison de leur traitement. Plutôt que d'avoir un paquet de noyau mis à jour, un paquet de noyau entièrement nouveau est créé à chaque fois, et le métapaquet du noyau est mis à jour pour dépendre du nouveau paquet de noyau au lieu de l'ancien. Cela a été fait pour que vous conserviez les anciennes versions du noyau afin que, en cas de problème lors du démarrage du nouveau noyau, vous puissiez choisir l’ancien dans le menu de démarrage et le récupérer.

    
réponse donnée psusi 22.11.2011 - 15:45
la source
11

La commande apt-get upgrade installera normalement uniquement les mises à jour (ou correctifs) sur les packages actuellement installés. En règle générale, une nouvelle version de Mozilla Firefox , par exemple, serait installée avec cette commande.

Cependant, apt-get upgrade ne PAS installera de nouvelles versions, où des modifications majeures (y compris la suppression de packages ou la mise à jour GRUB sont requises). Par exemple, lorsqu'un nouveau noyau Linux (linux-image-3.x.x-xx-generic, etc.) est disponible, le paquet ne sera pas installé.

Pour installer le nouveau noyau, vous devez exécuter apt-get dist-upgrade . Vous serez averti lorsque vous exécuterez apt-get upgrade , car certains paquets auront été bloqués. C'est votre repère à utiliser: apt-get dist-upgrade .

    
réponse donnée david6 28.01.2012 - 01:55
la source

Lire d'autres questions sur les étiquettes