Nécessite l'installation de paquets non fiables?

76

J'ai essayé d'installer VLC Player hier et j'ai reçu l'erreur Requires installation of untrusted packages . J'ai cherché pendant des heures pour une solution à ce problème, et j'ai finalement trouvé une suggestion qui disait de changer de serveur pour le téléchargement des mises à jour. Je l'ai fait et cela m'a donné une erreur 404 lorsque j'ai cliqué sur "Vérifier" dans le gestionnaire de mise à jour. J'ai essayé de rétablir le serveur principal (et ensuite plusieurs autres), mais je continue à recevoir une erreur 404:

Et l'autre erreur que j'ai lors du téléchargement ou de la mise à jour:

Modifier: Sortie de cat /etc/apt/sources.list :

deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise universe
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse #Added by software-properties

deb http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-security restricted main multiverse universe #Added by software-properties
deb http://us.archive.ubuntu.com/ubuntu/ precise-security universe

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
    
posée Isaiah Bugarin 04.09.2012 - 23:19
la source

4 réponses

89

Sur la base des erreurs que vous avez collées dans la section commentaires de ma réponse précédente, j'ai une autre solution possible:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean 
sudo apt-get update

Cela reconstruira le cache.
Courtoisie: lien

    
réponse donnée saji89 08.09.2012 - 08:43
la source
33

Ce lien peut aider . Cela résout un problème très similaire.

En gros, vous ouvrez un terminal et tapez sudo apt-get update && sudo apt-get upgrade . Cela l'a fait pour moi.

    
réponse donnée Jorge M. Treviño 08.09.2012 - 06:27
la source
5

La réponse acceptée ne m'a pas aidé dans mon cas (Ubuntu 13.10) mais j'ai pu contourner le problème en mettant à jour la ligne de commande plutôt que via Software Updater (au cas où quelqu'un rencontrerait ce problème).

sudo aptitude upgrade

m'a présenté le paquet particulier provenant d'une source non fiable (Music Manager de Google) et m'a demandé si je voulais l'accepter et la mettre à niveau.

    
réponse donnée David Ashford 15.03.2014 - 12:01
la source
2

J'ai eu exactement la même erreur en essayant de mettre à jour l'indicateur du système.

Dans mon cas, c’était à cause des clés GPG manquantes. Il y a une réponse ici qui vous demandera d'installer un gestionnaire PPA et il peut essayer d'importer toutes les clés manquantes. Je l'ai fait et cela ne m'a donné aucune confirmation que les clés manquantes avaient été importées, mais j'ai ensuite effectué la mise à jour et l'installation s'est bien déroulée.

C'est un message d'erreur horrible (non utile) que je dois dire dans ce cas.

lien

    
réponse donnée Elijah Lynn 03.09.2014 - 17:01
la source

Lire d'autres questions sur les étiquettes