Comment installer Adobe Acrobat dans Ubuntu 16.04?

91

Je connais le fil Comment installer le package deb Adobe Acrobat Reader téléchargé depuis le site Web d'Adobe? Cependant, il n'y a pas de Plus de Linux sur le site d’installation ici . Tentatives infructueuses

  • Je fais la proposition de DriraWassim qui n’ajoute rien à apt-get et n’affiche pas le package .deb installé dans le chemin / la recherche

    sudo apt-get install libxml2:i386 
    sudo apt-get update
    sudo apt-get upgrade 
    apt-cache search adobereader-enu
    

    Je télécharge le dernier package .deb ici . et lancez-le. Je ne trouve pas l'application quelque part dans le système. Ce n'est pas dans le chemin et pas dans la recherche d'Ubuntu. Comment pouvez-vous le démarrer?

Système: Ubuntu 16.04, 64 bit
Matériel: Macbook Air 2013-mid
Noyau Linux: 4.6

    
posée Léo Léopold Hertz 준영 05.05.2016 - 12:50
la source

7 réponses

108

J'ai suivi les conseils ci-dessous sur Kubuntu 16.04 64 bit:

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
sudo apt install adobereader-enu

Après avoir correctement installé Adobe Reader, n'oubliez pas de supprimer le référentiel Canonical Partners pour Precise:

sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
sudo apt update
    
réponse donnée A.Pereira 31.07.2016 - 22:17
la source
36

Pour Adobe Reader 9.5.5 (exécuté nativement sans Wine)

N'ajoutez pas le dépôt Ubuntu 12.04 Partner, vous n'êtes pas vraiment censé ajouter des dépôts à partir des versions précédentes d'Ubuntu! Récupérez le fichier Deb depuis ici ( source - il est également associé à la question), Non, il ne sera pas automatiquement mis à jour mais puisqu'il n'est plus supporté (et Ubuntu ne peut de toute façon pas patcher les vulnérabilités de sécurité dans Ubuntu 12.04 parce que c'est propriétaire) cela n'a pas d'importance. Vous avez moins de chance de détruire votre système si vous l'obtenez de cette façon.

Si vous ne pouvez pas trouver / exécuter Adobe Reader, vous devrez exécuter sudo apt -f install pour résoudre les dépendances. Si cela ne fonctionne toujours pas, essayez sudo apt install libxml2:i386 .

Ceci est, bien sûr, une version très obsolète d’Adobe Reader, mais ce n’est pas la faute d’Ubuntu, Adobe n’a pas mis à jour le client Linux d’Adobe Reader. Vous pouvez, cependant, obtenir une version plus récente en utilisant le processus ci-dessous (ceci installe une version Windows d'Adobe Reader sur Ubuntu).

Pour Adobe Reader DC 1501020056 (exécuté avec Wine 1.9)

  1. Installez PlayOnLinux
  2. Charger PlayOnLinux
  3. Cliquez sur "Installer" (dans la barre d’outils)
  4. Tapez "Adobe Acrobat Reader DC" dans la barre de recherche
  5. Cliquez sur "Adobe Acrobat Reader DC"
  6. Cliquez sur "Installer" (en bas à droite)
  7. Suivez les écrans d'installation
  8. Une fois installé, cliquez sur "Adobe Acrobat Reader DC"
  9. Cliquez sur "Exécuter" (dans la barre d’outils)

Vous devez ouvrir PlayOnLinux pour exécuter Adobe Reader DC à chaque fois (notez que vous pouvez l’installer avec Adobe Reader 9.5.5). Vous pouvez faire glisser le fichier du bureau dans le lanceur pour y obtenir un bouton, vous pouvez également ajouter une icône dans le tableau de bord Ubuntu en utilisant Alacarte («Menu principal»). Je pourrais ajouter des instructions pour cela plus tard. Malheureusement, même cette version n'est pas complètement à jour (il existe probablement des vulnérabilités de sécurité non corrigées dans cette version et Wine est également obsolète, même si cela n'a pas d'importance). Pour installer la dernière version de Reader, DC ou non-DC, vous devez le faire manuellement en utilisant PlayOnLinux. Je pourrais écrire des instructions pour cela ou écrire un script POL pour le faire ultérieurement.

    
réponse donnée Ads20000 20.11.2016 - 23:49
la source
14

Oui, mais le support a été supprimé. Cochez ceci et suivez les instructions pour installer:

  
  1. Ouvrez le terminal en appuyant sur Ctrl + Alt + T sur le clavier. Quand il s'ouvre, collez la commande ci-dessous et appuyez sur Entrée pour ajouter le référentiel:

    sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
    
         

    Saisissez votre mot de passe utilisateur lorsqu'il vous le demande. Notez qu'il n'y a pas de retour visuel lorsque vous tapez un mot de passe.

  2.   
  3. Après avoir ajouté le référentiel, mettez à jour les listes de packages et installez le package acroread en exécutant les commandes un par un:

    sudo apt-get update
    sudo apt-get install acroread
    
         

    Une fois installé, vous devriez pouvoir l’ouvrir à partir du tableau de bord Unity ou du menu Application.

  4.   
  5. Après avoir correctement installé Adobe Reader, n'oubliez pas de supprimer le référentiel Canonical Partners pour Precise:

    sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
    sudo apt-get update
    
  6.   
  7. Comment définir Adobe Reader comme lecteur de PDF par défaut:

  8.   

Exécutez la commande ci-dessous dans le terminal pour modifier le fichier de configuration:

    sudo gedit /etc/gnome/defaults.list
     

Lorsque le fichier s'ouvre, faites:

     

Découvrez et changez la ligne

application/pdf=evince.desktop
     

dans:

application/pdf=acroread.desktop
     

Ajoutez la ligne ci-dessous à la fin:

application/fdf=acroread.desktop
application/xdp=acroread.desktop
application/xfdf=acroread.desktop
application/pdx=acroread.desktop
     

Enfin, enregistrez le fichier et redémarrez nautilus (exécutez la commande nautilus -q in terminal) pour appliquer les modifications.

    
réponse donnée Mookey 05.05.2016 - 12:57
la source
11

Vous devriez juste pouvoir télécharger le fichier .deb ici: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

et installez-le en ouvrant ce fichier. Essayez d'installer via le terminal pour voir les erreurs s'il ne fonctionne pas via l'interface graphique du gestionnaire de logiciel: lien

J'ouvre généralement les fichiers avec Acrobat en utilisant le terminal et la commande acroread filename.pdf . Il a fallu du temps pour ouvrir la première fois que je l'ai couru.

Lorsque je l’ai récemment installé sur Ubuntu 16.04, j’ai eu quelques erreurs:

libxml2.so.2: cannot open shared object file: No such file or directory

et

Gtk-Message: Failed to load module "canberra-gtk-module"

J'ai corrigé cela avec

sudo apt-get install libxml2:i386 libstdc++6:i386 ( ici )

et

sudo apt-get install libcanberra-gtk-module:i386 ( ici )

Apparemment, il peut y avoir une autre erreur liée à adobereader-enu:i386 ; courir:

sudo apt-get install libgtk2.0-0
sudo apt-get -f install

Ensuite, installez à nouveau le fichier .deb et vous devriez être trié.

    
réponse donnée wordsforthewise 27.05.2017 - 06:04
la source
8

Installation de dépendances pour Adobe Reader

sudo apt-get install gtk2-engines-murrine:i386 libcanberra-gtk-module:i386 libatk-adaptor:i386 libgail-common:i386

Installez Adobe Reader à l’aide des commandes suivantes

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner" 
sudo apt-get update 
sudo apt-get install adobereader-enu

Après l'installation, vous devez supprimer le référentiel précis à l'aide des commandes suivantes

sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner" 
sudo apt-get update

Pour la configuration I A écrit un article breif Installation d'Adobe Reader dans Ubuntu 16.04 / 16.06

    
réponse donnée MC Naveen 10.04.2017 - 18:50
la source
2

J'ai trouvé que:

sudo apt install adoberead-enu

... jette une erreur à l'effet qu'il n'a pas pu trouver le paquet adoberead-enu. Cependant quand j'ai fait:

sudo apt install adoberead-bin:i386

... ça a marché, et le résultat semble être un Adobe Reader fonctionnel.

J'utilise Ubuntu 16.04.

    
réponse donnée Rolf Turner 27.09.2016 - 05:50
la source
1

Vous pouvez toujours utiliser sa dernière version "Adobe Acrobat Reader DC" avec Wine, bien que Adobe ait abandonné son logiciel de lecture de PDF pour Linux il y a plusieurs années. Cela fonctionne parfaitement pour moi.

Installez d'abord wine et winetricks

sudo apt install wine-stable winetricks

Préparez le vin pour recevoir l'installation d'Acrobat Reader DC:

winetricks mspatcha

Téléchargez la dernière version d'Adobe Reader pour Windows 10 à partir du site officiel lien

Un fichier avec extension exe sera téléchargé. ( AcroRdrDC1801120040_en_US.exe ) Maintenant, installez ce fichier exe dans wine:

wine AcroRdrDC1801120040_en_US.exe

(Utilisez le même nom que celui du fichier exe téléchargé)

Cliquez sur le bouton Install .

Attendez que l'installation soit terminée et cliquez sur Finish .

Maintenant, recherchez Acrobat Reader dans le menu des applications et ouvrez-le.

Sélectionnez Always open with Protected Mode Disabled . (Adobe Reader DC s'exécute en mode protégé par défaut pour fournir un niveau de sécurité supplémentaire)

Accepter la licence.

Maintenant, vous pouvez ouvrir vos fichiers en utilisant Acrobat Reader DC même sur Ubuntu.

    
réponse donnée Tejesh Raut 19.05.2018 - 09:42
la source

Lire d'autres questions sur les étiquettes