Comment installer PostgreSQL 9.6 sur une version d'Ubuntu?

83

Comment est-ce que j'installe PostgreSQL 9.6 sur n'importe quelle version d'Ubuntu puisqu'il ne vient pas par défaut avec la version la plus récente?

Ubuntu Xenial (16.04) est livré avec PostgreSQL 9.5 à partir des référentiels par défaut.

    
posée Victor 29.09.2016 - 19:38
la source

3 réponses

179

Pour les versions suivantes d’Ubuntu, vous pouvez l’installer avec les commandes indiquées, conformément à la référentiel PostgreSQL Apt officiel .

Ubuntu 17.04 - 17.10

La version 9.6 est livrée avec la distribution.

sudo apt-get install postgresql-9.6

Ubuntu 12.04, 14.04, 16.04

sudo add-apt-repository "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -sc)-pgdg main"
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get install postgresql-9.6
    
réponse donnée Victor 29.09.2016 - 19:38
la source
12

Suivez les étapes ci-dessous:

Référence est extrait de ce blog.

Vous devez ajouter le dernier référentiel PostgreSQL pour la dernière version.

sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main"

Mettre à jour et installer PostgreSQL 9.6:

sudo apt-get update
sudo apt-get install postgresql-9.6

La base de données superutilisateur et postgres postgres par défaut est créée. Vous devez définir un mot de passe pour le super utilisateur de postgres.

[email protected]:~$ sudo passwd postgres
Enter new UNIX password:****
Retype new UNIX password:****
passwd: password updated successfully

Si le service n’est pas démarré, vous pouvez démarrer le service PostgreSQL.

sudo service postgresql start

Connecter le serveur PostgreSQL avec l’utilisateur postgres:

[email protected]:~$ su postgres
Password:****

Créez une base de données exemple:

createdb database_name

Connectez-vous à cette base de données:

psql -d database_name
    
réponse donnée Anvesh 18.01.2017 - 22:24
la source
1

J'ai suivi cet message Github - Je lance ubuntu xenial dans un vagabond et je souhaite mettre à jour la version 9.5 à 9.6 du référentiel officiel postresql pour que je puisse utiliser l’extension PostGIS qui est la plus utilisée par version 9.6 (mentionnée officiellement sur leur site) J'espère que cela aide quelqu'un.

    
réponse donnée Sanchit 24.06.2017 - 16:09
la source

Lire d'autres questions sur les étiquettes