Le clavier se verrouille dans IntelliJ IDEA sur Ubuntu 14.04

164

Pourriez-vous m'aider avec un problème étrange? J'utilise Intellij IDEA 13 sur Ubuntu 14.04 et, de temps en temps, mon clavier se verrouille complètement (oui, complètement, il ne s'agit pas de raccourcis) dans IDEA. Je peux toujours faire tout ce que je veux dans IDEA avec ma souris, aussi je peux utiliser le clavier partout ailleurs sauf IDEA. Et cela ne peut être corrigé qu'en redémarrant IDEA jusqu'à présent.

Quelqu'un peut-il donner un indice, s'il vous plaît?

    
posée Treble Snake 24.07.2014 - 08:58
la source

4 réponses

206

Il existe un problème non résolu dans jetbrains youtrack for intellij idea qui recommande deux solutions:

  1. L'entrée du clavier peut être déverrouillée en redémarrant le démon IBus depuis une console:

    ibus-daemon -rd
    
  2. IBus peut être désactivé pour IDEA en désactivant env. variable XMODIFIERS, mais la capacité à saisir des caractères nationaux dans IDEA sera perdue:

    XMODIFIERS="" idea.sh
    

J'ai utilisé le second et j'ai corrigé mon problème.

    
réponse donnée Saeed Zarinfam 18.10.2014 - 18:50
la source
14

J'ai été capable de le résoudre avec ce que j'ai trouvé ici qui ajoute essentiellement export XMODIFIERS="" sur idea.sh

    
réponse donnée Alfergon 05.03.2015 - 17:45
la source
5

Pour une solution permanente , la mise à jour du 1er octobre 2015 sur le problème recommande à:

Mettez à niveau IBus vers la version 1.5.11 ou ajoutez export IBUS_ENABLE_SYNC_MODE=1 à votre ~/.profile , puis redémarrez une session.

Vous pouvez également désactiver IBus à System Settings | Language Support | Keyboard input method .

IDEA 15 affichera un avertissement si une version incompatible d’IBus est utilisée.

    
réponse donnée Alex 30.11.2015 - 12:53
la source
1

J'ai essayé ceci et son fonctionnement jusqu'à présent, mais je le mettrai à jour s'il se fige à nouveau. J'ai vu une suggestion sur youtrack qui suggère d'éteindre iBus qui semble interférer en particulier à cause de l'utilisation du raccourci ctrl + espace pour modifier les paramètres de langue. Vous pouvez le faire en allant sur:

support de la langue & gt; méthode de saisie au clavier système & gt; aucun

**** UPDATE *****

Après l'avoir exécuté pendant un moment, cette technique ne fonctionnait toujours pas car je continuais à geler. Je suppose que pour l'instant je vais m'en tenir à la solution de contournement suivante pour redémarrer ibus, ce qui est un peu gênant, mais que pouvez-vous faire?

entrer dans le terminal

tapez:

ibus-daemon -rd
    
réponse donnée ThinkBonobo 05.04.2015 - 02:33
la source

Lire d'autres questions sur les étiquettes