Ubuntu 17.10 Nvidia Drivers, boucle d'écran noir?

15

Très bien, j'ai donc dû faire face à un problème similaire tout au long de l'utilisation d'Ubuntu avec Nvidia. Mais avec la nouvelle mise à jour de la version 17.10, un nouveau bogue a été récemment discuté. Mon écran est passé dans un écran noir et la boucle "a arrêté le gestionnaire d’utilisateur pour uid (#)". depuis l'ordinateur, le maintien des touches au démarrage ne fait rien.

Donc, comme solution de contournement, j'ai SSHed sur le bureau et j'ai essayé des solutions de contournement que j'ai entendues sur des forums aléatoires.

Tentative:

  • décommenté "WaylandEnable = false" dans (/etc/gdm3/custom.conf)
  • "nomodeset" dans grub (/ etc / default / grub)
  • réinstaller les pilotes après et avant

Ces tentatives n’ont rien changé au résultat du problème. La seule chose qui a aidé est la suppression des pilotes Nvidia que j'ai initialement installés via l'interface graphique de Software Update, ce qui a rendu le périphérique amorçable.

J'espère que vous pourrez m'aider à utiliser à nouveau les bons pilotes Nvidia; -;

    
posée Mr.Midnight 24.10.2017 - 06:05
la source

8 réponses

4

Cela ressemble à un problème que je rencontrais, auquel j'ai répondu dans cette discussion

Il semble que la mise à jour d'Ubuntu ait basculé sur un noyau à faible latence, qui ne mettait pas automatiquement à jour l'installation des en-têtes du noyau, et que les paquets binaires nvidia requièrent la présence des en-têtes du noyau. Essayez ce qui suit:

sudo apt purge 'nvidia-*'
sudo apt install linux-headers-$(uname -r)
sudo apt install nvidia-384

Notez que j’ai empêché gdm d’utiliser Wayland avant d’essayer quoi que ce soit, et selon ce que je comprends, Wayland ne travaillera pas avec les binaires nvidia, alors je vous conseille de le désactiver dans /etc/gdm3/custom.conf en décommentant la ligne #WaylandEnable=false .

    
réponse donnée Steven Murdoch 24.10.2017 - 19:19
la source
3

Grâce à la réponse de Steven , je suis sur la bonne voie et après quelques recherches sur Google, j'ai trouvé le < a href="https://bbs.archlinux.org/viewtopic.php?id=220296"> dernière réponse dans (bien sûr) la communauté dynamique d’Arch Linux: -)

Donc, ce que Steven a trouvé, c'est que les fichiers d'en-tête du noyau à faible latence sont manquants. Donc, vous devez faire:

sudo apt install linux-headers-$(uname -r)

Et une exigence pour Wayland sur NVidia (il faut au moins Gnome 3.23, mais Ubuntu 17.10 est livré avec 3.26 pour que nous soyons couverts) consiste à activer KMS, en éditant votre fichier /etc/default/grub et en modifiant la ligne suivante en Ajouter nvidia-drm.modeset=1 , voir exemple:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"

Remarque: ne supprimez pas d’autres paramètres si vous en avez / avez besoin, ajoutez simplement le paramètre de mode NVidia DRM.

Ensuite, vous devez régénérer les modules initramfs et le noyau. Le mieux est de faire comme le suggère Steven, de supprimer le paquet nvidia et de le réinstaller (une réinstallation potentielle pourrait fonctionner, mais je n’ai pas essayé, c’est-à-dire que sudo apt install --reinstall nvidia-xxx replace xxx cartes récentes).

sudo apt remove --purge nvidia-xxx
sudo apt install nvidia-xxx

PS: Je savais qu'il y avait un moyen de fonctionner, car cela fonctionnait sur ma boîte Fedora 25 (maintenant 26) avec une carte NVidia également)

PS2: Je souhaite que le pilote nouveau fonctionne mieux car je ne crains pas d’échanger un peu de performance pour un pilote open source. Mais même en 2D, le défilement d'une page est terriblement lent et pas fluide avec le nouveau, et cela ne va pas encore pour moi. Je souhaite vraiment que le nouveau soit meilleur en 2D (et en 3D) ou que AMD s'améliore en créant une carte passive et à faible consommation. Quoi qu’il en soit, ils font un travail formidable compte tenu de la relation avec NVidia.

    
réponse donnée Huygens 26.10.2017 - 10:08
la source
2

J'ai exactement le même problème avec une GTX 1060, j'ai essayé les corrections suggérées (désactivation de Wayland dans la configuration et correction du pilote défectueux) mais cela ne fonctionne toujours pas. Cependant, je peux étrangement entrer en mode de récupération dans grub (avec le noyau générique) et en sélectionnant resume.

EDIT

J'ai réussi à le faire fonctionner! Pour ce faire, je suis allé à grub, sélectionné "c" pour la ligne de commande, entré la commande "videoinfo" - vu que mon paramètre vidéo par défaut est 1024x768 .. est allé dans / etc / default / grub et a ajouté les lignes GRUB_GFXMODE = 1024x760 GRUB_GFXPAYLOAD_LINUX = 1024x768 et définissez GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" - puis mettez à jour-grub et redémarrez. Cependant, cela ne fonctionnait que lors de la sélection du noyau générique dans les "options avancées" de grub, et non de la version basse. J'ai également vu un certain nombre de messages sur "démarrer / arrêter nvidia persistait" qui peuvent être liés ou non.

2ème édition

@Huygens a mentionné l'utilisation de l'option de démarrage de nvidia-drm.modeset = 1 dans / etc / default / grub, qui fonctionnait également plutôt que d'utiliser nomodeset. Cependant, je ne peux toujours pas utiliser le noyau à faible latence, même après avoir corrigé les fichiers d'en-tête manquants. Il ne va pas non plus charger Wayland. J'ai vu un certain nombre de messages dans la région disant que mon cas particulier pouvait être lié à une vidéo intel intégrée et à une carte nvidia dédiée causant des problèmes avec nvidia-persistentenced et gdm3 ( lien ). Certaines personnes ont également signalé un succès en utilisant lightdm (dpkg-reconfigure lightdm), mais je ne pouvais pas le connecter sans redémarrer lightdm à chaque fois.

    
réponse donnée Roland Quast 25.10.2017 - 09:18
la source
1

Je devais juste désactiver Wayland: "WaylandEnable = false" dans (/etc/gdm3/custom.conf) et maintenant tout fonctionne correctement!

    
réponse donnée Pöl Halbert 24.10.2017 - 18:58
la source
0

Hier, j'ai finalement réussi à installer Ubuntu 17.10 sur mon PC. En fait, j'ai installé Ubuntu 16.10 avant d'essayer de mettre à niveau 17.04. Ensuite, j'ai réalisé que les pilotes NVIDIA ne fonctionnaient plus sur Ubuntu 17.04. J'ai essayé de passer en mode de récupération pour réinstaller les pilotes, mais rien n'a fonctionné. Jusqu'à présent, je ne comprends toujours pas. J'étais bloqué depuis un moment sur les pilotes NVIDIA. Ensuite, j'ai décidé de démarrer Ubuntu 17.10 avec mon USB.

  1. Démarrez avec votre périphérique USB.
  2. Sélectionnez "Essayer ubuntu sans installer" dans le fichier.
  3. Appuyez sur "e" pour modifier
  4. Remplacer "mode silencieux" par "nomodeset"
  5. Presse "Ctrl + X" pour démarrer.
  6. Installez votre système puis redémarrez.
  7. Premier démarrage après l’installation, vous devez également éditer le Grub comme 3. Et 4.
  8. Installez les pilotes NVIDIA. lien
  9. Quelle que soit la méthode que vous utilisez dans 8. Vous devez vous assurer que les "Paramètres de NVIDIA X Server" affichent les options de paramétrage, alors vous êtes prêt à partir. Redémarrez et profitez de votre Ubuntu.

  10. Si ce n’est pas le cas:

  11. Allez dans "Logiciels & amp; Mises à jour "- & gt; "Pilotes supplémentaires", sélectionnez le pilote par défaut "Utiliser X.Org ..."

  12. Dans le terminal: (installez lightdm si ce n’est pas encore installé) "Sudo service lightdm restart" "Sudo apt-get remove --purge nvidia - *"
  13. Revenir à "Logiciel & amp; Mises à jour "- & gt; "Pilotes supplémentaires", puis choisissez les suites du pilote à la carte.
  14. "sudo service lightdm restart"
  15. Redémarrez votre système
réponse donnée tho.nguyenkhac 27.10.2017 - 11:29
la source
0

Le problème n'est pas nvidia , c'est gdm3 . Vous devez utiliser lightdm au lieu de gdm3 avec nvidia . Vous devez également installer le header en premier.

sudo apt purge nvidia-*
sudo apt install linux-headers-$(uname -r)
sudo apt --no-install--recommends install nvidia-384
sudo apt install lightdm

Maintenant, redémarrez. Tout devrait bien se passer. Bumblebee travaille également avec nvidia-384 et nvidia-387

    
réponse donnée shantanu 02.11.2017 - 21:36
la source
0

Ce contournement temporaire pour charger les pilotes Nvidia semble fonctionner pour moi (AMD FX6300, Geforce GT730, mise à niveau vers 17.10 à partir de 17.04):

  1. démarrer dans le menu de récupération

  2. charger la racine ( / ) en lecture / écriture (j'utilise des paquets défectueux)

  3. ouvrir un shell racine

  4. purger, puis installez les pilotes Nvidia

    sudo apt remove --purge nvidia-*
    sudo install nvidia-384
    
  5. quitte le shell pour continuer le démarrage

À ce stade, je peux me connecter avec Unity ou Ubuntu.

(Je suppose que cela permet au pilote d'être contourné pour le démarrage, mais disponible pour les applications.)

    
réponse donnée user266235 26.10.2017 - 18:17
la source
0

Désinstaller Upstart (sudo apt remove upstart) - si installé. Apparemment, cela tombe de 17.10 & amp; 18.04 dans tous les cas, mais peut causer des problèmes.

En dehors de cela, bien qu’il continue à être flou, l’ajout de nomodeset à Grub (donc GRUB_CMDLINE_LINUX="nomodeset" dans etc / default / grub) obtient au moins un système de travail.

    
réponse donnée Lemon Dexter 17.04.2018 - 16:26
la source

Lire d'autres questions sur les étiquettes