Le bureau oublie le thème?

78

Je cours Ubuntu dans VirtualBox (sur un hôte Windows 7). Plusieurs fois, la barre de menus de niveau supérieur, la barre des tâches - et apparemment toutes les boîtes de dialogue du système - ont oublié le thème "Ambiance" prêt à l'emploi auquel ils se sont conformés lors de la première installation du système. Les légendes de fenêtre conservent toujours le thème, mais pratiquement rien d'autre ne le fait.

J'ai cherché haut et bas sur Google pour obtenir de l'aide avec ce problème. Tout ce que j'ai trouvé suggère de lancer une réinitialisation de gconf ou de supprimer .gconf * .gnome * et d'autres répertoires similaires. J'ai suivi tous ces conseils et rien ne fonctionne. Je reçois toujours un aspect 3D gris ennuyeux de style Windows-95. Auparavant, après beaucoup de dérangement, j'ai abandonné et redémarré l'instance VM, et j'ai été agréablement surpris de voir le thème "Ambience" original restauré dans toute l'interface utilisateur, mais disparaît invariablement plus tard, généralement après un redémarrage, donc je ne peux jamais comprendre ce que j'ai fait qui l'a brisé.

Voici un exemple du site d'Ubuntu sur lequel je veux qu'il ressemble.

Et voici une capture d'écran de mon système tel qu'il se présente actuellement.

Notez également que mes terminaux GNOME ont normalement un joli aspect violet semi-translucide et, comme on peut le voir sur la capture d'écran, ils ne sont plus qu'un blanc mat solide.

Cette dernière fois (juste hier), en essayant de nombreuses combinaisons toutes les astuces habituelles et en redémarrant plusieurs fois n'a pas résolu le problème, alors je suis sur SU demandant:

Comment récupérer le thème prêt à l'emploi pour mon bureau Gnome / Ubuntu, en notant que le fait de faire sauter tous les fichiers de configuration - comme suggéré dans de nombreux endroits en ligne - n'y parvient pas?

Il peut être utile de savoir qu’il semble échouer après avoir redimensionné l’instance de la machine virtuelle, obligeant le bureau Ubuntu à se redimensionner, ou après avoir joué avec les paramètres de Compiz. Je n'ai pas été en mesure de déterminer lequel, et ce ne peut être ni l'un ni l'autre. Compte tenu de l'ampleur de la douleur que j'ai dû subir pour remettre les choses en place (et étant donné que je ne sais pas comment faire), il s'est avéré difficile d'isoler définitivement la cause.

    
posée Marcelo Cantos 13.01.2011 - 03:09
la source

15 réponses

45

La réponse de @ zpletan mène à la chasse autour, ce qui a rapidement mis au jour ce qui semble être la cause profonde de mon problème. Il est détaillé dans Ubuntu Bogue n ° 574296 . En résumé, mon système Core i7 avec un SSD démarre tout avec des timings suffisamment différents pour que gnome-settings-daemon fonctionne trop tôt, bails, et me laisse surtout avec un thème GTK standard.

Un bref sommeil dans /etc/xdg/autostart/gnome-settings-daemon.desktop corrige ce problème:

Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"
    
réponse donnée Marcelo Cantos 17.01.2011 - 03:34
la source
22

Je ne pouvais résoudre ce problème avec aucune des réponses suggérées (la réponse actuellement acceptée fonctionnait sporadiquement, mais ne fonctionnait généralement pas pour moi). J'ai essayé d'augmenter considérablement le temps de sommeil et cela ne fonctionnait toujours pas de manière cohérente.

Cependant, l’une des réponses indique un bug qui suit ce problème, et j’ai trouvé un commentaire sur le bogue qui l'a résolu pour moi.

Voici les principaux éléments:

D'abord, créez un script bash (je l'ai nommé /etc/xdg/autostart/gnomesettingsdaemonfix.sh )

#!/bin/bash

pid=$(pgrep gnome-settings-)

while [ -n "$pid" ];
do
  pid=$(pgrep gnome-settings-)
  sleep 0
done

exit 0

Assurez-vous qu'il est exécutable (exécutez chmod +x ).

Puis éditez /etc/xdg/autostart/gnome-settings-daemon.desktop

Modifiez la ligne Exec en:

Exec=bash -c '/etc/xdg/autostart/gnomesettingsdaemonfix.sh;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

Cela semble s’être arrangé jusqu’à présent pour moi.

    
réponse donnée TM. 15.05.2011 - 23:49
la source
16

Appuyez sur Alt + F2 (Exécuter l’application) et exécutez les opérations suivantes:

gksudo gnome-settings-daemon
    
réponse donnée zpletan 14.01.2011 - 13:13
la source
7

10.10 a ce problème, mais normalement, cela se produit lorsque vous installez le pilote nvidia propriétaire. Cependant, la solution fonctionnera probablement également sur une machine virtuelle.

Créez un fichier texte. Écrivez-le

include "/usr/share/themes/Ambiance/gtk-2.0/gtkrc"
gtk-icon-theme-name = "ubuntu-mono-dark"

et enregistrez-le dans votre dossier personnel sous le nom .gtkrc-2.0. Redémarrer.

S'il y a encore des éléments incorrects (pour moi c'était la police), vous devez ajouter cette modification au fichier google pour un tutoriel sur gtk pour les ajustements possibles.

    
réponse donnée rumtscho 13.01.2011 - 08:55
la source
4

Je cherche un correctif pour ce problème depuis des mois. Apparemment, personne ne sait ce qui le cause. Ce bug existe depuis des années et personne ne l'a corrigé.

Parfois, il se produit lors du démarrage avec une condition de concurrence entre la première et la deuxième instance de gnome-settings-daemon, et parfois au milieu d'une session de bureau active lorsque gnome-settings-daemon cesse de fonctionner ou se bloque. / p>

La seule solution de contournement que j'ai trouvée qui semble la résoudre est de taper

killall gnome-settings-daemon
gnome-settings-daemon &

dans un terminal actif que je laisse ouvert.

La fermeture du terminal tue l'instance d'arrière-plan de gnome-settings-daemon et le bureau revient au thème par défaut (pas Ubuntu par défaut mais gnome par défaut). Par conséquent, je lance le démon en arrière-plan et laisse le terminal en marche aussi car le processus a besoin de son parent.

    
réponse donnée Cheryl 23.01.2012 - 14:10
la source
4

J'ai eu le même problème et j'ai eu une erreur dans la mendicité: Could not apply the stored configuration for monitors.

Suppression du fichier: ~/.config/monitors.xml ré-enregistré et travaillé comme un gant.

    
réponse donnée topless 12.10.2011 - 21:08
la source
2

J'ai le même problème, sudo killall nautilus le répare. (temporairement)

    
réponse donnée Pit 14.01.2011 - 09:12
la source
1

Désolé mais ma suggestion précédente d'utiliser '--sync' n'est pas un correctif. Après quelques redémarrages, le problème est le même.

J'espère que j'ai réussi à capturer la sortie suivante du processus "gnome-settings-daemon" en panne au démarrage lorsque le thème ne parvient pas à s'appliquer:

** (gnome-settings-daemon:1679): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1679): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

Lorsque le thème est appliqué avec succès, il n'y a pas de sortie.

Il semblerait que gnome-settings-daemon fonctionne deux fois. Apparemment, si la première instance se termine avant l'exécution de la seconde instance, le thème sera appliqué sinon il échouera.

REMARQUE: La capture de sortie a été effectuée en éditant l'entrée "Exec=" de /etc/xdg/autostart/gnome-settings-daemon.desktop dans "bash -c" / usr / lib / gnome-settings-daemon / gnome- settings-daemon --debug --sync & amp; & gt; /home/sanjeev/Desktop/test.txt '"(l'option --sync a été utilisée comme recommandé par certains sites Web)

PS: D'autres tests, montrent qu'il y a bien deux instances en cours d'exécution qui devraient s'exécuter les unes après les autres.

Bien que la méthode du «sommeil» puisse suffire, voici une solution plus «techniquement correcte» au problème. J'ai essayé avec 6 redémarrages et le suivant semble fonctionner:

Etape 1: Créez un script (je l'ai appelé gnome-settings-daemon-fix.sh) sous / etc / xdg / autostart avec les éléments suivants:

#!/bin/bash
# gnome-settings-daemon-fix.sh

pid='pgrep gnome-settings-'
wait pid

exit 0

Etape 2: Editez 'gnome-settings-daemon.desktop' sous 'Exec =' et remplacez-le par:

Exec=bash -c 'bash /etc/xdg/autostart/gnome-settings-daemon-fix.sh ;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

Tout est fait. Fondamentalement, nous attendons que la première instance soit sortie avant que la seconde ne soit lancée. Quelqu'un pourrait-il notifier si cela résout leur problème?

    
réponse donnée Sanjeev 28.03.2011 - 01:33
la source
1

J'ai aussi eu le même problème. C'était après une mise à niveau (partielle de l'IIRC) de mon Natty Narwhal tel qu'il était dans l'état alpha 3. Dans mon cas, le fichier ~ / michael / .nautilus / browser.xml semblait être corrompu. Après avoir essayé certaines des suggestions de ce site partiel, j'ai simplement supprimé ce fichier, redémarré mon PC et tous mes thèmes étaient revenus et restaient stables. Je pense que vous pouvez essayer de résoudre votre problème comme moi.

    
réponse donnée Michael Staengl 08.05.2011 - 10:23
la source
1

Cela m'arrive de temps en temps avec 11.04 Unity 3D et chaque fois que je l'ai effacé en ouvrant Apparence, bouton Personnaliser, onglet Icône et en cliquant sur le jeu d'icônes que j'ai choisi, même s'il était indiqué comme étant utilisé. Dans mon cas, ce serait Faenza-Dark. Il arrive si rarement que je n'ai pas encore identifié de séquence d'événements à l'origine de cette situation.

    
réponse donnée fragos 28.08.2011 - 22:58
la source
1

Cela a fonctionné pour moi dans une fenêtre de terminal:

echo "PATH=\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games\"" | tee -a ~/.profile
    
réponse donnée user10655 08.07.2011 - 05:43
la source
1

Voici une solution rapide: accédez à votre console virtuelle, arrêtez gdm, démarrez le serveur X

  1. appuyez sur "Ctrl droite + F1" (Ctrl + Alt + F1 est une combinaison pour les installations non virtualisées)
  2. connectez-vous
  3. tapez: sudo /etc/init.d/gdm stop
  4. tapez: startx

puisque c’est mon premier post, je devais mettre des images comme ceci:

lien

    
réponse donnée nidla 09.11.2011 - 10:18
la source
1

Cela m’est arrivé aussi et dans mon cas, j’ai dû détacher tout mon répertoire personnel, puis restaurer les bits et les morceaux, par la réponse ici . Si vous exécutez les scripts de synchronisation pour gnome-settings-daemon, voyez si vous pouvez le faire fonctionner correctement en créant un autre compte et en vous connectant sous ce compte. Dans mon cas, le deuxième compte n’a pas eu le problème de non-démarrage et, par conséquent, j’ai appliqué le correctif dans le lien.

    
réponse donnée mfisch 12.12.2011 - 07:41
la source
0

S'il vous plaît, essayez ceci et redémarrez! :)

gconftool-2 --shutdown        
rm -rf ~/.gconf/apps/panel       
pkill gnome-panel        
    
réponse donnée Iván Stojanovic 13.01.2011 - 03:20
la source
0

Je pense qu'il y a pas mal de gens avec la bonne idée.

Je suppose qu'après certaines mises à jour (nouveaux noyaux, etc.), ureadahead sera reprofilé. C'est là que je pense que le problème se produit. gnome-settings-daemon est appelé trop tôt.

J'ai supprimé tous les fichiers avec «pack» (pack, home.pack, boot.pack, run.pack) dans le nom dans / var / lib / ureadahead / folder pour forcer une reprofilage. Tout était parfait après ça.

Lors du reprofilage, supprimez les fichiers ci-dessus, redémarrez et connectez-vous rapidement dès que l'écran de connexion s'affiche. Attendez environ 30 secondes ou lorsque le lecteur arrête de tourner avant de faire quoi que ce soit. Laissez-le finir ses affaires. Votre fenêtre de Nautilus devrait être correcte maintenant.

Peut-être qu'un bogue devrait être déposé avec ureadahead pour que gnome-settings-daemon soit désordonné.

    
réponse donnée user32089 10.04.2012 - 09:50
la source

Lire d'autres questions sur les étiquettes