google-chrome-stable continue à demander s'il devrait être défini par défaut

77

Depuis la mise à niveau d'Ubuntu 15.10, google-chrome-stable continue de demander s'il doit être défini comme navigateur par défaut, même s'il l'est déjà. J'ai essayé de le réinstaller, mais cela n'a pas aidé. Des idées?

    
posée Yanick Nedderhoff 23.10.2015 - 10:07
la source

3 réponses

54

Pour le correctif de travail, reportez-vous à la fin de cette réponse.

RÉPONSE INITIALE 28 octobre 2015 (correction obsolète)

Pour éviter de vous demander si vous souhaitez utiliser Chrome comme navigateur par défaut, utilisez la solution de contournement suivante (proposé ici et suggéré dans la section commentaires de cette question par Yurii Kolesnykov ):

Ouvrez le fichier ~/.config/google-chrome/Default/Preferences avec un éditeur de texte.

Trouvez la ligne

"check_default_browser": true,

et remplacez-le par

"check_default_browser": false,

Dans mon cas, le fichier était> 200k caractères, raison pour laquelle gedit a planté plusieurs fois. Si c'est la même chose dans votre cas, vous voudrez probablement utiliser un éditeur basé sur un terminal comme vi.

Notez qu'il s'agit d'une solution de contournement, le problème lui-même doit être résolu par les développeurs Chrome.

MISE À JOUR du 24 novembre 2015

Comme mentionné dans Danilo Piazzalunga , le bogue est confirmé . Comme suggéré par NicDumZ , votez pour ce bug en cliquant sur

pour attirer l'attention. Merci!

MISE À JOUR du 20 février 2016

Comme indiqué en premier par Ron Thompson et 3vi1 dans la section commentaire; et finalement confirmé par moi-même (en utilisant Ubuntu 15.10), cette solution ne semble plus fonctionner, du moins pas pour tout le monde, après la réinstallation de Google Chrome. Tous ceux qui ont utilisé cette solution de contournement doivent essayer d’éviter de réinstaller Chrome.

Je vous encourage à nouveau à dire que vous êtes affecté par le bogue sur le tableau de bord (actuellement 302 personnes).

MISE À JOUR du 5 avril 2016 (correctif de travail!)

Un correctif a été proposé sur tableau de bord qui a apparemment fait le travail pour quelques personnes:

Pour appliquer le correctif, changez la ligne n ° 198 dans le fichier /usr/bin/xdg-settings de

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//''"

à

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//' | head -n 1'"

MISE À JOUR du 25 juillet 2016 (correctif de travail!)

Mise à jour du correctif proposé pour (K) Ubuntu 16.04:

Pour appliquer le correctif, changez les lignes # 177 et # 202 dans le fichier /usr/bin/xdg-settings from

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word"

à

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word | head -n 1'"

Accédez ensuite aux paramètres de Google Chrome et définissez Chrome comme navigateur par défaut.

MISE À JOUR 1er juin 2017

Le bug a été fermé et marqué "Fix Released" à ce jour. Citant l'utilisateur Olivier Tilloy (osomon) :

  

Si je lis le rapport correctement, le problème a été résolu dans xdg-utils dans xenial. Wily est EOL depuis presque un an, alors je ferme le bogue.

     

no longer affects: chromium-browser no longer affects: google-chrome-beta (Ubuntu) no longer affects: google-chrome (Ubuntu) Changed in chromium-browser (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: In Progress → Invalid Changed in xdg-utils (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: Confirmed → Fix Released

    
réponse donnée Yanick Nedderhoff 28.10.2015 - 12:48
la source
3

Cela a été détecté comme un bogue dans les utilitaires XDG, et cela affecte également Chromium Browser.

Voir Bogue LP 1509139 .

    
réponse donnée Danilo Piazzalunga 11.11.2015 - 23:01
la source
-1

J'avais le même problème avec 15.10. Chaque fois que j'ai redémarré et démarré chrome, il s'est plaint que ce n'était pas le navigateur par défaut même si les détails des paramètres des applications par défaut le montrent par défaut pour le web. J'ai remarqué que firefox était la valeur par défaut pour les photos, définissez donc cela sur le visualiseur d'images. Après un redémarrage total, chrome ne se plaint plus. Je devrais essayer quelques fois avant de prétendre que cela résout mon problème mais je voulais partager le résultat initial si quelqu'un est en train d'essayer les choses lui-même.

    
réponse donnée mrh53 31.12.2015 - 18:22
la source

Lire d'autres questions sur les étiquettes