Supprimer une session d'invité à la connexion à Ubuntu 14.04 [dupliquer]

78

J'ai récemment installé Ubuntu 14.04 LTS ça marche bien mais je veux supprimer la connexion au compte invité.

    
posée Sudheer 20.04.2014 - 19:46
la source

3 réponses

133

Appuyez simplement sur Ctrl + Alt + T sur votre clavier pour ouvrir le terminal. Lorsqu'il s'ouvre, exécutez la ou les commandes ci-dessous:

sudo nano /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf

Ajoutez la ligne suivante, enregistrez et fermez.

allow-guest=false

Redémarrez et vous êtes défini.

Modifier

Merci à Gunnar Hjalmarsson

Basé sur le commentaire de Gunnar Hjalmarsson "ubuntu-session a été mis à jour pour la dernière fois à la mi-mars. Essayez sudo apt-get install --reinstall ubuntu-session".

Après quelques recherches, cela peut également être fait différemment.

Ouvrez le fichier /etc/lightdm/lightdm.conf à partir de votre terminal en utilisant la commande suivante:

sudo -H gedit /etc/lightdm/lightdm.conf

Si le fichier existe, ajoutez simplement la ligne suivante:

allow-guest=false

Sinon, copiez et collez les éléments suivants:

[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter
allow-guest=false

Enregistrez le fichier et quittez l'éditeur. Redémarrez votre système, et les modifications resteront même après une mise à jour vers ubuntu-session, comme indiqué dans le commentaire de Gunnar Hjalmarsson.

    
réponse donnée Mitch 20.04.2014 - 20:01
la source
38

Pour supprimer la connexion invité:

  1. sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" > /etc/lightdm/lightdm.conf.d/50-no-guest.conf'

  2. Cela créera un nouveau fichier dans /etc/lightdm/lightdm.conf.d

  3. Pour récupérer la connexion invité à nouveau, supprimez 50-no-guest.conf

Pour supprimer la connexion à distance:

  1. sudo sh -c 'printf "[SeatDefaults]\ngreeter-show-remote-login=false\n" >/etc/lightdm/lightdm.conf.d/50-no-remote-login.conf'

  2. Cela créera un nouveau fichier dans /etc/lightdm/lightdm.conf.d

  3. Pour rétablir la connexion à distance, supprimez 50-no-remote-login.conf

réponse donnée Muddassir Nazir 20.04.2014 - 21:00
la source
0

Ou ajoutez simplement:

greeter-show-remote-login=false

vers /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf

avec votre disable guest line

Plus besoin de compliquer une solution très simple en créant des fichiers de configuration supplémentaires en plus du défaut, ce qui ne fera qu'embrouiller le système d'exploitation à un moment où les deux fichiers sont en conflit ou le fichier par défaut est effacé. annulé parce que vous ne les avez pas fait ensemble.

    
réponse donnée expectnothing 22.06.2014 - 19:28
la source

Lire d'autres questions sur les étiquettes