Comment puis-je faire fonctionner le plug-in Java sur Google Chrome?

62

Google a mis à jour son navigateur Chrome vers la version 35. Cette nouvelle version utilise Aura à la place de GTK2 et ne prend plus en charge les plug-ins NPAPI tels que Java (OpenJDK et Oracle). . Les plugins PPAPI comme PepperFlash fonctionnent toujours.

Mon école utilise Google Chrome et les applications Google tous les jours et cela semble être un gros problème pour certains des sites Web éducatifs que nous utilisons. Quelqu'un at-il rencontré une solution ou une solution pour faire fonctionner Java?

Cet article WEB UPD8 confirme que Java ne fonctionne pas .

    
posée HarlemSquirrel 22.05.2014 - 14:02
la source

2 réponses

56

Vous ne pouvez pas utiliser Java sur Chrome 35. C'est à cause de la suppression de l'ancien plug-in NPAPI. J'ai soulevé un rapport de bogue. En attente d'une réponse correcte de la part des développeurs. Le rapport de bogue est ici: lien . Vous pouvez essayer de suivre le fil de discussion pour cette discussion ici: lien

MISE À JOUR On dirait que nous allons rester coincés ici pendant un certain temps. Mon rapport de bogue a été fusionné dans le bogue parent et il a été défini comme ne corrigera pas. La voici: lien

UPDATE2 Une question pertinente a été postée sur Oracle. Pas beaucoup de traction. Vous pouvez commencer une discussion sur ce sujet. Allez ici: lien

À vous tous: Pour que Chrome fonctionne, veuillez passer votre Google Chrome à 34. Vous pouvez télécharger le deb ici: lien . Utilisez ensuite le gestionnaire de paquets synaptic ou utilisez la ligne de commande pour verrouiller les mises à niveau du package google-chrome-stable. Chrome 34 n'a pas de bugs flagrants, vous pouvez donc l'utiliser en toute sécurité pour les 3 prochains mois. J'espère qu'à ce moment, un patch sera ajouté.

    
réponse donnée Ubuntuser 22.05.2014 - 20:38
la source
2

Vous pouvez CAN activer Java sur Chrome, ou au moins activer le plug-in NPAPI pour cela ... temporairement. L'option est en cours de suppression dans Chrome 45. (Actuellement, nous en sommes à 43, l'estimation est septembre 2015.)

Notez que l’activation de NPAPI ne signifie pas nécessairement que l’applet Java fonctionnera ... Je l’ai essayé avec un seul et il ne l’a pas fait. Cela est probablement dû au fait que la dernière version de Java est installée, ce qui verrouille pratiquement tous les accès Web. Ce qui est dommage, car de nombreux services Web Java astucieux ont été créés (tels que lien .)

Dans tous les cas, l'option permettant d'activer NPAPI se trouve en naviguant jusqu'à:

chrome://flags/#enable-npapi

Encore une fois, votre kilométrage peut varier (YMMV.)

    
réponse donnée rdtsc 15.06.2015 - 17:46
la source

Lire d'autres questions sur les étiquettes